Intel-XE Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: "Michał Grzelak" <michal.grzelak@intel.com>
To: intel-gfx@lists.freedesktop.org, intel-xe@lists.freedesktop.org
Cc: "Jani Nikula" <jani.nikula@intel.com>,
	"Michał Grzelak" <michal.grzelak@intel.com>
Subject: [PATCH v5 0/2] match *_PCODE_DATA naming with spec
Date: Fri, 28 Aug 2026 21:09:54 +0200	[thread overview]
Message-ID: <20260828190956.2622350-1-michal.grzelak@intel.com> (raw)

Resend of [1]. Last time I messed up versioning in the changelog:
mentioned change done from v4 to v5, while series was at v4.

BR,
Michał

[1] https://lore.kernel.org/intel-gfx/20260602223640.1375933-1-michal.grzelak@intel.com

---
Changelog:
v4->v5
- clean changelog's versioning

v3->v4
- apply the rename to the read()'s signature as well (Sashiko)
- split i915 changes from xe (Jani)

v2->v3
- resolve conflict from rebase

v1->v2
- rebase onto drm-tip (Jani)

Michał Grzelak (2):
  drm/i915/pcode: rename GEN6_PCODE_DATA to match spec
  drm/xe/pcode: match argument naming with PCODE_DATAx

 drivers/gpu/drm/i915/display/intel_parent.c   |  4 ++--
 drivers/gpu/drm/i915/display/intel_parent.h   |  2 +-
 drivers/gpu/drm/i915/gvt/handlers.c           |  2 +-
 drivers/gpu/drm/i915/i915_reg.h               |  2 +-
 drivers/gpu/drm/i915/intel_gvt_mmio_table.c   |  2 +-
 drivers/gpu/drm/i915/intel_pcode.c            | 14 +++++++-------
 drivers/gpu/drm/i915/intel_pcode.h            |  2 +-
 drivers/gpu/drm/xe/display/xe_display_pcode.c |  4 ++--
 drivers/gpu/drm/xe/xe_pcode.c                 |  4 ++--
 drivers/gpu/drm/xe/xe_pcode.h                 |  2 +-
 include/drm/intel/display_parent_interface.h  |  2 +-
 11 files changed, 20 insertions(+), 20 deletions(-)

-- 
2.45.2


             reply	other threads:[~2026-08-28 19:10 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-28 19:09 Michał Grzelak [this message]
2026-08-28 19:09 ` [PATCH v5 1/2] drm/i915/pcode: rename GEN6_PCODE_DATA to match spec Michał Grzelak
2026-08-28 19:09 ` [PATCH v5 2/2] drm/xe/pcode: match argument naming with PCODE_DATAx Michał Grzelak
2026-08-28 19:17 ` ✓ CI.KUnit: success for match *_PCODE_DATA naming with spec Patchwork
2026-08-28 19:54 ` ✓ Xe.CI.BAT: " Patchwork
2026-08-28 21:05 ` ✓ Xe.CI.FULL: " Patchwork
2026-08-31  9:07 ` [PATCH v5 0/2] " Jani Nikula

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260828190956.2622350-1-michal.grzelak@intel.com \
    --to=michal.grzelak@intel.com \
    --cc=intel-gfx@lists.freedesktop.org \
    --cc=intel-xe@lists.freedesktop.org \
    --cc=jani.nikula@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox