From: sashiko-bot@kernel.org
To: "Jonathan Cavitt" <jonathan.cavitt@intel.com>
Cc: dri-devel@lists.freedesktop.org, intel-xe@lists.freedesktop.org
Subject: Re: [PATCH] drm/xe: Rename xe_vm_fault to drm_xe_vm_fault
Date: Thu, 03 Sep 2026 23:22:25 +0000 [thread overview]
Message-ID: <20260903232225.8E7B71F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260903231632.399765-1-jonathan.cavitt@intel.com>
Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [High] Renaming the exported UAPI structure `xe_vm_fault` breaks userspace source compatibility.
--
commit 718d9f0d7813c0d7b1b78dab4ab5c1afd1f3f75a
Author: Jonathan Cavitt <jonathan.cavitt@intel.com>
drm/xe: Rename xe_vm_fault to drm_xe_vm_fault
This commit renames xe_vm_fault to drm_xe_vm_fault to better align with
uAPI struct naming conventions.
[ ... ]
> diff --git a/include/uapi/drm/xe_drm.h b/include/uapi/drm/xe_drm.h
> index 8c852abcacf0d..89c0dbe227dd7 100644
> --- a/include/uapi/drm/xe_drm.h
> +++ b/include/uapi/drm/xe_drm.h
> @@ -1271,8 +1271,8 @@ struct drm_xe_vm_bind {
> __u64 reserved[2];
> };
>
> -/** struct xe_vm_fault - Describes faults for %DRM_XE_VM_GET_PROPERTY_FAULTS */
> -struct xe_vm_fault {
> +/** struct drm_xe_vm_fault - Describes faults for %DRM_XE_VM_GET_PROPERTY_FAULTS */
> +struct drm_xe_vm_fault {
[Severity: High]
Does renaming this exported UAPI structure break userspace source
compatibility?
Userspace applications that rely on struct xe_vm_fault will fail to compile
when updating their kernel headers and attempting to use the old struct
xe_vm_fault name.
Should a backward-compatible alias be provided for the old name?
> /** @address: Canonical address of the fault */
> __u64 address;
> /** @address_precision: Precision of faulted address */
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260903231632.399765-1-jonathan.cavitt@intel.com?part=1
next prev parent reply other threads:[~2026-09-03 23:22 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-03 23:16 [PATCH] drm/xe: Rename xe_vm_fault to drm_xe_vm_fault Jonathan Cavitt
2026-09-03 23:22 ` sashiko-bot [this message]
2026-09-03 23:24 ` ✓ CI.KUnit: success for " Patchwork
2026-09-04 0:09 ` ✓ Xe.CI.BAT: " Patchwork
2026-09-04 0:16 ` [PATCH] " Matthew Brost
2026-09-04 13:26 ` ✗ Xe.CI.FULL: failure for " Patchwork
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260903232225.8E7B71F000E9@smtp.kernel.org \
--to=sashiko-bot@kernel.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=intel-xe@lists.freedesktop.org \
--cc=jonathan.cavitt@intel.com \
--cc=sashiko-reviews@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox