From mboxrd@z Thu Jan 1 00:00:00 1970 From: Stephan =?ISO-8859-1?Q?M=FCller?= Date: Mon, 14 Jan 2019 09:31:53 +0000 Subject: Re: [PATCH 2/6] crypto: kdf - SP800-108 Key Derivation Function Message-Id: <1573163.Xcg6e5WDL9@positron.chronox.de> MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit List-Id: References: <20190103143227.9138-1-jlee@suse.com> <1830918.5I3Y3k8tQf@positron.chronox.de> <20190112052758.GD639@sol.localdomain> In-Reply-To: <20190112052758.GD639@sol.localdomain> To: Eric Biggers Cc: Herbert Xu , James Bottomley , Andy Lutomirski , "Lee, Chun-Yi" , "Rafael J . Wysocki" , Pavel Machek , linux-kernel@vger.kernel.org, linux-pm@vger.kernel.org, keyrings@vger.kernel.org, "Rafael J. Wysocki" , Chen Yu , Oliver Neukum , Ryan Chen , David Howells , Giovanni Gherdovich , Randy Dunlap , Jann Horn , Andy Lutomirski , linux-crypto@vger.kernel.org Am Samstag, 12. Januar 2019, 06:27:59 CET schrieb Eric Biggers: Hi Eric, [...] > > > > +obj-$(CONFIG_CRYPTO_KDF) += kdf.o > > This naming is too generic. CONFIG_CRYPTO_KDF and kdf.c imply that this is > related to all KDFs. But actually it is an implementation of a few specific > KDFs. Can you give it a clearer name, like KDF_SP800? > I am going to use kdf_sp800108 or CRYPTO_CONFIG_KDF_SP800108. The reason is that there are many SP800 documents. Thanks Ciao Stephan