From mboxrd@z Thu Jan 1 00:00:00 1970 From: David Howells Date: Wed, 18 Mar 2020 15:14:24 +0000 Subject: Re: [PATCH v4 4/4] KEYS: Avoid false positive ENOMEM error on key read Message-Id: <2866042.1584544464@warthog.procyon.org.uk> MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit List-Id: References: <20200317194140.6031-5-longman@redhat.com> <20200317194140.6031-1-longman@redhat.com> <2832139.1584520054@warthog.procyon.org.uk> In-Reply-To: To: Waiman Long Cc: dhowells@redhat.com, Jarkko Sakkinen , James Morris , "Serge E. Hallyn" , Mimi Zohar , "David S. Miller" , Jakub Kicinski , keyrings@vger.kernel.org, linux-kernel@vger.kernel.org, linux-security-module@vger.kernel.org, linux-integrity@vger.kernel.org, netdev@vger.kernel.org, linux-afs@lists.infradead.org, Sumit Garg , Jerry Snitselaar , Roberto Sassu , Eric Biggers , Chris von Recklinghausen Waiman Long wrote: > Doing this is micro-optimization. As the keys subsystem is that > performance critical, do we need to do that to save a cycle or two while > making the code a bit harder to read? It was more sort of a musing comment. Feel free to ignore it. kvfree() doesn't do this. David