Kernel keyring development
 help / color / mirror / Atom feed
 messages from 2019-03-26 12:58:34 to 2019-05-08 14:44:22 UTC [more...]

[PATCH, RFC 00/62] Intel MKTME enabling
 2019-05-08 14:44 UTC  (63+ messages)
` [PATCH, RFC 01/62] mm: Do no merge VMAs with different encryption KeyIDs
` [PATCH, RFC 02/62] mm: Add helpers to setup zero page mappings
` [PATCH, RFC 03/62] mm/ksm: Do not merge pages with different KeyIDs
` [PATCH, RFC 04/62] mm/page_alloc: Unify alloc_hugepage_vma()
` [PATCH, RFC 05/62] mm/page_alloc: Handle allocation for encrypted memory
` [PATCH, RFC 06/62] mm/khugepaged: Handle encrypted pages
` [PATCH, RFC 07/62] x86/mm: Mask out KeyID bits from page table entry pfn
` [PATCH, RFC 08/62] x86/mm: Introduce variables to store number, shift and mask of KeyIDs
` [PATCH, RFC 09/62] x86/mm: Preserve KeyID on pte_modify() and pgprot_modify()
` [PATCH, RFC 10/62] x86/mm: Detect MKTME early
` [PATCH, RFC 11/62] x86/mm: Add a helper to retrieve KeyID for a page
` [PATCH, RFC 12/62] x86/mm: Add a helper to retrieve KeyID for a VMA
` [PATCH, RFC 13/62] x86/mm: Add hooks to allocate and free encrypted pages
` [PATCH, RFC 14/62] x86/mm: Map zero pages into encrypted mappings correctly
` [PATCH, RFC 15/62] x86/mm: Rename CONFIG_RANDOMIZE_MEMORY_PHYSICAL_PADDING
` [PATCH, RFC 16/62] x86/mm: Allow to disable MKTME after enumeration
` [PATCH, RFC 17/62] x86/mm: Calculate direct mapping size
` [PATCH, RFC 18/62] x86/mm: Implement syncing per-KeyID direct mappings
` [PATCH, RFC 19/62] x86/mm: Handle encrypted memory in page_to_virt() and __pa()
` [PATCH, RFC 20/62] mm/page_ext: Export lookup_page_ext() symbol
` [PATCH, RFC 21/62] mm/rmap: Clear vma->anon_vma on unlink_anon_vmas()
` [PATCH, RFC 22/62] x86/pconfig: Set a valid encryption algorithm for all MKTME commands
` [PATCH, RFC 23/62] keys/mktme: Introduce a Kernel Key Service for MKTME
` [PATCH, RFC 24/62] keys/mktme: Preparse the MKTME key payload
` [PATCH, RFC 25/62] keys/mktme: Instantiate and destroy MKTME keys
` [PATCH, RFC 26/62] keys/mktme: Move the MKTME payload into a cache aligned structure
` [PATCH, RFC 27/62] keys/mktme: Strengthen the entropy of CPU generated MKTME keys
` [PATCH, RFC 28/62] keys/mktme: Set up PCONFIG programming targets for "
` [PATCH, RFC 29/62] keys/mktme: Program MKTME keys into the platform hardware
` [PATCH, RFC 30/62] keys/mktme: Set up a percpu_ref_count for MKTME keys
` [PATCH, RFC 31/62] keys/mktme: Require CAP_SYS_RESOURCE capability "
` [PATCH, RFC 32/62] keys/mktme: Store MKTME payloads if cmdline parameter allows
` [PATCH, RFC 33/62] acpi: Remove __init from acpi table parsing functions
` [PATCH, RFC 34/62] acpi/hmat: Determine existence of an ACPI HMAT
` [PATCH, RFC 35/62] keys/mktme: Require ACPI HMAT to register the MKTME Key Service
` [PATCH, RFC 36/62] acpi/hmat: Evaluate topology presented in ACPI HMAT for MKTME
` [PATCH, RFC 37/62] keys/mktme: Do not allow key creation in unsafe topologies
` [PATCH, RFC 38/62] keys/mktme: Support CPU hotplug for MKTME key service
` [PATCH, RFC 39/62] keys/mktme: Find new PCONFIG targets during memory hotplug
` [PATCH, RFC 40/62] keys/mktme: Program new PCONFIG targets with MKTME keys
` [PATCH, RFC 41/62] keys/mktme: Support memory hotplug for "
` [PATCH, RFC 42/62] mm: Generalize the mprotect implementation to support extensions
` [PATCH, RFC 43/62] syscall/x86: Wire up a system call for MKTME encryption keys
` [PATCH, RFC 44/62] x86/mm: Set KeyIDs in encrypted VMAs for MKTME
` [PATCH, RFC 45/62] mm: Add the encrypt_mprotect() system call "
` [PATCH, RFC 46/62] x86/mm: Keep reference counts on encrypted VMAs "
` [PATCH, RFC 47/62] mm: Restrict MKTME memory encryption to anonymous VMAs
` [PATCH, RFC 48/62] selftests/x86/mktme: Test the MKTME APIs
` [PATCH, RFC 49/62] mm, x86: export several MKTME variables
` [PATCH, RFC 50/62] kvm, x86, mmu: setup MKTME keyID to spte for given PFN
` [PATCH, RFC 51/62] iommu/vt-d: Support MKTME in DMA remapping
` [PATCH, RFC 52/62] x86/mm: introduce common code for mem encryption
` [PATCH, RFC 53/62] x86/mm: Use common code for DMA memory encryption
` [PATCH, RFC 54/62] x86/mm: Disable MKTME on incompatible platform configurations
` [PATCH, RFC 55/62] x86/mm: Disable MKTME if not all system memory supports encryption
` [PATCH, RFC 56/62] x86: Introduce CONFIG_X86_INTEL_MKTME
` [PATCH, RFC 57/62] x86/mktme: Overview of Multi-Key Total Memory Encryption
` [PATCH, RFC 58/62] x86/mktme: Document the MKTME provided security mitigations
` [PATCH, RFC 59/62] x86/mktme: Document the MKTME kernel configuration requirements
` [PATCH, RFC 60/62] x86/mktme: Document the MKTME Key Service API
` [PATCH, RFC 61/62] x86/mktme: Document the MKTME API for anonymous memory encryption
` [PATCH, RFC 62/62] x86/mktme: Demonstration program using the MKTME APIs

[PATCH] X.509: Add messages for obsolete OIDs
 2019-05-02  4:12 UTC 

[GIT PULL] keys: Namespacing
 2019-05-01 17:18 UTC  (3+ messages)

[PATCH 00/11] keys: Namespacing [ver #2]
 2019-04-30 15:08 UTC  (12+ messages)
` [PATCH 01/11] keys: Invalidate used request_key authentication keys "
` [PATCH 02/11] keys: Kill off request_key_async{, _with_auxdata} "
` [PATCH 03/11] keys: Simplify key description management "
` [PATCH 04/11] keys: Cache the hash value to avoid lots of recalculation "
` [PATCH 05/11] keys: Add a 'recurse' flag for keyring searches "
` [PATCH 06/11] keys: Namespace keyring names "
` [PATCH 07/11] keys: Move the user and user-session keyrings to the user_namespace "
` [PATCH 08/11] keys: Include target namespace in match criteria "
` [PATCH 09/11] keys: Garbage collect keys for which the domain has been removed "
` [PATCH 10/11] keys: Network namespace domain tag "
` [PATCH 11/11] keys: Pass the network namespace into request_key mechanism "

[PATCH AUTOSEL 5.0 52/79] KEYS: trusted: fix -Wvarags warning
 2019-04-27  1:38 UTC 

[PATCH v2] KEYS: Make use of platform keyring for module signature verify
 2019-04-25 19:46 UTC  (5+ messages)

[PATCH 00/11] keys: Namespacing
 2019-04-25 11:38 UTC  (18+ messages)
` [PATCH 01/11] keys: Invalidate used request_key authentication keys
` [PATCH 02/11] keys: Kill off request_key_async{,_with_auxdata}
` [PATCH 03/11] keys: Simplify key description management
` [PATCH 04/11] keys: Cache the hash value to avoid lots of recalculation
` [PATCH 05/11] keys: Add a 'recurse' flag for keyring searches
` [PATCH 06/11] keys: Namespace keyring names
` [PATCH 07/11] keys: Move the user and user-session keyrings to the user_namespace
` [PATCH 08/11] keys: Include target namespace in match criteria
` [PATCH 09/11] keys: Garbage collect keys for which the domain has been removed
` [PATCH 10/11] keys: Network namespace domain tag
` [PATCH 11/11] keys: Pass the network namespace into request_key mechanism

Dear
 2019-04-19 17:32 UTC 

[PATCH v5 00/16] fscrypt: key management improvements
 2019-04-18 23:29 UTC  (17+ messages)
` [PATCH v5 01/16] fs, fscrypt: move uapi definitions to new header <linux/fscrypt.h>
` [PATCH v5 02/16] fscrypt: use FSCRYPT_ prefix for uapi constants
` [PATCH v5 03/16] fscrypt: use FSCRYPT_* definitions, not FS_*
` [PATCH v5 04/16] fscrypt: add ->ci_inode to fscrypt_info
` [PATCH v5 05/16] fscrypt: refactor v1 policy key setup into keysetup_legacy.c
` [PATCH v5 06/16] fscrypt: add FS_IOC_ADD_ENCRYPTION_KEY ioctl
` [PATCH v5 07/16] fscrypt: add FS_IOC_REMOVE_ENCRYPTION_KEY ioctl
` [PATCH v5 08/16] fscrypt: add FS_IOC_GET_ENCRYPTION_KEY_STATUS ioctl
` [PATCH v5 09/16] fscrypt: add an HKDF-SHA512 implementation
` [PATCH v5 10/16] fscrypt: v2 encryption policy support
` [PATCH v5 11/16] fscrypt: allow unprivileged users to add/remove keys for v2 policies
` [PATCH v5 12/16] fscrypt: require that key be added when setting a v2 encryption policy
` [PATCH v5 13/16] ext4: wire up new fscrypt ioctls
` [PATCH v5 14/16] f2fs: "
` [PATCH v5 15/16] ubifs: "
` [PATCH v5 16/16] fscrypt: document the new ioctls and policy version

[PATCH v9 00/10] crypto: add EC-RDSA (GOST 34.10) algorithm
 2019-04-18 14:25 UTC  (13+ messages)
` [PATCH v9 01/10] crypto: akcipher - default implementations for request callbacks
` [PATCH v9 02/10] crypto: rsa - unimplement sign/verify for raw RSA backends
` [PATCH v9 03/10] crypto: akcipher - new verify API for public key algorithms
` [PATCH v9 04/10] KEYS: do not kmemdup digest in {public,tpm}_key_verify_signature
` [PATCH v9 05/10] X.509: parse public key parameters from x509 for akcipher
` [PATCH v9 06/10] crypto: Kconfig - create Public-key cryptography section
` [PATCH v9 07/10] crypto: ecc - make ecc into separate module
` [PATCH v9 08/10] crypto: ecrdsa - add EC-RDSA (GOST 34.10) algorithm
` [PATCH v9 09/10] crypto: ecrdsa - add EC-RDSA test vectors to testmgr
` [PATCH v9 10/10] integrity: support EC-RDSA signatures for asymmetric_verify

[PATCH v10 00/12] Appended signatures support for IMA appraisal
 2019-04-18  3:51 UTC  (13+ messages)
` [PATCH v10 01/12] MODSIGN: Export module signature definitions
` [PATCH v10 02/12] PKCS#7: Refactor verify_pkcs7_signature()
` [PATCH v10 03/12] PKCS#7: Introduce pkcs7_get_digest()
` [PATCH v10 04/12] integrity: Introduce struct evm_xattr
` [PATCH v10 05/12] integrity: Select CONFIG_KEYS instead of depending on it
` [PATCH v10 06/12] ima: Use designated initializers for struct ima_event_data
` [PATCH v10 07/12] ima: Add modsig appraise_type option for module-style appended signatures
` [PATCH v10 08/12] ima: Factor xattr_verify() out of ima_appraise_measurement()
` [PATCH v10 09/12] ima: Implement support for module-style appended signatures
` [PATCH v10 10/12] ima: Collect modsig
` [PATCH v10 11/12] ima: Define ima-modsig template
` [PATCH v10 12/12] ima: Store the measurement again when appraising a modsig

[PATCH v2] MAINTAINERS: fix style in KEYS-TRUSTED entry
 2019-04-15  7:46 UTC  (2+ messages)

ATTENTION:BENEFICIARY
 2019-04-12  8:02 UTC 

Zdravstvujte Vas interesuyut klientskie bazy dannyh?
 2019-04-11  4:34 UTC 

[PATCH] keys: safe concurrent user->{session,uid}_keyring access
 2019-04-10 17:31 UTC  (2+ messages)

[PATCH] security: don't use RCU accessors for cred->session_keyring
 2019-04-10 17:29 UTC  (2+ messages)

[PATCH v4 00/17] fscrypt: key management improvements
 2019-04-03 20:36 UTC  (20+ messages)
` [PATCH v4 01/17] fs, fscrypt: move uapi definitions to new header <linux/fscrypt.h>
` [PATCH v4 02/17] fscrypt: use FSCRYPT_ prefix for uapi constants
` [PATCH v4 03/17] fscrypt: use FSCRYPT_* definitions, not FS_*
` [PATCH v4 04/17] fscrypt: add ->ci_inode to fscrypt_info
` [PATCH v4 05/17] fscrypt: refactor v1 policy key setup into keysetup_legacy.c
` [PATCH v4 06/17] fscrypt: add FS_IOC_ADD_ENCRYPTION_KEY ioctl
` [PATCH v4 07/17] fs/dcache.c: add shrink_dcache_inode()
` [PATCH v4 08/17] fscrypt: add FS_IOC_REMOVE_ENCRYPTION_KEY ioctl
` [PATCH v4 09/17] fscrypt: add FS_IOC_GET_ENCRYPTION_KEY_STATUS ioctl
` [PATCH v4 10/17] fscrypt: add an HKDF-SHA512 implementation
` [PATCH v4 11/17] fscrypt: v2 encryption policy support
` [PATCH v4 12/17] fscrypt: allow unprivileged users to add/remove keys for v2 policies
` [PATCH v4 13/17] fscrypt: require that key be added when setting a v2 encryption policy
` [PATCH v4 14/17] ext4: wire up new fscrypt ioctls
` [PATCH v4 15/17] f2fs: "
` [PATCH v4 16/17] ubifs: "
` [PATCH v4 17/17] fscrypt: document the new ioctls and policy version

[PATCH] KEYS: asym_tpm: move setting set_pub_key parameters into derive_pub_key
 2019-03-31 14:46 UTC 

[PATCH] X.509: Add messages for obsolete OIDs
 2019-03-29 17:47 UTC  (3+ messages)

[PATCH v3] KEYS: trusted: allow trusted.ko to initialize w/o a TPM
 2019-03-28 12:27 UTC  (3+ messages)

[PATCH v8 00/10] crypto: add EC-RDSA (GOST 34.10) algorithm
 2019-03-28  6:16 UTC  (16+ messages)
` [PATCH v8 02/10] crypto: rsa - unimplement sign/verify for raw RSA backends
` [PATCH v8 03/10] crypto: akcipher - new verify API for public key algorithms
` [PATCH v8 04/10] KEYS: do not kmemdup digest in {public,tpm}_key_verify_signature
` [PATCH v8 05/10] X.509: parse public key parameters from x509 for akcipher
` [PATCH v8 06/10] crypto: Kconfig - create Public-key cryptography section
` [PATCH v8 07/10] crypto: ecc - make ecc into separate module
` [PATCH v8 08/10] crypto: ecrdsa - add EC-RDSA (GOST 34.10) algorithm
` [PATCH v8 09/10] crypto: ecrdsa - add EC-RDSA test vectors to testmgr
` [PATCH v8 10/10] integrity: support EC-RDSA signatures for asymmetric_verify

Bad file pattern in MAINTAINERS section 'KEYS-TRUSTED'
 2019-03-27  4:58 UTC  (8+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox