From mboxrd@z Thu Jan 1 00:00:00 1970 From: Shenlin Liang Date: Thu, 11 Apr 2024 15:24:09 +0800 (GMT+08:00) Subject: [PATCH 1/2] RISCV: KVM: add tracepoints for entry and exit events In-Reply-To: <40a8d9d3-20a8-44e8-96d2-0dcd8627cfc8@gmail.com> References: <20240328031220.1287-1-liangshenlin@eswincomputing.com> <20240328031220.1287-2-liangshenlin@eswincomputing.com> <40a8d9d3-20a8-44e8-96d2-0dcd8627cfc8@gmail.com> Message-ID: <607ba9f5.2876.18ecc0ae30d.Coremail.liangshenlin@eswincomputing.com> List-Id: To: kvm-riscv@lists.infradead.org MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit On 2024-04-10 15:12, Eric Cheng wrote: > > On 3/28/2024 11:12 AM, Shenlin Liang wrote: > > Like other architectures, RISCV KVM also needs to add these event > > tracepoints to count the number of times kvm guest entry/exit. > > > > Signed-off-by: Shenlin Liang > > --- > > arch/riscv/kvm/trace_riscv.h | 60 ++++++++++++++++++++++++++++++++++++ > > Conventionally, it should be named to trace.h, especially if only one. Refer to > other arch's. Thank you for the review. I will send the v2 version.