KVM-RISCV Archive on lore.kernel.org
 help / color / mirror / Atom feed
 messages from 2024-04-11 00:07:33 to 2024-04-22 11:19:36 UTC [more...]

[PATCH v2 00/12] Add support for a few Zc* extensions as well as Zcmop
 2024-04-22 11:19 UTC  (28+ messages)
` [PATCH v2 01/12] dt-bindings: riscv: add Zca, Zcf, Zcd and Zcb ISA extension description
` [PATCH v2 02/12] riscv: dts: enable Zc* extensions when needed
` [PATCH v2 03/12] dt-bindings: riscv: add Zc* extension rules implied by C extension
` [PATCH v2 04/12] riscv: add ISA parsing for Zca, Zcf, Zcd and Zcb
` [PATCH v2 05/12] riscv: hwprobe: export Zca, Zcf, Zcd and Zcb ISA extensions
` [PATCH v2 06/12] RISC-V: KVM: Allow Zca, Zcf, Zcd and Zcb extensions for Guest/VM
` [PATCH v2 07/12] KVM: riscv: selftests: Add some Zc* extensions to get-reg-list test
` [PATCH v2 08/12] dt-bindings: riscv: add Zcmop ISA extension description
` [PATCH v2 09/12] riscv: add ISA extension parsing for Zcmop
` [PATCH v2 10/12] riscv: hwprobe: export Zcmop ISA extension
` [PATCH v2 11/12] RISC-V: KVM: Allow Zcmop extension for Guest/VM
` [PATCH v2 12/12] KVM: riscv: selftests: Add Zcmop extension to get-reg-list test

[PATCH v8 00/24] RISC-V SBI v2.0 PMU improvements and Perf sampling in KVM guest
 2024-04-22  9:59 UTC  (33+ messages)
` [PATCH v8 01/24] RISC-V: Fix the typo in Scountovf CSR name
` [PATCH v8 02/24] RISC-V: Add FIRMWARE_READ_HI definition
` [PATCH v8 03/24] drivers/perf: riscv: Read upper bits of a firmware counter
` [PATCH v8 04/24] drivers/perf: riscv: Use BIT macro for shifting operations
` [PATCH v8 05/24] RISC-V: Add SBI PMU snapshot definitions
` [PATCH v8 06/24] RISC-V: KVM: Rename the SBI_STA_SHMEM_DISABLE to a generic name
` [PATCH v8 07/24] RISC-V: Use the minor version mask while computing sbi version
` [PATCH v8 08/24] drivers/perf: riscv: Fix counter mask iteration for RV32
` [PATCH v8 09/24] drivers/perf: riscv: Implement SBI PMU snapshot function
` [PATCH v8 10/24] RISC-V: KVM: Fix the initial sample period value
` [PATCH v8 11/24] RISC-V: KVM: No need to update the counter value during reset
` [PATCH v8 12/24] RISC-V: KVM: No need to exit to the user space if perf event failed
` [PATCH v8 13/24] RISC-V: KVM: Implement SBI PMU Snapshot feature
` [PATCH v8 14/24] RISC-V: KVM: Add perf sampling support for guests
` [PATCH v8 15/24] RISC-V: KVM: Support 64 bit firmware counters on RV32
` [PATCH v8 16/24] RISC-V: KVM: Improve firmware counter read function
` [PATCH v8 17/24] KVM: riscv: selftests: Move sbi definitions to its own header file
` [PATCH v8 18/24] KVM: riscv: selftests: Add helper functions for extension checks
` [PATCH v8 19/24] KVM: riscv: selftests: Add Sscofpmf to get-reg-list test
` [PATCH v8 20/24] KVM: riscv: selftests: Add SBI PMU extension definitions
` [PATCH v8 21/24] KVM: riscv: selftests: Add SBI PMU selftest
` [PATCH v8 22/24] KVM: riscv: selftests: Add a test for PMU snapshot functionality
` [PATCH v8 23/24] KVM: riscv: selftests: Add a test for counter overflow
` [PATCH v8 24/24] KVM: riscv: selftests: Add commandline option for SBI PMU test

[PATCH v2 0/6] riscv: Apply Zawrs when available
 2024-04-22  8:36 UTC  (15+ messages)
` [PATCH v2 1/6] riscv: Provide a definition for 'pause'
` [PATCH v2 2/6] dt-bindings: riscv: Add Zawrs ISA extension description
` [PATCH v2 3/6] riscv: Add Zawrs support for spinlocks
` [PATCH v2 4/6] riscv: hwprobe: export Zawrs ISA extension
` [PATCH v2 5/6] KVM: riscv: Support guest wrs.nto
` [PATCH v2 6/6] KVM: riscv: selftests: Add Zawrs extension to get-reg-list test

[PATCH v2 0/2] perf kvm: Add kvm stat support on riscv
 2024-04-22  8:27 UTC  (7+ messages)
` [PATCH v2 1/2] RISCV: KVM: add tracepoints for entry and exit events
` [PATCH v2 2/2] perf kvm/riscv: Port perf kvm stat to RISC-V

[PATCH v3 0/2] perf kvm: Add kvm stat support on riscv
 2024-04-22  8:08 UTC  (3+ messages)
` [PATCH v3 1/2] RISCV: KVM: add tracepoints for entry and exit events
` [PATCH v3 2/2] perf kvm/riscv: Port perf kvm stat to RISC-V

[PATCH v2 0/2] RISCV: KVM: Avoid lock inversion in SBI_EXT_HSM_HART_START
 2024-04-22  5:13 UTC  (6+ messages)
` [PATCH v2 1/2] RISCV: KVM: Introduce mp_state_lock to avoid "
` [PATCH v2 2/2] RISCV: KVM: Introduce vcpu->reset_cntx_lock

[PATCH v7 00/24] RISC-V SBI v2.0 PMU improvements and Perf sampling in KVM guest
 2024-04-19 23:42 UTC  (30+ messages)
` [PATCH v7 01/24] RISC-V: Fix the typo in Scountovf CSR name
` [PATCH v7 02/24] RISC-V: Add FIRMWARE_READ_HI definition
` [PATCH v7 03/24] drivers/perf: riscv: Read upper bits of a firmware counter
` [PATCH v7 04/24] drivers/perf: riscv: Use BIT macro for shifting operations
` [PATCH v7 05/24] RISC-V: Add SBI PMU snapshot definitions
` [PATCH v7 06/24] RISC-V: KVM: Rename the SBI_STA_SHMEM_DISABLE to a generic name
` [PATCH v7 07/24] RISC-V: Use the minor version mask while computing sbi version
` [PATCH v7 08/24] drivers/perf: riscv: Implement SBI PMU snapshot function
` [PATCH v7 09/24] drivers/perf: riscv: Fix counter mask iteration for RV32
` [PATCH v7 10/24] RISC-V: KVM: Fix the initial sample period value
` [PATCH v7 11/24] RISC-V: KVM: No need to update the counter value during reset
` [PATCH v7 12/24] RISC-V: KVM: No need to exit to the user space if perf event failed
` [PATCH v7 13/24] RISC-V: KVM: Implement SBI PMU Snapshot feature
` [PATCH v7 14/24] RISC-V: KVM: Add perf sampling support for guests
` [PATCH v7 15/24] RISC-V: KVM: Support 64 bit firmware counters on RV32
` [PATCH v7 16/24] RISC-V: KVM: Improve firmware counter read function
` [PATCH v7 17/24] KVM: riscv: selftests: Move sbi definitions to its own header file
` [PATCH v7 18/24] KVM: riscv: selftests: Add helper functions for extension checks
` [PATCH v7 19/24] KVM: riscv: selftests: Add Sscofpmf to get-reg-list test
` [PATCH v7 20/24] KVM: riscv: selftests: Add SBI PMU extension definitions
` [PATCH v7 21/24] KVM: riscv: selftests: Add SBI PMU selftest
` [PATCH v7 22/24] KVM: riscv: selftests: Add a test for PMU snapshot functionality
` [PATCH v7 23/24] KVM: riscv: selftests: Add a test for counter overflow
` [PATCH v7 24/24] KVM: riscv: selftests: Add commandline option for SBI PMU test

[PATCH 0/4] KVM, mm: remove the .change_pte() MMU notifier and set_pte_at_notify()
 2024-04-19 13:58 UTC  (18+ messages)
` [PATCH 1/4] KVM: delete .change_pte MMU notifier callback

[RFC PATCH 0/7] riscv: Add support for Ssdbltrp extension
 2024-04-18 14:26 UTC  (8+ messages)
` [RFC PATCH 1/7] riscv: kvm: add support for FWFT SBI extension
` [RFC PATCH 2/7] dt-bindings: riscv: add Ssdbltrp ISA extension description
` [RFC PATCH 3/7] riscv: add Ssdbltrp ISA extension parsing
` [RFC PATCH 4/7] riscv: handle Ssdbltrp mstatus SDT bit
` [RFC PATCH 5/7] riscv: add double trap driver
` [RFC PATCH 6/7] riscv: kvm: add SBI FWFT support for SBI_FWFT_DOUBLE_TRAP_ENABLE
` [RFC PATCH 7/7] RISC-V: KVM: add support for double trap exception

[PATCH 00/10] Add support for a few Zc* extensions as well as Zcmop
 2024-04-17 13:11 UTC  (14+ messages)
` [PATCH 07/10] riscv: add ISA extension parsing for Zcmop

[RFC kvm-unit-tests PATCH v2 00/14] add shellcheck support
 2024-04-17  1:40 UTC  (8+ messages)
` [RFC kvm-unit-tests PATCH v2 01/14] Add initial shellcheck checking

Very Urgent Reply!!!!
 2024-04-16 21:54 UTC 

[PATCH v6 00/24] RISC-V SBI v2.0 PMU improvements and Perf sampling in KVM guest
 2024-04-16  8:49 UTC  (35+ messages)
` [PATCH v6 01/24] RISC-V: Fix the typo in Scountovf CSR name
` [PATCH v6 05/24] RISC-V: Add SBI PMU snapshot definitions
` [PATCH v6 06/24] RISC-V: KVM: Rename the SBI_STA_SHMEM_DISABLE to a generic name
` [PATCH v6 07/24] RISC-V: Use the minor version mask while computing sbi version
` [PATCH v6 08/24] drivers/perf: riscv: Implement SBI PMU snapshot function
` [PATCH v6 09/24] drivers/perf: riscv: Fix counter mask iteration for RV32
` [PATCH v6 10/24] RISC-V: KVM: Fix the initial sample period value
` [PATCH v6 11/24] RISC-V: KVM: No need to update the counter value during reset
` [PATCH v6 12/24] RISC-V: KVM: No need to exit to the user space if perf event failed
` [PATCH v6 13/24] RISC-V: KVM: Implement SBI PMU Snapshot feature
` [PATCH v6 14/24] RISC-V: KVM: Add perf sampling support for guests
` [PATCH v6 15/24] RISC-V: KVM: Support 64 bit firmware counters on RV32
` [PATCH v6 16/24] RISC-V: KVM: Improve firmware counter read function
` [PATCH v6 17/24] KVM: riscv: selftests: Move sbi definitions to its own header file
` [PATCH v6 18/24] KVM: riscv: selftests: Add helper functions for extension checks
` [PATCH v6 19/24] KVM: riscv: selftests: Add Sscofpmf to get-reg-list test
` [PATCH v6 20/24] KVM: riscv: selftests: Add SBI PMU extension definitions
` [PATCH v6 21/24] KVM: riscv: selftests: Add SBI PMU selftest
` [PATCH v6 22/24] KVM: riscv: selftests: Add a test for PMU snapshot functionality
` [PATCH v6 23/24] KVM: riscv: selftests: Add a test for counter overflow
` [PATCH v6 24/24] KVM: riscv: selftests: Add commandline option for SBI PMU test

[PATCH 1/1] RISC-V: KVM: No need to use mask when hart-index-bit is 0
 2024-04-15  6:49 UTC 

[PATCH 0/2] KVM RISC-V HW IMSIC guest files
 2024-04-11  9:06 UTC  (3+ messages)
` [PATCH 1/2] RISC-V: KVM: Share APLIC and IMSIC defines with irqchip drivers
` [PATCH 2/2] RISC-V: KVM: Use IMSIC guest files when available

[PATCH v5 00/22] RISC-V SBI v2.0 PMU improvements and Perf sampling in KVM guest
 2024-04-11  7:45 UTC  (5+ messages)
` [PATCH v5 06/22] drivers/perf: riscv: Implement SBI PMU snapshot function

[PATCH v4 00/15] RISC-V SBI v2.0 PMU improvements and Perf sampling in KVM guest
 2024-04-11  7:38 UTC  (7+ messages)
` [PATCH v4 07/15] RISC-V: KVM: No need to exit to the user space if perf event failed

[PATCH 0/2] perf kvm: Add kvm stat support on riscv
 2024-04-11  7:24 UTC  (6+ messages)
` [PATCH 1/2] RISCV: KVM: add tracepoints for entry and exit events


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox