Kernel KVM virtualization development
 help / color / mirror / Atom feed
From: Mark McLoughlin <markmc@redhat.com>
To: "Han, Weidong" <weidong.han@intel.com>
Cc: "'Avi Kivity'" <avi@redhat.com>,
	"kvm@vger.kernel.org" <kvm@vger.kernel.org>
Subject: Re: [PATCH 1/4] kvm: qemu: Remove the useless parameter of assigned_dev_update_irq
Date: Wed, 10 Dec 2008 10:11:29 +0000	[thread overview]
Message-ID: <1228903889.5384.30.camel@blaa> (raw)
In-Reply-To: <715D42877B251141A38726ABF5CABF2C018BF9ACDF@pdsmsx503.ccr.corp.intel.com>

On Wed, 2008-12-10 at 17:44 +0800, Han, Weidong wrote:
> Should pass &assigned_dev->dev to ipf_map_irq in while loop.
> 
> Signed-off-by: Weidong Han <weidong.han@intel.com>
> ---
>  qemu/hw/device-assignment.c |    4 ++--
>  qemu/hw/pci.c               |    4 ++--
>  2 files changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/qemu/hw/device-assignment.c b/qemu/hw/device-assignment.c
> index 4a38a22..7240158 100644
> --- a/qemu/hw/device-assignment.c
> +++ b/qemu/hw/device-assignment.c
> @@ -491,7 +491,7 @@ static uint32_t calc_assigned_dev_id(uint8_t bus, uint8_t devfn)
>  /* The pci config space got updated. Check if irq numbers have changed
>   * for our devices
>   */
> -void assigned_dev_update_irq(PCIDevice *d)
> +void assigned_dev_update_irq()

Yes, but perhaps also rename to update_assigned_device_irqs() ?

(i.e. the current name implies that it's an operation on a single
assigned device, rather than an operation on all assigned devices)

Cheers,
Mark.


  reply	other threads:[~2008-12-10 10:12 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-12-10  9:44 [PATCH 1/4] kvm: qemu: Remove the useless parameter of assigned_dev_update_irq Han, Weidong
2008-12-10 10:11 ` Mark McLoughlin [this message]
2008-12-10 10:21   ` Han, Weidong

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1228903889.5384.30.camel@blaa \
    --to=markmc@redhat.com \
    --cc=avi@redhat.com \
    --cc=kvm@vger.kernel.org \
    --cc=weidong.han@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox