From mboxrd@z Thu Jan 1 00:00:00 1970 From: Takuya Yoshikawa Subject: [PATCH 2/3] KVM: MMU: Rename the walk label in walk_addr_generic() Date: Fri, 1 Jul 2011 01:36:07 +0900 Message-ID: <20110701013607.eea23028.takuya.yoshikawa@gmail.com> References: <20110701013320.977cdfea.takuya.yoshikawa@gmail.com> Mime-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Content-Transfer-Encoding: 7bit Cc: kvm@vger.kernel.org, yoshikawa.takuya@oss.ntt.co.jp, mingo@elte.hu To: avi@redhat.com, mtosatti@redhat.com Return-path: Received: from mail-pz0-f46.google.com ([209.85.210.46]:57879 "EHLO mail-pz0-f46.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752933Ab1F3QgM (ORCPT ); Thu, 30 Jun 2011 12:36:12 -0400 Received: by pzk9 with SMTP id 9so1876849pzk.19 for ; Thu, 30 Jun 2011 09:36:12 -0700 (PDT) In-Reply-To: <20110701013320.977cdfea.takuya.yoshikawa@gmail.com> Sender: kvm-owner@vger.kernel.org List-ID: From: Takuya Yoshikawa The current name does not explain the meaning well. So give it a better name "retry_walk" to show that we are trying the walk again. This was suggested by Ingo Molnar. Cc: Ingo Molnar Signed-off-by: Takuya Yoshikawa --- arch/x86/kvm/paging_tmpl.h | 6 +++--- 1 files changed, 3 insertions(+), 3 deletions(-) diff --git a/arch/x86/kvm/paging_tmpl.h b/arch/x86/kvm/paging_tmpl.h index f0746d2..9c0afba 100644 --- a/arch/x86/kvm/paging_tmpl.h +++ b/arch/x86/kvm/paging_tmpl.h @@ -134,7 +134,7 @@ static int FNAME(walk_addr_generic)(struct guest_walker *walker, trace_kvm_mmu_pagetable_walk(addr, write_fault, user_fault, fetch_fault); -walk: +retry_walk: eperm = false; walker->level = mmu->root_level; pte = mmu->get_cr3(vcpu); @@ -211,7 +211,7 @@ walk: if (unlikely(ret < 0)) goto error; else if (ret) - goto walk; + goto retry_walk; mark_page_dirty(vcpu->kvm, table_gfn); pte |= PT_ACCESSED_MASK; @@ -277,7 +277,7 @@ walk: if (unlikely(ret < 0)) goto error; else if (ret) - goto walk; + goto retry_walk; mark_page_dirty(vcpu->kvm, table_gfn); pte |= PT_DIRTY_MASK; -- 1.7.4.1