From mboxrd@z Thu Jan 1 00:00:00 1970 From: Eduardo Habkost Subject: Re: [PATCH v2 0/2] kvm: x86 CPU power management Date: Thu, 14 Jun 2018 13:53:13 -0300 Message-ID: <20180614165313.GT7451@localhost.localdomain> References: <20180612184616.90838-1-mst@redhat.com> <20180614081800.GH6355@redhat.com> <2219a7fd-b496-6653-b79a-c20136727f98@redhat.com> Mime-Version: 1.0 Content-Type: text/plain; charset=iso-8859-1 Content-Transfer-Encoding: quoted-printable Cc: kvm@vger.kernel.org, "Michael S. Tsirkin" , Marcelo Tosatti , qemu-devel@nongnu.org, Richard Henderson To: Paolo Bonzini Return-path: Content-Disposition: inline In-Reply-To: <2219a7fd-b496-6653-b79a-c20136727f98@redhat.com> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: qemu-devel-bounces+gceq-qemu-devel2=m.gmane.org@nongnu.org Sender: "Qemu-devel" List-Id: kvm.vger.kernel.org On Thu, Jun 14, 2018 at 05:40:41PM +0200, Paolo Bonzini wrote: > On 14/06/2018 10:18, Daniel P. Berrang=E9 wrote: > > I don't think > > the -realtime flag should ever have been introduced, and we certainly > > shouldn't add more stuff under it. > >=20 > > "-realtime" is referring to a very specific use case, while the > > properties listed under it are all general purpose features. Real > > time guests just happen to be one possible use case, but it is > > valid to use them for non-real time guests. > >=20 > > IOW, I think we should just have this as an option under -cpu or > > some other *functionally* named option, not a option named after > > a specific usage scenario. >=20 > "-cpu" is certainly wrong for KVM_CAP_X86_DISABLE_EXITS. "-cpu" is a > device option, while this is about host behavior. "-realtime"'s name i= s > awful, but I still think it's the best place for this option. Maybe we > could call it "-realtime power-mgmt=3D{host|guest}". >=20 > A separate issue is whether the same flag should control both > KVM_CAP_X86_DISABLE_EXITS and the monitor/mwait CPUID leaf. Eduardo, > what do you think? Making "-cpu host" be affected by a host-side option is acceptable to me. A "-cpu" option would be more appropriate if we decide to allow monitor/mwait be enabled for other CPU models too. --=20 Eduardo