From: sashiko-bot@kernel.org
To: Dylan.Wu <fredwudi0305@gmail.com>
Cc: kvm@vger.kernel.org
Subject: Re: [PATCH v3 1/3] riscv: ptdump: Create ptdump.h and move declarations
Date: Tue, 28 Jul 2026 16:26:01 +0000 [thread overview]
Message-ID: <20260728162602.0D6C21F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260728161449.190058-2-fredwudi0305@gmail.com>
Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Low] Exporting the generic symbol `note_page` pollutes the kernel's global namespace.
--
--- Patch [1]: [PATCH v3 1/3] riscv: ptdump: Create ptdump.h and move declarations ---
commit f9b97fdc17623863fd64f27ed80770e08d139f2a
Author: Dylan.Wu <fredwudi0305@gmail.com>
riscv: ptdump: Create ptdump.h and move declarations
This commit extracts page table dumping structures and level definitions
into a new header file, arch/riscv/include/asm/ptdump.h. It also exports
the note_page function for use by other kernel components like KVM.
> diff --git a/arch/riscv/mm/ptdump.c b/arch/riscv/mm/ptdump.c
> index f4b4a9fcbbd88..d9a955b8a532d 100644
> --- a/arch/riscv/mm/ptdump.c
> +++ b/arch/riscv/mm/ptdump.c
[ ... ]
> @@ -317,6 +280,7 @@ static void note_page(struct ptdump_state *pt_st, unsigned long addr,
> st->last_pa = pa;
> }
> }
> +EXPORT_SYMBOL_GPL(note_page);
[Severity: Low]
Does exporting this highly generic name (note_page) without an architectural
or subsystem prefix risk build or link collisions?
Since it is now in the global module namespace, should it be renamed with a
prefix like ptdump_ or riscv_ to avoid polluting the global namespace and
adhere to standard kernel naming conventions?
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260728161449.190058-1-fredwudi0305@gmail.com?part=1
next prev parent reply other threads:[~2026-07-28 16:26 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-01 8:50 [PATCH 0/2] riscv: ptdump: Refactor for KVM gstage ptdump support Dylan.Wu
2026-07-01 8:50 ` [PATCH 1/2] riscv: ptdump: Move pagetable definitions to common header Dylan.Wu
2026-07-01 9:01 ` sashiko-bot
2026-07-21 2:58 ` Paul Walmsley
2026-07-27 12:39 ` Dylan.Wu
2026-07-28 16:14 ` [PATCH v3 0/3] RISC-V KVM gstage page table dumper Dylan.Wu
2026-07-28 16:14 ` [PATCH v3 1/3] riscv: ptdump: Create ptdump.h and move declarations Dylan.Wu
2026-07-28 16:26 ` sashiko-bot [this message]
2026-07-28 16:14 ` [PATCH v3 2/3] riscv: ptdump: Use per-level attribute bits for parsing Dylan.Wu
2026-07-28 16:31 ` sashiko-bot
2026-07-28 16:14 ` [PATCH v3 3/3] KVM: riscv: Register ptdump with debugfs on guest creation Dylan.Wu
2026-07-28 16:50 ` sashiko-bot
2026-07-01 8:50 ` [PATCH 2/2] " Dylan.Wu
2026-07-01 9:06 ` sashiko-bot
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260728162602.0D6C21F000E9@smtp.kernel.org \
--to=sashiko-bot@kernel.org \
--cc=fredwudi0305@gmail.com \
--cc=kvm@vger.kernel.org \
--cc=sashiko-reviews@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox