From: sashiko-bot@kernel.org
To: "Steffen Eiden" <seiden@linux.ibm.com>
Cc: "Oliver Upton" <oupton@kernel.org>,
"Alexander Gordeev" <agordeev@linux.ibm.com>,
linux-s390@vger.kernel.org,
"Christian Borntraeger" <borntraeger@linux.ibm.vom>,
"Marc Zyngier" <maz@kernel.org>,
kvmarm@lists.linux.dev, "Vasily Gorbik" <gor@linux.ibm.com>,
"Heiko Carstens" <hca@linux.ibm.com>,
kvm@vger.kernel.org
Subject: Re: [PATCH v6 02/33] KVM: Make device name configurable
Date: Wed, 12 Aug 2026 16:08:29 +0000 [thread overview]
Message-ID: <20260812160829.D28C51F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260812153631.3376090-3-seiden@linux.ibm.com>
Thank you for your contribution! Sashiko AI review found 4 potential issue(s) to consider:
- [High] Calling `kvm_init_with_dev()` multiple times within the same module to support multiple simultaneous KVM implementations corrupts KVM's static singleton state and guarantees list corruption.
- [High] `kvm_init_with_dev` is not exported, making it unusable by independent loadable KVM architecture modules.
- [Medium] The patch fails to parameterize the `kvm_gmem_inode_cache` name, causing a sysfs kmem_cache name collision when multiple KVM implementations are loaded simultaneously.
- [Medium] The patch silently adds the `SLAB_ACCOUNT` flag to the async page fault kmem_cache without justification in the commit message.
--
--- Patch [2]: [PATCH v6 02/33] KVM: Make device name configurable ---
commit fddf3fec3ead355cf194e06551ca60993f2aec03
Author: Steffen Eiden <seiden@linux.ibm.com>
KVM: Make device name configurable
Allow KVM implementations to choose alternative device names. This is
especially useful for architectures providing multiple KVM
implementations simultaneously.
> diff --git a/virt/kvm/async_pf.c b/virt/kvm/async_pf.c
> index b8aaa96b799bf..0157612491070 100644
> --- a/virt/kvm/async_pf.c
> +++ b/virt/kvm/async_pf.c
[ ... ]
> -int kvm_async_pf_init(void)
> +int kvm_async_pf_init(const char *cache_name)
> {
> - async_pf_cache = KMEM_CACHE(kvm_async_pf, 0);
> + char *full_cache_name;
> +
> + full_cache_name = kasprintf(GFP_KERNEL, "%s_async_pf", cache_name);
> + if (!full_cache_name)
> + return -ENOMEM;
> +
> + async_pf_cache = kmem_cache_create(full_cache_name,
> + sizeof(struct kvm_async_pf), 0,
> + SLAB_ACCOUNT, NULL);
[Severity: Medium]
Does this silently introduce a behavior change? The previous KMEM_CACHE call
passed 0 for flags, but this adds SLAB_ACCOUNT. While accounting these
to the vCPU's memory cgroup is likely correct, shouldn't this functional
change be documented in the commit message?
> + kfree(full_cache_name);
>
> if (!async_pf_cache)
> return -ENOMEM;
[ ... ]
> diff --git a/virt/kvm/kvm_main.c b/virt/kvm/kvm_main.c
> index 0d80730e84240..0b34477bf325b 100644
> --- a/virt/kvm/kvm_main.c
> +++ b/virt/kvm/kvm_main.c
[ ... ]
> +int kvm_init_with_dev(unsigned int vcpu_size, unsigned int vcpu_align,
> + struct module *module, const char *dev_name, int minor)
> +{
> + char *cache_name;
> int r;
> int cpu;
>
> + kvm_dev.minor = minor;
> + kvm_dev.name = kstrdup_const(dev_name, GFP_KERNEL);
[Severity: High]
Can calling kvm_init_with_dev() multiple times corrupt the static miscdevice
and list state?
If multiple KVM implementations share the same kvm_main.o core and call this
initialization, they will unconditionally overwrite the shared static kvm_dev
struct. Calling misc_register(&kvm_dev) a second time with the exact same
static struct would overwrite its list_head pointers, which structurally
guarantees misc_list corruption and a fatal kernel panic on the next
traversal.
> + if (!kvm_dev.name)
> + return -ENOMEM;
> +
> /* A kmem cache lets us meet the alignment requirements of fx_save. */
> if (!vcpu_align)
> vcpu_align = __alignof__(struct kvm_vcpu);
> +
> + r = -ENOMEM;
> + cache_name = kasprintf(GFP_KERNEL, "%s_vcpu", dev_name);
> + if (!cache_name)
> + goto err_dev_name;
> kvm_vcpu_cache =
> - kmem_cache_create_usercopy("kvm_vcpu", vcpu_size, vcpu_align,
> + kmem_cache_create_usercopy(cache_name, vcpu_size, vcpu_align,
[Severity: High]
Doesn't this also unconditionally overwrite the global kvm_vcpu_cache pointer
and leak the previous cache when multiple implementations initialize?
> SLAB_ACCOUNT,
> offsetof(struct kvm_vcpu, arch),
> offsetofend(struct kvm_vcpu, stats_id)
[ ... ]
> @@ -6597,6 +6615,8 @@ int kvm_init(unsigned vcpu_size, unsigned vcpu_align, struct module *module)
> for_each_possible_cpu(cpu)
> free_cpumask_var(per_cpu(cpu_kick_mask, cpu));
> kmem_cache_destroy(kvm_vcpu_cache);
> +err_dev_name:
> + kfree_const(kvm_dev.name);
> return r;
> }
> EXPORT_SYMBOL_FOR_KVM_INTERNAL(kvm_init);
[Severity: High]
Should kvm_init_with_dev() be exported? The commit states it is meant for
architectures providing multiple KVM implementations simultaneously, but
without an export macro like EXPORT_SYMBOL_FOR_KVM_INTERNAL, external
loadable architecture modules will fail to link against it.
[Severity: Medium]
Also, if multiple implementations are statically linked to avoid the missing
export, wouldn't kvm_gmem_init() (called earlier in this function) cause a
sysfs naming collision?
It does not take a dev_name parameter and hardcodes the name
"kvm_gmem_inode_cache". Because SLAB_ACCOUNT caches are unmergeable, the
second creation attempt will fail sysfs registration and emit a SLUB error
in dmesg.
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260812153631.3376090-1-seiden@linux.ibm.com?part=2
next prev parent reply other threads:[~2026-08-12 16:08 UTC|newest]
Thread overview: 80+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-12 15:35 [PATCH v6 00/33] KVM: s390: Introduce arm64 KVM Steffen Eiden
2026-08-12 15:35 ` [PATCH v6 01/33] vfio: Use file-based reference counting for KVM Steffen Eiden
2026-08-12 16:00 ` sashiko-bot
2026-08-12 15:35 ` [PATCH v6 02/33] KVM: Make device name configurable Steffen Eiden
2026-08-12 16:08 ` sashiko-bot [this message]
2026-08-12 15:35 ` [PATCH v6 03/33] KVM: Allow KVM implementations to switch off MMIO independent of Kconfig Steffen Eiden
2026-08-12 15:49 ` sashiko-bot
2026-08-12 15:36 ` [PATCH v6 04/33] arm64: Use proper include variant Steffen Eiden
2026-08-12 15:52 ` sashiko-bot
2026-08-12 15:36 ` [PATCH v6 05/33] arm64: ptrace: Use constants for compat register numbers Steffen Eiden
2026-08-12 15:46 ` sashiko-bot
2026-08-12 15:36 ` [PATCH v6 06/33] arm64: sysreg: Convert SPSR_ELx to automatic register generation Steffen Eiden
2026-08-12 15:48 ` sashiko-bot
2026-08-12 15:36 ` [PATCH v6 07/33] KVM: arm64: Access elements of vcpu_gp_regs individually Steffen Eiden
2026-08-12 15:48 ` sashiko-bot
2026-08-12 15:36 ` [PATCH v6 08/33] KVM: arm64: Use accessor functions for core regs Steffen Eiden
2026-08-12 15:50 ` sashiko-bot
2026-08-12 15:36 ` [PATCH v6 09/33] arm64: Prepare sharing arm64 headers with s390 Steffen Eiden
2026-08-12 15:52 ` sashiko-bot
2026-08-12 15:36 ` [PATCH v6 10/33] arm64: Share " Steffen Eiden
2026-08-12 16:20 ` sashiko-bot
2026-08-12 15:36 ` [PATCH v6 11/33] KVM: arm64: Share arm64 code " Steffen Eiden
2026-08-12 15:59 ` sashiko-bot
2026-08-12 15:36 ` [PATCH v6 12/33] KVM: s390: Extract gmap tracing to a separate header Steffen Eiden
2026-08-12 15:57 ` sashiko-bot
2026-08-12 17:13 ` Christian Borntraeger
2026-08-12 15:36 ` [PATCH v6 13/33] KVM: s390: Prepare include guards for a new location Steffen Eiden
2026-08-12 15:53 ` sashiko-bot
2026-08-12 17:35 ` Christian Borntraeger
2026-08-12 15:36 ` [PATCH v6 14/33] KVM: s390: Rename kvm-s390.{c,h} to s390.{c,h} Steffen Eiden
2026-08-12 15:58 ` sashiko-bot
2026-08-12 17:58 ` Christian Borntraeger
2026-08-12 15:36 ` [PATCH v6 15/33] KVM: s390: Move kvm_host definitions to kvm_host_s390 Steffen Eiden
2026-08-12 15:54 ` sashiko-bot
2026-08-12 18:12 ` Christian Borntraeger
2026-08-12 15:36 ` [PATCH v6 16/33] KVM: s390: Move s390 kvm code into a subdirectory Steffen Eiden
2026-08-12 16:02 ` sashiko-bot
2026-08-12 18:32 ` Christian Borntraeger
2026-08-12 15:36 ` [PATCH v6 17/33] KVM: s390: Move PGM code definitions to asm/kvm_host.h Steffen Eiden
2026-08-12 16:04 ` sashiko-bot
2026-08-12 18:47 ` Christian Borntraeger
2026-08-12 15:36 ` [PATCH v6 18/33] KVM: s390: Prepare gmap for a second KVM implementation Steffen Eiden
2026-08-12 16:10 ` sashiko-bot
2026-08-12 19:05 ` Christian Borntraeger
2026-08-12 15:36 ` [PATCH v6 19/33] KVM: s390: gmap: Make storage keys optional Steffen Eiden
2026-08-12 16:06 ` sashiko-bot
2026-08-12 19:07 ` Christian Borntraeger
2026-08-12 15:36 ` [PATCH v6 20/33] KVM: s390: gmap: Make CMMA optional Steffen Eiden
2026-08-12 16:09 ` sashiko-bot
2026-08-12 19:07 ` Christian Borntraeger
2026-08-12 15:36 ` [PATCH v6 21/33] KVM: s390: gmap: Make prefix handling optional Steffen Eiden
2026-08-12 16:08 ` sashiko-bot
2026-08-12 19:10 ` Christian Borntraeger
2026-08-12 15:36 ` [PATCH v6 22/33] KVM: s390: Prepare KVM/s390 for a second KVM module Steffen Eiden
2026-08-12 16:21 ` sashiko-bot
2026-08-12 15:36 ` [PATCH v6 23/33] s390: Use arm64 headers Steffen Eiden
2026-08-12 16:23 ` sashiko-bot
2026-08-12 15:36 ` [PATCH v6 24/33] KVM: s390: Use arm64 code Steffen Eiden
2026-08-12 16:18 ` sashiko-bot
2026-08-12 15:36 ` [PATCH v6 25/33] s390: Introduce Start Arm Execution instruction Steffen Eiden
2026-08-12 16:24 ` sashiko-bot
2026-08-12 15:36 ` [PATCH v6 26/33] KVM: s390: arm64: Introduce host definitions Steffen Eiden
2026-08-12 16:27 ` sashiko-bot
2026-08-12 15:36 ` [PATCH v6 27/33] s390/hwcaps: Report SAE support as hwcap Steffen Eiden
2026-08-12 16:15 ` sashiko-bot
2026-08-12 15:36 ` [PATCH v6 28/33] KVM: s390: Add basic arm64 kvm module Steffen Eiden
2026-08-12 16:23 ` sashiko-bot
2026-08-12 15:36 ` [PATCH v6 29/33] KVM: s390: arm64: Implement required functions Steffen Eiden
2026-08-12 16:36 ` sashiko-bot
2026-08-12 15:36 ` [PATCH v6 30/33] KVM: s390: arm64: Implement vm/vcpu create destroy Steffen Eiden
2026-08-12 16:38 ` sashiko-bot
2026-08-12 15:36 ` [PATCH v6 31/33] KVM: s390: arm64: Implement vCPU IOCTLs Steffen Eiden
2026-08-12 16:41 ` sashiko-bot
2026-08-12 15:36 ` [PATCH v6 32/33] KVM: s390: arm64: Implement basic page fault handler Steffen Eiden
2026-08-12 16:34 ` sashiko-bot
2026-08-12 15:36 ` [PATCH v6 33/33] KVM: s390: arm64: Enable KVM_ARM64 config and Kbuild Steffen Eiden
2026-08-12 16:59 ` sashiko-bot
2026-08-12 16:28 ` [PATCH v6 00/33] KVM: s390: Introduce arm64 KVM Christian Borntraeger
2026-08-12 16:36 ` Sean Christopherson
2026-08-12 18:58 ` Steffen Eiden
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260812160829.D28C51F000E9@smtp.kernel.org \
--to=sashiko-bot@kernel.org \
--cc=agordeev@linux.ibm.com \
--cc=borntraeger@linux.ibm.vom \
--cc=gor@linux.ibm.com \
--cc=hca@linux.ibm.com \
--cc=kvm@vger.kernel.org \
--cc=kvmarm@lists.linux.dev \
--cc=linux-s390@vger.kernel.org \
--cc=maz@kernel.org \
--cc=oupton@kernel.org \
--cc=sashiko-reviews@lists.linux.dev \
--cc=seiden@linux.ibm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox