From mboxrd@z Thu Jan 1 00:00:00 1970 From: Brijesh Singh Subject: Re: [Part1 PATCH v4 13/17] x86/io: Unroll string I/O when SEV is active Date: Tue, 26 Sep 2017 14:08:35 -0500 Message-ID: <4aa2ff15-771c-388d-a443-486808d9ae3f@amd.com> References: <20170916123418.37807-1-brijesh.singh@amd.com> <20170916123418.37807-14-brijesh.singh@amd.com> <20170917150846.GK4733@nazgul.tnic> Mime-Version: 1.0 Content-Type: text/plain; charset=utf-8; format=flowed Content-Transfer-Encoding: 7bit Cc: brijesh.singh@amd.com, linux-kernel@vger.kernel.org, x86@kernel.org, kvm@vger.kernel.org, Thomas Gleixner , Ingo Molnar , "H . Peter Anvin" , Andy Lutomirski , Tom Lendacky , Andy Shevchenko , David Laight , Arnd Bergmann To: Borislav Petkov Return-path: In-Reply-To: <20170917150846.GK4733@nazgul.tnic> Content-Language: en-US Sender: linux-kernel-owner@vger.kernel.org List-Id: kvm.vger.kernel.org On 09/17/2017 10:08 AM, Borislav Petkov wrote: ... >> + >> +extern struct static_key_false __sev; >> +static inline bool __sev_active(void) >> +{ >> + return static_branch_unlikely(&__sev); >> +} > > I'm still not happy about the two's sev_active() and __sev_active() > naming. Perhaps the __ variant should be called sev_key_active() or ... > Will rename it to sev_key_active() in next rev. -Brijesh