From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-16.8 required=3.0 tests=BAYES_00, HEADER_FROM_DIFFERENT_DOMAINS,INCLUDES_CR_TRAILER,INCLUDES_PATCH, MAILING_LIST_MULTI,SPF_HELO_NONE,SPF_PASS,USER_AGENT_GIT autolearn=ham autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 379DAC433E0 for ; Mon, 15 Mar 2021 15:34:17 +0000 (UTC) Received: from mm01.cs.columbia.edu (mm01.cs.columbia.edu [128.59.11.253]) by mail.kernel.org (Postfix) with ESMTP id 6DCB764E6B for ; Mon, 15 Mar 2021 15:34:16 +0000 (UTC) DMARC-Filter: OpenDMARC Filter v1.3.2 mail.kernel.org 6DCB764E6B Authentication-Results: mail.kernel.org; dmarc=fail (p=none dis=none) header.from=arm.com Authentication-Results: mail.kernel.org; spf=pass smtp.mailfrom=kvmarm-bounces@lists.cs.columbia.edu Received: from localhost (localhost [127.0.0.1]) by mm01.cs.columbia.edu (Postfix) with ESMTP id D20D94B483; Mon, 15 Mar 2021 11:34:15 -0400 (EDT) X-Virus-Scanned: at lists.cs.columbia.edu Received: from mm01.cs.columbia.edu ([127.0.0.1]) by localhost (mm01.cs.columbia.edu [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id r0ChiAwIFHdb; Mon, 15 Mar 2021 11:34:14 -0400 (EDT) Received: from mm01.cs.columbia.edu (localhost [127.0.0.1]) by mm01.cs.columbia.edu (Postfix) with ESMTP id A1D1F4B4B4; Mon, 15 Mar 2021 11:34:14 -0400 (EDT) Received: from localhost (localhost [127.0.0.1]) by mm01.cs.columbia.edu (Postfix) with ESMTP id 611BF4B483 for ; Mon, 15 Mar 2021 11:34:13 -0400 (EDT) X-Virus-Scanned: at lists.cs.columbia.edu Received: from mm01.cs.columbia.edu ([127.0.0.1]) by localhost (mm01.cs.columbia.edu [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id mN7OrW+48BbH for ; Mon, 15 Mar 2021 11:34:11 -0400 (EDT) Received: from foss.arm.com (foss.arm.com [217.140.110.172]) by mm01.cs.columbia.edu (Postfix) with ESMTP id CBEFD4B3FF for ; Mon, 15 Mar 2021 11:34:11 -0400 (EDT) Received: from usa-sjc-imap-foss1.foss.arm.com (unknown [10.121.207.14]) by usa-sjc-mx-foss1.foss.arm.com (Postfix) with ESMTP id 382AF1FB; Mon, 15 Mar 2021 08:34:11 -0700 (PDT) Received: from localhost.localdomain (unknown [172.31.20.19]) by usa-sjc-imap-foss1.foss.arm.com (Postfix) with ESMTPSA id E03333F792; Mon, 15 Mar 2021 08:34:09 -0700 (PDT) From: Andre Przywara To: Will Deacon , Julien Thierry Subject: [PATCH kvmtool v3 00/22] Unify I/O port and MMIO trap handling Date: Mon, 15 Mar 2021 15:33:28 +0000 Message-Id: <20210315153350.19988-1-andre.przywara@arm.com> X-Mailer: git-send-email 2.14.1 Cc: Marc Zyngier , Sami Mujawar , kvmarm@lists.cs.columbia.edu, kvm@vger.kernel.org X-BeenThere: kvmarm@lists.cs.columbia.edu X-Mailman-Version: 2.1.14 Precedence: list List-Id: Where KVM/ARM decisions are made List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Errors-To: kvmarm-bounces@lists.cs.columbia.edu Sender: kvmarm-bounces@lists.cs.columbia.edu Hi, this version is addressing Alexandru's comments, fixing mostly minor issues in the naming scheme. The biggest change is to keep the ioport__read/ioport_write wrappers for the serial device. For more details see the changelog below. ============== At the moment we use two separate code paths to handle exits for KVM_EXIT_IO (ioport.c) and KVM_EXIT_MMIO (mmio.c), even though they are semantically very similar. Because the trap handler callback routine is different, devices need to decide on one conduit or need to provide different handler functions for both of them. This is not only unnecessary code duplication, but makes switching devices from I/O port to MMIO a tedious task, even though there is no real difference between the two, especially on ARM and PowerPC. For ARM we aim at providing a flexible memory layout, and also have trouble with the UART and RTC device overlapping with the PCI I/O area, so it seems indicated to tackle this once and for all. The first three patches do some cleanup, to simplify things later. Patch 04/22 lays the groundwork, by extending mmio.c to be able to also register I/O port trap handlers, using the same callback prototype as we use for MMIO. The next 14 patches then convert devices that use the I/O port interface over to the new joint interface. This requires to rework the trap handler routine to adhere to the same prototype as the existing MMIO handlers. For most devices this is done in two steps: a first to introduce the reworked handler routine, and a second to switch to the new joint registration routine. For some devices the first step is trivial, so it's done in one patch. Patch 19/22 then retires the old I/O port interface, by removing ioport.c and friends. Patch 20/22 uses the opportunity to clean up the memory map description, also declares a new region (from 16MB on), where the final two patches switch the UART and the RTC device to. They are now registered on the MMIO "bus", when running on ARM or arm64. This moves them away from the first 64KB, so they are not in the PCI I/O area anymore. Please have a look and comment! Cheers, Andre Changelog v2 .. v3: - use _io as function prefix for x86 I/O port devices - retain ioport__{read,write}8() wrappers for serial device - fix memory map ASCII art - fix serial base declaration - minor nit fixes - add Reviewed-by: tags Changelog v1 .. v2: - rework memory map definition - add explicit debug output for debug I/O port - add explicit check for MMIO coalescing on I/O ports - drop usage of ioport__{read,write}8() from serial - drop explicit I/O port cleanup routine (to mimic MMIO operation) - add comment for IOTRAP_BUS_MASK - minor cleanups / formatting changes Andre Przywara (22): ioport: Remove ioport__setup_arch() hw/serial: Use device abstraction for FDT generator function ioport: Retire .generate_fdt_node functionality mmio: Extend handling to include ioport emulation hw/i8042: Clean up data types hw/i8042: Refactor trap handler hw/i8042: Switch to new trap handlers x86/ioport: Refactor trap handlers x86/ioport: Switch to new trap handlers hw/rtc: Refactor trap handlers hw/rtc: Switch to new trap handler hw/vesa: Switch trap handling to use MMIO handler hw/serial: Refactor trap handler hw/serial: Switch to new trap handlers vfio: Refactor ioport trap handler vfio: Switch to new ioport trap handlers virtio: Switch trap handling to use MMIO handler pci: Switch trap handling to use MMIO handler Remove ioport specific routines arm: Reorganise and document memory map hw/serial: ARM/arm64: Use MMIO at higher addresses hw/rtc: ARM/arm64: Use MMIO at higher addresses Makefile | 1 - arm/include/arm-common/kvm-arch.h | 47 ++++-- arm/ioport.c | 5 - hw/i8042.c | 94 +++++------- hw/rtc.c | 91 ++++++------ hw/serial.c | 126 +++++++++++----- hw/vesa.c | 19 +-- include/kvm/i8042.h | 1 - include/kvm/ioport.h | 32 ---- include/kvm/kvm.h | 49 ++++++- ioport.c | 235 ------------------------------ mips/kvm.c | 5 - mmio.c | 65 +++++++-- pci.c | 82 +++-------- powerpc/ioport.c | 6 - vfio/core.c | 50 ++++--- virtio/pci.c | 46 ++---- x86/ioport.c | 108 +++++++------- 18 files changed, 421 insertions(+), 641 deletions(-) delete mode 100644 ioport.c -- 2.17.5 _______________________________________________ kvmarm mailing list kvmarm@lists.cs.columbia.edu https://lists.cs.columbia.edu/mailman/listinfo/kvmarm