From: Marc Zyngier <maz@kernel.org>
To: Joey Gouly <joey.gouly@arm.com>
Cc: kvmarm@lists.linux.dev, kvm@vger.kernel.org,
linux-arm-kernel@lists.infradead.org,
James Morse <james.morse@arm.com>,
Suzuki K Poulose <suzuki.poulose@arm.com>,
Oliver Upton <oliver.upton@linux.dev>,
Zenghui Yu <yuzenghui@huawei.com>, Will Deacon <will@kernel.org>,
Catalin Marinas <catalin.marinas@arm.com>
Subject: Re: [PATCH 02/13] KVM: arm64: Clarify ESR_ELx_ERET_ISS_ERET*
Date: Tue, 20 Feb 2024 12:29:30 +0000 [thread overview]
Message-ID: <861q9748ut.wl-maz@kernel.org> (raw)
In-Reply-To: <20240220113127.GB16168@e124191.cambridge.arm.com>
On Tue, 20 Feb 2024 11:31:27 +0000,
Joey Gouly <joey.gouly@arm.com> wrote:
>
> On Mon, Feb 19, 2024 at 09:20:03AM +0000, Marc Zyngier wrote:
> > The ESR_ELx_ERET_ISS_ERET* macros are a bit confusing:
> >
> > - ESR_ELx_ERET_ISS_ERET really indicates that we have trapped an
> > ERETA* instruction, as opposed to an ERET
> >
> > - ESR_ELx_ERET_ISS_ERETA reallu indicates that we have trapped
> > an ERETAB instruction, as opposed to an ERETAA.
> >
> > Repaint the two helpers such as:
> >
> > - ESR_ELx_ERET_ISS_ERET becomes ESR_ELx_ERET_ISS_ERETA
> >
> > - ESR_ELx_ERET_ISS_ERETA becomes ESR_ELx_ERET_ISS_ERETAB
> >
> > At the same time, use BIT() instead of raw values.
> >
> > Signed-off-by: Marc Zyngier <maz@kernel.org>
>
> I'm somewhat against this, as the original names are what the Arm
> ARM specifies.
I don't disagree, but that doesn't make the ARM ARM right! ;-)
>
> > ---
> > arch/arm64/include/asm/esr.h | 4 ++--
> > arch/arm64/kvm/handle_exit.c | 2 +-
> > 2 files changed, 3 insertions(+), 3 deletions(-)
> >
> > diff --git a/arch/arm64/include/asm/esr.h b/arch/arm64/include/asm/esr.h
> > index 353fe08546cf..72c7810ccf2c 100644
> > --- a/arch/arm64/include/asm/esr.h
> > +++ b/arch/arm64/include/asm/esr.h
> > @@ -290,8 +290,8 @@
> > ESR_ELx_SYS64_ISS_OP2_SHIFT))
> >
> > /* ISS field definitions for ERET/ERETAA/ERETAB trapping */
> > -#define ESR_ELx_ERET_ISS_ERET 0x2
> > -#define ESR_ELx_ERET_ISS_ERETA 0x1
> > +#define ESR_ELx_ERET_ISS_ERETA BIT(1)
> > +#define ESR_ELx_ERET_ISS_ERETAB BIT(0)
> >
> > /*
> > * ISS field definitions for floating-point exception traps
> > diff --git a/arch/arm64/kvm/handle_exit.c b/arch/arm64/kvm/handle_exit.c
> > index 617ae6dea5d5..0646c623d1da 100644
> > --- a/arch/arm64/kvm/handle_exit.c
> > +++ b/arch/arm64/kvm/handle_exit.c
> > @@ -219,7 +219,7 @@ static int kvm_handle_ptrauth(struct kvm_vcpu *vcpu)
> >
> > static int kvm_handle_eret(struct kvm_vcpu *vcpu)
> > {
> > - if (kvm_vcpu_get_esr(vcpu) & ESR_ELx_ERET_ISS_ERET)
> > + if (kvm_vcpu_get_esr(vcpu) & ESR_ELx_ERET_ISS_ERETA)
>
> If this part is confusing due to the name, maybe introduce a function in esr.h
> esr_is_pac_eret() (name pending bikeshedding)?
That's indeed a better option. Now for the bikeshed aspect:
- esr_iss_is_eretax(): check for ESR_ELx_ERET_ISS_ERET being set
- esr_iss_is_eretab(): check for ESR_ELx_ERET_ISS_ERETA being set
Thoughts?
M.
--
Without deviation from the norm, progress is not possible.
next prev parent reply other threads:[~2024-02-20 12:29 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-02-19 9:20 [PATCH 00/13] KVM/arm64: Add NV support for ERET and PAuth Marc Zyngier
2024-02-19 9:20 ` [PATCH 01/13] KVM: arm64: Harden __ctxt_sys_reg() against out-of-range values Marc Zyngier
2024-02-20 11:20 ` Joey Gouly
2024-02-20 11:57 ` Marc Zyngier
2024-02-20 13:17 ` Joey Gouly
2024-02-19 9:20 ` [PATCH 02/13] KVM: arm64: Clarify ESR_ELx_ERET_ISS_ERET* Marc Zyngier
2024-02-20 11:31 ` Joey Gouly
2024-02-20 12:29 ` Marc Zyngier [this message]
2024-02-20 13:23 ` Joey Gouly
2024-02-20 13:41 ` Marc Zyngier
2024-02-20 15:18 ` Joey Gouly
2024-02-19 9:20 ` [PATCH 03/13] KVM: arm64: nv: Drop VCPU_HYP_CONTEXT flag Marc Zyngier
2024-02-20 11:58 ` Joey Gouly
2024-02-19 9:20 ` [PATCH 04/13] KVM: arm64: nv: Configure HCR_EL2 for FEAT_NV2 Marc Zyngier
2024-02-20 15:16 ` Joey Gouly
2024-02-20 15:41 ` Marc Zyngier
2024-02-19 9:20 ` [PATCH 05/13] KVM: arm64: nv: Add trap forwarding for ERET and SMC Marc Zyngier
2024-02-22 11:05 ` Joey Gouly
2024-02-19 9:20 ` [PATCH 06/13] KVM: arm64: nv: Fast-track 'InHost' exception returns Marc Zyngier
2024-02-19 9:20 ` [PATCH 07/13] KVM: arm64: nv: Honor HFGITR_EL2.ERET being set Marc Zyngier
2024-02-19 9:20 ` [PATCH 08/13] KVM: arm64: nv: Handle HCR_EL2.{API,APK} independantly Marc Zyngier
2024-02-19 9:20 ` [PATCH 09/13] KVM: arm64: nv: Reinject PAC exceptions caused by HCR_EL2.API==0 Marc Zyngier
2024-02-19 9:20 ` [PATCH 10/13] KVM: arm64: nv: Add kvm_has_pauth() helper Marc Zyngier
2024-02-19 9:20 ` [PATCH 11/13] KVM: arm64: nv: Add emulation for ERETAx instructions Marc Zyngier
2024-02-19 9:20 ` [PATCH 12/13] KVM: arm64: nv: Handle ERETA[AB] instructions Marc Zyngier
2024-02-19 9:20 ` [PATCH 13/13] KVM: arm64: nv: Advertise support for PAuth Marc Zyngier
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=861q9748ut.wl-maz@kernel.org \
--to=maz@kernel.org \
--cc=catalin.marinas@arm.com \
--cc=james.morse@arm.com \
--cc=joey.gouly@arm.com \
--cc=kvm@vger.kernel.org \
--cc=kvmarm@lists.linux.dev \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=oliver.upton@linux.dev \
--cc=suzuki.poulose@arm.com \
--cc=will@kernel.org \
--cc=yuzenghui@huawei.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox