From: Marc Zyngier <maz@kernel.org>
To: Quentin Perret <qperret@google.com>
Cc: Oliver Upton <oliver.upton@linux.dev>,
Joey Gouly <joey.gouly@arm.com>,
Suzuki K Poulose <suzuki.poulose@arm.com>,
Zenghui Yu <yuzenghui@huawei.com>,
Catalin Marinas <catalin.marinas@arm.com>,
Will Deacon <will@kernel.org>, Fuad Tabba <tabba@google.com>,
Vincent Donnefort <vdonnefort@google.com>,
Sebastian Ene <sebastianene@google.com>,
linux-arm-kernel@lists.infradead.org, kvmarm@lists.linux.dev,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3 18/18] KVM: arm64: Plumb the pKVM MMU in KVM
Date: Tue, 17 Dec 2024 15:38:21 +0000 [thread overview]
Message-ID: <86pllqqpzm.wl-maz@kernel.org> (raw)
In-Reply-To: <Z2GLR8KZzJn1YpUu@google.com>
On Tue, 17 Dec 2024 14:31:35 +0000,
Quentin Perret <qperret@google.com> wrote:
>
> On Tuesday 17 Dec 2024 at 14:03:37 (+0000), Marc Zyngier wrote:
> > My gripe with this is that it makes it much harder to follow what is
> > happening by using tags (ctags, etags, whatever). I ended up with the
> > hack below, which is super ugly, but preserves the tagging
> > functionality for non-pKVM.
>
> Ack.
>
> > I'll scratch my head to find something more elegant...
>
> I find your proposal pretty reasonable -- I had a few different ideas
> but they were all really over-engineered, so I figured relying on a
> naming convention was the simplest. And any divergence will be flagged
> at compile time, so that shouldn't be too hard to maintain looking
> forward.
>
> The __S2 name isn't massively descriptive though. Maybe KVM_PGT_CALL()
> or something? Thinking about it, this abstraction doesn't need to be
> restricted to stage-2 stuff. We could most likely hide the
> __pkvm_host_{un}share_hyp() logic behind a pkvm_pgtable_hyp_{un}map()
> implementation in pkvm.c as well...
Oh, I'm happy with *any* name. I just changed it to make sure any
missing occurrence would blow up.
And yes, if we can make that more uniform, I'm all for that.
Thanks,
M.
--
Without deviation from the norm, progress is not possible.
next prev parent reply other threads:[~2024-12-17 15:38 UTC|newest]
Thread overview: 53+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-12-16 17:57 [PATCH v3 00/18] KVM: arm64: Non-protected guest stage-2 support for pKVM Quentin Perret
2024-12-16 17:57 ` [PATCH v3 01/18] KVM: arm64: Change the layout of enum pkvm_page_state Quentin Perret
2024-12-17 8:43 ` Fuad Tabba
2024-12-17 10:52 ` Marc Zyngier
2024-12-17 13:07 ` Quentin Perret
2024-12-16 17:57 ` [PATCH v3 02/18] KVM: arm64: Move enum pkvm_page_state to memory.h Quentin Perret
2024-12-17 8:43 ` Fuad Tabba
2024-12-16 17:57 ` [PATCH v3 03/18] KVM: arm64: Make hyp_page::order a u8 Quentin Perret
2024-12-17 8:43 ` Fuad Tabba
2024-12-17 10:55 ` Marc Zyngier
2024-12-17 13:08 ` Quentin Perret
2024-12-16 17:57 ` [PATCH v3 04/18] KVM: arm64: Move host page ownership tracking to the hyp vmemmap Quentin Perret
2024-12-17 8:46 ` Fuad Tabba
2024-12-17 11:03 ` Marc Zyngier
2024-12-17 13:09 ` Quentin Perret
2024-12-16 17:57 ` [PATCH v3 05/18] KVM: arm64: Pass walk flags to kvm_pgtable_stage2_mkyoung Quentin Perret
2024-12-17 8:47 ` Fuad Tabba
2024-12-16 17:57 ` [PATCH v3 06/18] KVM: arm64: Pass walk flags to kvm_pgtable_stage2_relax_perms Quentin Perret
2024-12-17 8:47 ` Fuad Tabba
2024-12-16 17:57 ` [PATCH v3 07/18] KVM: arm64: Make kvm_pgtable_stage2_init() a static inline function Quentin Perret
2024-12-17 8:48 ` Fuad Tabba
2024-12-16 17:57 ` [PATCH v3 08/18] KVM: arm64: Add {get,put}_pkvm_hyp_vm() helpers Quentin Perret
2024-12-17 8:48 ` Fuad Tabba
2024-12-16 17:57 ` [PATCH v3 09/18] KVM: arm64: Introduce __pkvm_vcpu_{load,put}() Quentin Perret
2024-12-17 8:48 ` Fuad Tabba
2024-12-16 17:57 ` [PATCH v3 10/18] KVM: arm64: Introduce __pkvm_host_share_guest() Quentin Perret
2024-12-17 8:51 ` Fuad Tabba
2024-12-16 17:57 ` [PATCH v3 11/18] KVM: arm64: Introduce __pkvm_host_unshare_guest() Quentin Perret
2024-12-17 8:53 ` Fuad Tabba
2024-12-17 13:14 ` Quentin Perret
2024-12-17 13:22 ` Fuad Tabba
2024-12-17 11:29 ` Marc Zyngier
2024-12-17 13:33 ` Quentin Perret
2024-12-17 14:06 ` Marc Zyngier
2024-12-16 17:57 ` [PATCH v3 12/18] KVM: arm64: Introduce __pkvm_host_relax_guest_perms() Quentin Perret
2024-12-17 8:57 ` Fuad Tabba
2024-12-16 17:57 ` [PATCH v3 13/18] KVM: arm64: Introduce __pkvm_host_wrprotect_guest() Quentin Perret
2024-12-17 8:56 ` Fuad Tabba
2024-12-16 17:57 ` [PATCH v3 14/18] KVM: arm64: Introduce __pkvm_host_test_clear_young_guest() Quentin Perret
2024-12-17 8:57 ` Fuad Tabba
2024-12-16 17:58 ` [PATCH v3 15/18] KVM: arm64: Introduce __pkvm_host_mkyoung_guest() Quentin Perret
2024-12-17 9:00 ` Fuad Tabba
2024-12-16 17:58 ` [PATCH v3 16/18] KVM: arm64: Introduce __pkvm_tlb_flush_vmid() Quentin Perret
2024-12-17 9:00 ` Fuad Tabba
2024-12-16 17:58 ` [PATCH v3 17/18] KVM: arm64: Introduce the EL1 pKVM MMU Quentin Perret
2024-12-16 17:58 ` [PATCH v3 18/18] KVM: arm64: Plumb the pKVM MMU in KVM Quentin Perret
2024-12-17 9:34 ` Fuad Tabba
2024-12-17 14:03 ` Marc Zyngier
2024-12-17 14:31 ` Quentin Perret
2024-12-17 15:38 ` Marc Zyngier [this message]
2024-12-18 12:06 ` Quentin Perret
2024-12-17 9:25 ` [PATCH v3 00/18] KVM: arm64: Non-protected guest stage-2 support for pKVM Fuad Tabba
2024-12-17 13:05 ` Quentin Perret
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=86pllqqpzm.wl-maz@kernel.org \
--to=maz@kernel.org \
--cc=catalin.marinas@arm.com \
--cc=joey.gouly@arm.com \
--cc=kvmarm@lists.linux.dev \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=oliver.upton@linux.dev \
--cc=qperret@google.com \
--cc=sebastianene@google.com \
--cc=suzuki.poulose@arm.com \
--cc=tabba@google.com \
--cc=vdonnefort@google.com \
--cc=will@kernel.org \
--cc=yuzenghui@huawei.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox