Linux ACPI
 help / color / mirror / Atom feed
From: Jerry Hoemann <jerry.hoemann@hpe.com>
To: Dan Williams <dan.j.williams@intel.com>
Cc: Ross Zwisler <ross.zwisler@linux.intel.com>,
	"Rafael J. Wysocki" <rjw@rjwysocki.net>,
	Len Brown <lenb@kernel.org>,
	"Elliott, Robert (Persistent Memory)" <elliott@hpe.com>,
	jmoyer <jmoyer@redhat.com>,
	Dmitry Krivenok <krivenok.dmitry@gmail.com>,
	Linda Knippers <linda.knippers@hpe.com>,
	"linux-nvdimm@lists.01.org" <linux-nvdimm@lists.01.org>,
	Linux ACPI <linux-acpi@vger.kernel.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v2 0/3] nvdimm: Add an IOCTL pass thru for DSM calls
Date: Tue, 17 Nov 2015 09:56:45 -0700	[thread overview]
Message-ID: <20151117165645.GB91690@tevye.fc.hp.com> (raw)
In-Reply-To: <CAPcyv4jhORsskTr_SPpNO=zJf9V7_zrYNnNn61SMWApnv7TK0g@mail.gmail.com>

On Mon, Nov 16, 2015 at 05:29:41PM -0800, Dan Williams wrote:
> On Mon, Nov 16, 2015 at 1:10 PM, Jerry Hoemann <jerry.hoemann@hpe.com> wrote:
> > On Mon, Nov 16, 2015 at 11:00:20AM -0800, Dan Williams wrote:
> >> On Mon, Nov 16, 2015 at 10:38 AM, Jerry Hoemann <jerry.hoemann@hpe.com> wrote:
> >> >
> >>

...

> >> Let's not do the _intel vs _passthru split.  I want to convert the
> >> existing commands over to this new interface and deprecate the old
> >> ioctl-command formats.  I.e. it isn't the case that this will be a
> >> always be a blind "passthru" mechanism, the kernel will need to crack
> >> open this payload in some circumstances.
> >
> >
> > I'm confused.
> >
> > In this version there is only 1 ioctl 'N'.  The pass thru is using
> > number 100.  This is what I thought you wanted from prior comments.
> 
> It is indeed, I like that change.
> 
> > The split are for internal functions that deal specifically w/
> > the argument marshaling code and copy-in/copy-out.  These mechanisms
> > are different.
> >
> > I understand that you want to switch over, but don't you (at least for
> > the time being) need to keep the old marshaling code for the current
> > use case?   I was assuming a sequence like:
> >         1. The pass thru code gets submitted.
> >         2. The current tools are converted over to using the pass thru,
> >         3. The marshaling code using nd_cmd_in_size etc., would then
> >                 be removed.
> >
> > Are you wanting to make one big change and not in separate steps?
> 
> I want to do it in separate steps, I'd just like to see cmd number 100
> added to the existing __nd_ioctl and acpi_nfit_ctl routines.  That

   Why?

> plus quibbling about the name "ND_CMD_PASSTHRU".  Given the plans to
> eventually replace the existing commands we can call it something like
> 'ND_DSM_GENERIC'.


  No problem.  I'll change the name for ndn_passthru_pkg in a similar fashion.


  Question:	Are you planning to add other CMDs to the IOCTL in the future?
		(eg. ones not directly related to calling _dsm?)

	 	Or, is the ultimate goal to have an IOCTL that supports
		only the generic DSM call?

-- 

-----------------------------------------------------------------------------
Jerry Hoemann            Software Engineer      Hewlett-Packard Enterprise
-----------------------------------------------------------------------------

  reply	other threads:[~2015-11-17 16:56 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-11-16 18:38 [PATCH v2 0/3] nvdimm: Add an IOCTL pass thru for DSM calls Jerry Hoemann
2015-11-16 18:38 ` [PATCH v2 1/3] nvdimm: Clean-up access mode check Jerry Hoemann
2015-11-16 18:38 ` [PATCH v2 2/3] nvdimm: Add wrapper for IOCTL pass thru Jerry Hoemann
2015-11-16 18:38 ` [PATCH v2 3/3] nvdimm: Add IOCTL pass thru functions Jerry Hoemann
2015-11-16 19:00 ` [PATCH v2 0/3] nvdimm: Add an IOCTL pass thru for DSM calls Dan Williams
2015-11-16 21:10   ` Jerry Hoemann
2015-11-17  1:29     ` Dan Williams
2015-11-17 16:56       ` Jerry Hoemann [this message]
2015-11-17 17:05         ` Dan Williams
2015-11-18  7:01           ` Jerry Hoemann

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20151117165645.GB91690@tevye.fc.hp.com \
    --to=jerry.hoemann@hpe.com \
    --cc=dan.j.williams@intel.com \
    --cc=elliott@hpe.com \
    --cc=jmoyer@redhat.com \
    --cc=krivenok.dmitry@gmail.com \
    --cc=lenb@kernel.org \
    --cc=linda.knippers@hpe.com \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-nvdimm@lists.01.org \
    --cc=rjw@rjwysocki.net \
    --cc=ross.zwisler@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox