From mboxrd@z Thu Jan 1 00:00:00 1970 From: "Alex G." Subject: Re: [PATCH v6 1/2] acpi: apei: Rename ghes_severity() to ghes_cper_severity() Date: Tue, 22 May 2018 08:38:39 -0500 Message-ID: <53d0ba88-6929-a7cf-6c3e-4ca389f7249a@gmail.com> References: <20180521135003.32459-1-mr.nuke.me@gmail.com> <20180521135003.32459-2-mr.nuke.me@gmail.com> Mime-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 7bit Return-path: In-Reply-To: Content-Language: en-US Sender: linux-kernel-owner@vger.kernel.org To: "Rafael J. Wysocki" Cc: Borislav Petkov , alex_gagniuc@dellteam.com, austin_bolen@dell.com, shyam_iyer@dell.com, "Rafael J. Wysocki" , Len Brown , Tony Luck , Tyler Baicar , Will Deacon , James Morse , Shiju Jose , "Jonathan (Zhixiong) Zhang" , Dongjiu Geng , ACPI Devel Maling List , Linux Kernel Mailing List List-Id: linux-acpi@vger.kernel.org On 05/22/2018 03:55 AM, Rafael J. Wysocki wrote: > On Mon, May 21, 2018 at 3:49 PM, Alexandru Gagniuc wrote: >> ghes_severity() is a misnomer in this case, as it implies the severity >> of the entire GHES structure. Instead, it maps one CPER value to a >> GHES_SEV* value. ghes_cper_severity() is clearer. > > It looks like the *real* reason for this change is that you > re-introduce ghes_severity() as a different function in the second > patch. /me holds fist at Borislav > There are a couple of reasons to avoid that, one of them being that > people will now have to remember what the function did in which kernel > versions. So? > Also, the current name is good enough IMO, Two other reviewers were extremely confused by the vague name, so no, this is not good enough. > so I'm not going to apply this patch.