From mboxrd@z Thu Jan 1 00:00:00 1970 From: Len Brown Subject: Re: [PATCH 00/20] ACPI: PCI: simplify _PRT handling Date: Tue, 30 Dec 2008 23:17:12 -0500 (EST) Message-ID: References: <20081209042833.26415.24906.stgit@bob.kio> Mime-Version: 1.0 Content-Type: TEXT/PLAIN; charset=US-ASCII Return-path: Received: from vms173007pub.verizon.net ([206.46.173.7]:35297 "EHLO vms173007pub.verizon.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751596AbYLaER3 (ORCPT ); Tue, 30 Dec 2008 23:17:29 -0500 Received: from localhost.localdomain ([96.237.168.40]) by vms173007.mailsrvcs.net (Sun Java System Messaging Server 6.2-6.01 (built Apr 3 2006)) with ESMTPA id <0KCQ002R53UI6Z26@vms173007.mailsrvcs.net> for linux-acpi@vger.kernel.org; Tue, 30 Dec 2008 22:15:59 -0600 (CST) In-reply-to: <20081209042833.26415.24906.stgit@bob.kio> Sender: linux-acpi-owner@vger.kernel.org List-Id: linux-acpi@vger.kernel.org To: Bjorn Helgaas Cc: linux-acpi@vger.kernel.org series looks good -- applied all 20. thanks, -- Len Brown, Intel Open Source Technology Center On Mon, 8 Dec 2008, Bjorn Helgaas wrote: > This series simplifies the code that handles ACPI _PRTs (PCI routing > tables). My goal is to make this look more like the corresponding > code in other architectures, especially in terms of swizzling, e.g., > the various implementations of common_swizzle() and simple_swizzle(), > and the x86 non-ACPI code in pirq_enable_irq(). > > There should be no functional changes in this series. > > Comments welcome. > > Bjorn > > --- > > Bjorn Helgaas (20): > ACPI: PCI: add HP copyright > ACPI: PCI: whitespace and useless initialization cleanup > ACPI: PCI: expand acpi_pci_allocate_irq() and acpi_pci_free_irq() inline > ACPI: PCI: simplify struct acpi_prt_entry > ACPI: PCI: simplify list of _PRT entries > ACPI: PCI: combine lookup and derive > ACPI: PCI: follow typical PCI INTx swizzling pattern > ACPI: PCI: use positive logic to simplify code > ACPI: PCI: remove callback from acpi_pci_irq_lookup & acpi_pci_irq_derive > ACPI: PCI: tweak _PRT lookup debug > ACPI: PCI: lookup _PRT entry by PCI dev and pin, not segment/bus/dev/pin > ACPI: PCI: use 1-based encoding for _PRT quirks > ACPI: PCI: always use the PCI INTx pin values, not the _PRT ones > ACPI: PCI: add a helper to convert _PRT INTx pin number to name > ACPI: PCI: move struct acpi_prt_entry declaration out of public header file > ACPI: PCI: fix GSI/IRQ naming confusion > ACPI: PCI: ignore _PRT function information > ACPI: PCI: simplify buffer management for evaluating _PRT > ACPI: PCI: remove unnecessary null pointer checks > ACPI: PCI: use conventional PCI address format > > > drivers/acpi/pci_bind.c | 12 + > drivers/acpi/pci_irq.c | 416 +++++++++++++++-------------------------------- > include/linux/acpi.h | 16 -- > 3 files changed, 136 insertions(+), 308 deletions(-) >