From mboxrd@z Thu Jan 1 00:00:00 1970 From: Yu-cheng Yu Subject: Re: [RFC PATCH v9 11/27] drm/i915/gvt: Change _PAGE_DIRTY to _PAGE_DIRTY_BITS Date: Fri, 03 Apr 2020 08:42:06 -0700 Message-ID: <0ddcfb2630456324203917b78297b00cf5111c9e.camel@intel.com> References: <20200205181935.3712-1-yu-cheng.yu@intel.com> <20200205181935.3712-12-yu-cheng.yu@intel.com> <34c83f97-f206-1b43-db40-7e6a7d0f6bb7@intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset="UTF-8" Content-Transfer-Encoding: 7bit Return-path: In-Reply-To: <34c83f97-f206-1b43-db40-7e6a7d0f6bb7@intel.com> Sender: linux-kernel-owner@vger.kernel.org To: Dave Hansen , x86@kernel.org, "H. Peter Anvin" , Thomas Gleixner , Ingo Molnar , linux-kernel@vger.kernel.org, linux-doc@vger.kernel.org, linux-mm@kvack.org, linux-arch@vger.kernel.org, linux-api@vger.kernel.org, Arnd Bergmann , Andy Lutomirski , Balbir Singh , Borislav Petkov , Cyrill Gorcunov , Dave Hansen , Eugene Syromiatnikov , Florian Weimer , "H.J. Lu" , Jann Horn , Jonathan Corbet , Kees Cook , Mike Kravetz Cc: Zhenyu Wang , Zhi Wang , Jani Nikula , Joonas Lahtinen , Rodrigo Vivi , David Airlie , Daniel Vetter List-Id: linux-arch.vger.kernel.org On Wed, 2020-02-26 at 14:04 -0800, Dave Hansen wrote: > On 2/5/20 10:19 AM, Yu-cheng Yu wrote: > > diff --git a/drivers/gpu/drm/i915/gvt/gtt.c b/drivers/gpu/drm/i915/gvt/gtt.c > > index 4b04af569c05..e467ca182633 100644 > > --- a/drivers/gpu/drm/i915/gvt/gtt.c > > +++ b/drivers/gpu/drm/i915/gvt/gtt.c > > @@ -1201,7 +1201,7 @@ static int split_2MB_gtt_entry(struct intel_vgpu *vgpu, > > } > > > > /* Clear dirty field. */ > > - se->val64 &= ~_PAGE_DIRTY; > > + se->val64 &= ~_PAGE_DIRTY_BITS; > > > > ops->clear_pse(se); > > ops->clear_ips(se); > > Are the i915 maintainers on cc? > > Shouldn't this use pte_mkclean() instead of open-coding? These functions look like a set of pte_* equivalent for the driver. They all use the bits directly. Add its maintainers to cc. Yu-cheng From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Message-ID: <0ddcfb2630456324203917b78297b00cf5111c9e.camel@intel.com> Subject: Re: [RFC PATCH v9 11/27] drm/i915/gvt: Change _PAGE_DIRTY to _PAGE_DIRTY_BITS From: Yu-cheng Yu Date: Fri, 03 Apr 2020 08:42:06 -0700 In-Reply-To: <34c83f97-f206-1b43-db40-7e6a7d0f6bb7@intel.com> References: <20200205181935.3712-1-yu-cheng.yu@intel.com> <20200205181935.3712-12-yu-cheng.yu@intel.com> <34c83f97-f206-1b43-db40-7e6a7d0f6bb7@intel.com> Content-Type: text/plain; charset="UTF-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit Sender: linux-doc-owner@vger.kernel.org To: Dave Hansen , x86@kernel.org, "H. Peter Anvin" , Thomas Gleixner , Ingo Molnar , linux-kernel@vger.kernel.org, linux-doc@vger.kernel.org, linux-mm@kvack.org, linux-arch@vger.kernel.org, linux-api@vger.kernel.org, Arnd Bergmann , Andy Lutomirski , Balbir Singh , Borislav Petkov , Cyrill Gorcunov , Dave Hansen , Eugene Syromiatnikov , Florian Weimer , "H.J. Lu" , Jann Horn , Jonathan Corbet , Kees Cook , Mike Kravetz , Nadav Amit , Oleg Nesterov , Pavel Machek , Peter Zijlstra , Randy Dunlap , "Ravi V. Shankar" , Vedvyas Shanbhogue , Dave Martin , x86-patch-review@intel.com Cc: Zhenyu Wang , Zhi Wang , Jani Nikula , Joonas Lahtinen , Rodrigo Vivi , David Airlie , Daniel Vetter List-ID: Message-ID: <20200403154206.qsFHnidacMoIgnXcY9z2yQuIPKrCXBpmYcWa9aXOu28@z> On Wed, 2020-02-26 at 14:04 -0800, Dave Hansen wrote: > On 2/5/20 10:19 AM, Yu-cheng Yu wrote: > > diff --git a/drivers/gpu/drm/i915/gvt/gtt.c b/drivers/gpu/drm/i915/gvt/gtt.c > > index 4b04af569c05..e467ca182633 100644 > > --- a/drivers/gpu/drm/i915/gvt/gtt.c > > +++ b/drivers/gpu/drm/i915/gvt/gtt.c > > @@ -1201,7 +1201,7 @@ static int split_2MB_gtt_entry(struct intel_vgpu *vgpu, > > } > > > > /* Clear dirty field. */ > > - se->val64 &= ~_PAGE_DIRTY; > > + se->val64 &= ~_PAGE_DIRTY_BITS; > > > > ops->clear_pse(se); > > ops->clear_ips(se); > > Are the i915 maintainers on cc? > > Shouldn't this use pte_mkclean() instead of open-coding? These functions look like a set of pte_* equivalent for the driver. They all use the bits directly. Add its maintainers to cc. Yu-cheng