From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Subject: Re: [PATCH 1/19] MUTEX: Introduce simple mutex implementation From: Arjan van de Ven In-Reply-To: <439EDBC9.5000304@rtr.ca> References: <20051212161944.3185a3f9.akpm@osdl.org> <20051213075441.GB6765@elte.hu> <1134460804.2866.17.camel@laptopd505.fenrus.org> <20051213090349.GE10088@elte.hu> <20051213090917.GC15804@wotan.suse.de> <20051213093427.GA26097@elte.hu> <439EDBC9.5000304@rtr.ca> Content-Type: text/plain Date: Tue, 13 Dec 2005 15:45:08 +0100 Message-Id: <1134485109.9814.2.camel@laptopd505.fenrus.org> Mime-Version: 1.0 Content-Transfer-Encoding: 7bit To: Mark Lord Cc: Ingo Molnar , Andi Kleen , Andrew Morton , David Howells , torvalds@osdl.org, hch@infradead.org, matthew@wil.cx, linux-kernel@vger.kernel.org, linux-arch@vger.kernel.org List-ID: On Tue, 2005-12-13 at 09:33 -0500, Mark Lord wrote: > >'struct compat_semaphore' > > I really think this data type needs a better name, > one that reflects what it does. > > Something like 'struct binary_semaphore' or something. see the thing is.. this is the counting one ;) the -rt naming is just too confusing (but done to keep patch maintenance reasonable, which is fair enough for that purpose, but not good enough for kernel.org)