From mboxrd@z Thu Jan 1 00:00:00 1970 From: Mel Gorman Subject: Re: [PATCH v2 1/4] mm: refactoring TLB gathering API Date: Tue, 1 Aug 2017 11:30:55 +0100 Message-ID: <20170801103032.h7tnxryoxx7k7aqg@techsingularity.net> References: <1501566977-20293-1-git-send-email-minchan@kernel.org> <1501566977-20293-2-git-send-email-minchan@kernel.org> Mime-Version: 1.0 Content-Type: text/plain; charset=iso-8859-15 Return-path: Content-Disposition: inline In-Reply-To: <1501566977-20293-2-git-send-email-minchan@kernel.org> Sender: linux-kernel-owner@vger.kernel.org To: Minchan Kim Cc: Andrew Morton , linux-kernel@vger.kernel.org, linux-mm@kvack.org, kernel-team , Ingo Molnar , Russell King , Tony Luck , Martin Schwidefsky , "David S. Miller" , Heiko Carstens , Yoshinori Sato , Jeff Dike , linux-arch@vger.kernel.org, Nadav Amit List-Id: linux-arch.vger.kernel.org On Tue, Aug 01, 2017 at 02:56:14PM +0900, Minchan Kim wrote: > This patch is ready for solving race problems caused by TLB batch. s/is ready/is a preparatory patch/ > For that, we will increase/decrease TLB flush pending count of > mm_struct whenever tlb_[gather|finish]_mmu is called. > > Before making it simple, this patch separates architecture specific > part and rename it to arch_tlb_[gather|finish]_mmu and generic part > just calls it. > > It shouldn't change any behavior. > > Cc: Ingo Molnar > Cc: Russell King > Cc: Tony Luck > Cc: Martin Schwidefsky > Cc: "David S. Miller" > Cc: Heiko Carstens > Cc: Yoshinori Sato > Cc: Jeff Dike > Cc: linux-arch@vger.kernel.org > Cc: Nadav Amit > Cc: Mel Gorman > Signed-off-by: Minchan Kim You could alias arch_generic_tlb_finish_mmu as arch_tlb_gather_mmu simiilar to how other arch-generic helpers are done to avoid some #ifdeffery but otherwise Acked-by: Mel Gorman -- Mel Gorman SUSE Labs From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from outbound-smtp04.blacknight.com ([81.17.249.35]:34776 "EHLO outbound-smtp04.blacknight.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751925AbdHAKic (ORCPT ); Tue, 1 Aug 2017 06:38:32 -0400 Received: from mail.blacknight.com (pemlinmail05.blacknight.ie [81.17.254.26]) by outbound-smtp04.blacknight.com (Postfix) with ESMTPS id EAE2A994A0 for ; Tue, 1 Aug 2017 10:30:59 +0000 (UTC) Date: Tue, 1 Aug 2017 11:30:55 +0100 From: Mel Gorman Subject: Re: [PATCH v2 1/4] mm: refactoring TLB gathering API Message-ID: <20170801103032.h7tnxryoxx7k7aqg@techsingularity.net> References: <1501566977-20293-1-git-send-email-minchan@kernel.org> <1501566977-20293-2-git-send-email-minchan@kernel.org> MIME-Version: 1.0 Content-Type: text/plain; charset=iso-8859-15 Content-Disposition: inline In-Reply-To: <1501566977-20293-2-git-send-email-minchan@kernel.org> Sender: linux-arch-owner@vger.kernel.org List-ID: To: Minchan Kim Cc: Andrew Morton , linux-kernel@vger.kernel.org, linux-mm@kvack.org, kernel-team , Ingo Molnar , Russell King , Tony Luck , Martin Schwidefsky , "David S. Miller" , Heiko Carstens , Yoshinori Sato , Jeff Dike , linux-arch@vger.kernel.org, Nadav Amit Message-ID: <20170801103055.DvW7Sh8wVvGj_Do2Z6exWbHgpJV_RMlxrAoBlTeNUOc@z> On Tue, Aug 01, 2017 at 02:56:14PM +0900, Minchan Kim wrote: > This patch is ready for solving race problems caused by TLB batch. s/is ready/is a preparatory patch/ > For that, we will increase/decrease TLB flush pending count of > mm_struct whenever tlb_[gather|finish]_mmu is called. > > Before making it simple, this patch separates architecture specific > part and rename it to arch_tlb_[gather|finish]_mmu and generic part > just calls it. > > It shouldn't change any behavior. > > Cc: Ingo Molnar > Cc: Russell King > Cc: Tony Luck > Cc: Martin Schwidefsky > Cc: "David S. Miller" > Cc: Heiko Carstens > Cc: Yoshinori Sato > Cc: Jeff Dike > Cc: linux-arch@vger.kernel.org > Cc: Nadav Amit > Cc: Mel Gorman > Signed-off-by: Minchan Kim You could alias arch_generic_tlb_finish_mmu as arch_tlb_gather_mmu simiilar to how other arch-generic helpers are done to avoid some #ifdeffery but otherwise Acked-by: Mel Gorman -- Mel Gorman SUSE Labs