From mboxrd@z Thu Jan 1 00:00:00 1970 From: Josh Poimboeuf Subject: Re: [PATCH RFC 1/5] cpu/speculation: Add 'cpu_spec_mitigations=' cmdline options Date: Fri, 5 Apr 2019 11:18:52 -0500 Message-ID: <20190405161852.nmpk22omgiety4df@treble> References: <20190405131211.GE23348@zn.tnic> <20190405142048.burthk2jnpcvi2om@treble> <20190405152059.GG23348@zn.tnic> <20190405160136.GI23348@zn.tnic> Mime-Version: 1.0 Content-Type: text/plain; charset=utf-8 Return-path: Content-Disposition: inline In-Reply-To: <20190405160136.GI23348@zn.tnic> Sender: linux-kernel-owner@vger.kernel.org To: Borislav Petkov Cc: linux-kernel@vger.kernel.org, x86@kernel.org, Thomas Gleixner , Ingo Molnar , "H . Peter Anvin" , Andy Lutomirski , Peter Zijlstra , Jiri Kosina , Waiman Long , Andrea Arcangeli , Jon Masters , Benjamin Herrenschmidt , Paul Mackerras , Michael Ellerman , linuxppc-dev@lists.ozlabs.org, Martin Schwidefsky , Heiko Carstens , linux-s390@vger.kernel.org, Catalin Marinas , Will Deacon , linux-arm-kernel@lists.infradead List-Id: linux-arch.vger.kernel.org On Fri, Apr 05, 2019 at 06:01:36PM +0200, Borislav Petkov wrote: > Thinking about this more, we can shave off the first 4 chars and have it > be: > > spec_mitigations= > > I think it is painfully clear which speculation mitigations we mean. And > the other switches don't have "cpu_" prefixes too so... Sure, I'm ok with renaming it to that, if there are no objections. -- Josh From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from mx1.redhat.com ([209.132.183.28]:59724 "EHLO mx1.redhat.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1726694AbfDEQTA (ORCPT ); Fri, 5 Apr 2019 12:19:00 -0400 Date: Fri, 5 Apr 2019 11:18:52 -0500 From: Josh Poimboeuf Subject: Re: [PATCH RFC 1/5] cpu/speculation: Add 'cpu_spec_mitigations=' cmdline options Message-ID: <20190405161852.nmpk22omgiety4df@treble> References: <20190405131211.GE23348@zn.tnic> <20190405142048.burthk2jnpcvi2om@treble> <20190405152059.GG23348@zn.tnic> <20190405160136.GI23348@zn.tnic> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline In-Reply-To: <20190405160136.GI23348@zn.tnic> Sender: linux-arch-owner@vger.kernel.org List-ID: To: Borislav Petkov Cc: linux-kernel@vger.kernel.org, x86@kernel.org, Thomas Gleixner , Ingo Molnar , "H . Peter Anvin" , Andy Lutomirski , Peter Zijlstra , Jiri Kosina , Waiman Long , Andrea Arcangeli , Jon Masters , Benjamin Herrenschmidt , Paul Mackerras , Michael Ellerman , linuxppc-dev@lists.ozlabs.org, Martin Schwidefsky , Heiko Carstens , linux-s390@vger.kernel.org, Catalin Marinas , Will Deacon , linux-arm-kernel@lists.infradead.org, linux-arch@vger.kernel.org, Greg Kroah-Hartman , Tyler Hicks , Linus Torvalds Message-ID: <20190405161852.J3TqENa9y83lBhAYYn8eztByCoQiDh2Y1fSB-W_bHHo@z> On Fri, Apr 05, 2019 at 06:01:36PM +0200, Borislav Petkov wrote: > Thinking about this more, we can shave off the first 4 chars and have it > be: > > spec_mitigations= > > I think it is painfully clear which speculation mitigations we mean. And > the other switches don't have "cpu_" prefixes too so... Sure, I'm ok with renaming it to that, if there are no objections. -- Josh