From: Pratyush Yadav <pratyush@kernel.org>
To: Jonathan Corbet <corbet@lwn.net>,
Shuah Khan <skhan@linuxfoundation.org>,
Mike Rapoport <rppt@kernel.org>,
Pasha Tatashin <pasha.tatashin@soleen.com>,
Pratyush Yadav <pratyush@kernel.org>,
Alexander Graf <graf@amazon.com>,
Andrew Morton <akpm@linux-foundation.org>,
David Hildenbrand <david@kernel.org>,
Lorenzo Stoakes <ljs@kernel.org>,
"Liam R. Howlett" <liam@infradead.org>,
Vlastimil Babka <vbabka@kernel.org>,
Suren Baghdasaryan <surenb@google.com>,
Michal Hocko <mhocko@suse.com>, Thomas Gleixner <tglx@kernel.org>,
Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
Dave Hansen <dave.hansen@linux.intel.com>,
"H. Peter Anvin" <hpa@zytor.com>,
Ard Biesheuvel <ardb@kernel.org>,
Ilias Apalodimas <ilias.apalodimas@linaro.org>,
Rob Herring <robh@kernel.org>,
Saravana Kannan <saravanak@kernel.org>,
Arnd Bergmann <arnd@arndb.de>, Baoquan He <baoquan.he@linux.dev>
Cc: x86@kernel.org, linux-doc@vger.kernel.org,
linux-kernel@vger.kernel.org, kexec@lists.infradead.org,
linux-mm@kvack.org, linux-efi@vger.kernel.org,
devicetree@vger.kernel.org, linux-arch@vger.kernel.org
Subject: [PATCH 0/4] kho: rename "scratch" to "bootmem"
Date: Tue, 11 Aug 2026 18:26:36 +0200 [thread overview]
Message-ID: <20260811162642.3504565-1-pratyush@kernel.org> (raw)
From: "Pratyush Yadav (Google)" <pratyush@kernel.org>
The term "KHO scratch" is vague and overloaded. It does not accurately
describe what the memory is for. This was discussed previously at [0].
The conclusion was to rename "KHO scratch" to "KHO bootmem", since this
is memory passed by the previous kernel for early boot allocations.
In addition, memblock does not care about the provenance of the memory.
It cares more about how it should use it. Use MEMBLOCK_KHO_NOPRSRV,
instead of MEMBLOCK_KHO_SCRATCH, to describe this memory to memblock.
This series does the renames. It also gets rid of a redundant Kconfig.
While the diffstat is big and scary, most of the changes are mechanical.
The most interesting functional change is in patch 4.
This series touches a lot of files across a lot of trees. But since all
of that is purely KHO-related code, I would like to collect ACKs from
the maintainers and take it via the liveupdate tree.
Ideally we should queue it in liveupdate/next early in the v7.4 cycle
since it will cause a lot of conflicts with other patches throughout the
KHO tree.
[0] https://lore.kernel.org/kexec/agHGOxSnP_VraH1M@kernel.org/T/#u
Pratyush Yadav (Google) (4):
memblock: get rid of CONFIG_MEMBLOCK_KHO_SCRATCH
memblock: rename KHO_SCRATCH to KHO_NOPRSRV
kho: rename KHO scratch to KHO bootmem
kho: rename kho_scratch= commandline parameter to kho_bootmem=
.../admin-guide/kernel-parameters.txt | 15 +-
Documentation/admin-guide/mm/kho.rst | 18 +-
Documentation/core-api/kho/index.rst | 36 +-
arch/x86/boot/compressed/kaslr.c | 12 +-
arch/x86/include/uapi/asm/setup_data.h | 4 +-
arch/x86/kernel/e820.c | 2 +-
arch/x86/kernel/kexec-bzimage64.c | 6 +-
arch/x86/kernel/setup.c | 2 +-
arch/x86/realmode/init.c | 2 +-
drivers/firmware/efi/efi-init.c | 6 +-
drivers/of/kexec.c | 16 +-
include/asm-generic/kexec_handover.h | 2 +-
include/linux/kexec.h | 2 +-
include/linux/kexec_handover.h | 16 +-
include/linux/memblock.h | 30 +-
kernel/liveupdate/Kconfig | 1 -
kernel/liveupdate/kexec_handover.c | 340 +++++++++---------
kernel/liveupdate/kexec_handover_debugfs.c | 24 +-
kernel/liveupdate/kexec_handover_internal.h | 4 +-
mm/Kconfig | 4 -
mm/memblock.c | 56 +--
mm/mm_init.c | 6 +-
tools/testing/memblock/internal.h | 2 +-
23 files changed, 302 insertions(+), 304 deletions(-)
base-commit: 352ebb57013a08679788bc18c7f9af90903db256
--
2.55.0.679.g6767b8d81c-goog
next reply other threads:[~2026-08-11 16:26 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-11 16:26 Pratyush Yadav [this message]
2026-08-11 16:26 ` [PATCH 1/4] memblock: get rid of CONFIG_MEMBLOCK_KHO_SCRATCH Pratyush Yadav
2026-08-11 16:26 ` [PATCH 2/4] memblock: rename KHO_SCRATCH to KHO_NOPRSRV Pratyush Yadav
2026-08-11 16:26 ` [PATCH 3/4] kho: rename KHO scratch to KHO bootmem Pratyush Yadav
2026-08-11 16:26 ` [PATCH 4/4] kho: rename kho_scratch= commandline parameter to kho_bootmem= Pratyush Yadav
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260811162642.3504565-1-pratyush@kernel.org \
--to=pratyush@kernel.org \
--cc=akpm@linux-foundation.org \
--cc=ardb@kernel.org \
--cc=arnd@arndb.de \
--cc=baoquan.he@linux.dev \
--cc=bp@alien8.de \
--cc=corbet@lwn.net \
--cc=dave.hansen@linux.intel.com \
--cc=david@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=graf@amazon.com \
--cc=hpa@zytor.com \
--cc=ilias.apalodimas@linaro.org \
--cc=kexec@lists.infradead.org \
--cc=liam@infradead.org \
--cc=linux-arch@vger.kernel.org \
--cc=linux-doc@vger.kernel.org \
--cc=linux-efi@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=ljs@kernel.org \
--cc=mhocko@suse.com \
--cc=mingo@redhat.com \
--cc=pasha.tatashin@soleen.com \
--cc=robh@kernel.org \
--cc=rppt@kernel.org \
--cc=saravanak@kernel.org \
--cc=skhan@linuxfoundation.org \
--cc=surenb@google.com \
--cc=tglx@kernel.org \
--cc=vbabka@kernel.org \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox