From mboxrd@z Thu Jan 1 00:00:00 1970 From: Nadav Amit Subject: Re: [PATCH v2 1/4] mm: refactoring TLB gathering API Date: Tue, 1 Aug 2017 17:46:14 -0700 Message-ID: <59138710-3EFB-4D59-BD5B-D97CAFEBF098@gmail.com> References: <1501566977-20293-1-git-send-email-minchan@kernel.org> <1501566977-20293-2-git-send-email-minchan@kernel.org> <20170801103032.h7tnxryoxx7k7aqg@techsingularity.net> Mime-Version: 1.0 (Mac OS X Mail 10.3 \(3273\)) Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: quoted-printable Return-path: In-Reply-To: <20170801103032.h7tnxryoxx7k7aqg@techsingularity.net> Sender: owner-linux-mm@kvack.org To: Minchan Kim Cc: Andrew Morton , LKML , "open list:MEMORY MANAGEMENT" , kernel-team , Ingo Molnar , Russell King , Tony Luck , Martin Schwidefsky , "David S. Miller" , Heiko Carstens , Yoshinori Sato , Jeff Dike , linux-arch@vger.kernel.org, Mel Gorman List-Id: linux-arch.vger.kernel.org Mel Gorman wrote: > On Tue, Aug 01, 2017 at 02:56:14PM +0900, Minchan Kim wrote: >> This patch is ready for solving race problems caused by TLB batch. >=20 > s/is ready/is a preparatory patch/ >=20 >> For that, we will increase/decrease TLB flush pending count of >> mm_struct whenever tlb_[gather|finish]_mmu is called. >>=20 >> Before making it simple, this patch separates architecture specific >> part and rename it to arch_tlb_[gather|finish]_mmu and generic part >> just calls it. >>=20 >> It shouldn't change any behavior. >>=20 >> Cc: Ingo Molnar >> Cc: Russell King >> Cc: Tony Luck >> Cc: Martin Schwidefsky >> Cc: "David S. Miller" >> Cc: Heiko Carstens >> Cc: Yoshinori Sato >> Cc: Jeff Dike >> Cc: linux-arch@vger.kernel.org >> Cc: Nadav Amit >> Cc: Mel Gorman >> Signed-off-by: Minchan Kim >=20 > You could alias arch_generic_tlb_finish_mmu as arch_tlb_gather_mmu > simiilar to how other arch-generic helpers are done to avoid some > #ifdeffery but otherwise Minchan, Andrew wishes me to send one series that combines both series. What = about this comment from Mel? It seems you intentionally did not want to alias them... BTW: patch 4 should add =E2=80=9C#include " - I=E2=80=99ll = add it.=20 Thanks, Nadav= -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@kvack.org. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: email@kvack.org From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from mail-pf0-f194.google.com ([209.85.192.194]:36924 "EHLO mail-pf0-f194.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751368AbdHBAqS (ORCPT ); Tue, 1 Aug 2017 20:46:18 -0400 Content-Type: text/plain; charset=utf-8 Mime-Version: 1.0 (Mac OS X Mail 10.3 \(3273\)) Subject: Re: [PATCH v2 1/4] mm: refactoring TLB gathering API From: Nadav Amit In-Reply-To: <20170801103032.h7tnxryoxx7k7aqg@techsingularity.net> Date: Tue, 1 Aug 2017 17:46:14 -0700 Content-Transfer-Encoding: quoted-printable Message-ID: <59138710-3EFB-4D59-BD5B-D97CAFEBF098@gmail.com> References: <1501566977-20293-1-git-send-email-minchan@kernel.org> <1501566977-20293-2-git-send-email-minchan@kernel.org> <20170801103032.h7tnxryoxx7k7aqg@techsingularity.net> Sender: linux-arch-owner@vger.kernel.org List-ID: To: Minchan Kim Cc: Andrew Morton , LKML , "open list:MEMORY MANAGEMENT" , kernel-team , Ingo Molnar , Russell King , Tony Luck , Martin Schwidefsky , "David S. Miller" , Heiko Carstens , Yoshinori Sato , Jeff Dike , linux-arch@vger.kernel.org, Mel Gorman Message-ID: <20170802004614.kYlXEcjE__sJP4o3aunED-oqivqkbiohRfVP478UhMw@z> Mel Gorman wrote: > On Tue, Aug 01, 2017 at 02:56:14PM +0900, Minchan Kim wrote: >> This patch is ready for solving race problems caused by TLB batch. >=20 > s/is ready/is a preparatory patch/ >=20 >> For that, we will increase/decrease TLB flush pending count of >> mm_struct whenever tlb_[gather|finish]_mmu is called. >>=20 >> Before making it simple, this patch separates architecture specific >> part and rename it to arch_tlb_[gather|finish]_mmu and generic part >> just calls it. >>=20 >> It shouldn't change any behavior. >>=20 >> Cc: Ingo Molnar >> Cc: Russell King >> Cc: Tony Luck >> Cc: Martin Schwidefsky >> Cc: "David S. Miller" >> Cc: Heiko Carstens >> Cc: Yoshinori Sato >> Cc: Jeff Dike >> Cc: linux-arch@vger.kernel.org >> Cc: Nadav Amit >> Cc: Mel Gorman >> Signed-off-by: Minchan Kim >=20 > You could alias arch_generic_tlb_finish_mmu as arch_tlb_gather_mmu > simiilar to how other arch-generic helpers are done to avoid some > #ifdeffery but otherwise Minchan, Andrew wishes me to send one series that combines both series. What = about this comment from Mel? It seems you intentionally did not want to alias them... BTW: patch 4 should add =E2=80=9C#include " - I=E2=80=99ll = add it.=20 Thanks, Nadav=