messages from 2026-09-02 11:56:56 to 2026-09-08 20:19:08 UTC [more...]
[PATCH 00/39] mm: make VMA flag semantics explicit, eliminate VM_SPECIAL
2026-09-08 20:01 UTC (36+ messages)
` [PATCH 01/39] mm/vma: predicate setting mmap_prepare VMA fields on new vma alloc
` [PATCH 02/39] mm/vma: introduce and use vma_[flags_]can_merge()
` [PATCH 03/39] mm: consistently validate VMA state after mmap[_prepare] hooks
` [PATCH 04/39] mm/vma: ensure mmap_prepare doesn't set actions on a mergeable vma
` [PATCH 05/39] mm: make map_kernel_pages_[prepare,complete] internal and unexported
` [PATCH 06/39] mm/vma: tidy up map kernel pages enum values
` [PATCH 07/39] mm: add mmap action for discontiguous kernel page mapping
` [PATCH 08/39] docs: filesystems: update mmap_prepare docs for discontig kernel pgs
` [PATCH 09/39] drivers/usb/mon: update to use mmap_prepare + map kernel pages
` [PATCH 10/39] infiniband: update hfi1 to use remap_vmalloc_range()
` [PATCH 11/39] selinux: reject writable opens of policy file, drop mmap shared/write check
` [PATCH 12/39] ALSA: pcm: use vm_insert_page() to map PCM status page
` [PATCH 13/39] bpf: arena: mark arena_map_mmap() mappings VM_MIXEDMAP
` [PATCH 14/39] mm/vma: add vma[_flags]_is_kernel_owned() predicates
` [PATCH 15/39] mm/vma: only allow mmap to clear VMA_MAYWRITE_BIT if kernel-owned
` [PATCH 16/39] mm/vma: add and use vma_[flags]_is_fixed_mapping
` [PATCH 17/39] scsi: sg: convert mmap hook to mmap_prepare and rework
` [PATCH 18/39] fbdev: defio: assert FBINFO_VIRTFB, drop VM_IO, add VM_MIXEDMAP
` [PATCH 19/39] HSI: cmt_speech: convert mmap hook to mmap_prepare, refactor
` [PATCH 20/39] mm/gup: error out early on !VMA_MAYREAD_BIT VMAs
` [PATCH 21/39] uprobes: remove VM_IO, set VM_MIXEDMAP for mapped kernel pages
` [PATCH 22/39] mm/mlock: clear VMA_LOCKED_MASK over mmap callback
` [PATCH 23/39] mm/mlock: eliminate weird VMA_IO_BIT abuse and simplify
` [PATCH 24/39] mm/vma: enforce that only kernel-owned mappings may set VMA_IO_BIT
` [PATCH 25/39] mm: remove VMA_IO_BIT check in vma[_flags]_is_kernel_owned()
` [PATCH 26/39] mm: remove hugetlb_inline.h
` [PATCH 27/39] mm: rename is_vm_hugetlb_page() to vma_is_hugetlb()
` [PATCH 28/39] mm: drop some redundant checks around hugetlb VMAs
` [PATCH 29/39] mm/madvise: update is_valid_guard_vma() to use vma_can_merge()
` [PATCH 30/39] mm/vma: introduce vma[_flags]_is_persistent()
` [PATCH 31/39] mm/uffd: use predicates for userfaultfd checks
` [PATCH 32/39] mm/madvise: use predicates for madvise(..., MADV_DOFORK)
` [PATCH 33/39] mm: eliminate VMA_SPECIAL_FLAGS usage when hugetlb explicitly tested
` [PATCH 34/39] mm: eliminate VMA_SPECIAL_FLAGS check in lru_gen_look_around()
` [PATCH 35/39] mm: avoid use of VMA_SPECIAL_FLAGS in migrate_vma_setup()
[PATCH v2 0/4] kho: rename "scratch" to "bootmem"
2026-09-08 15:56 UTC (5+ messages)
` [PATCH v2 1/4] memblock: get rid of CONFIG_MEMBLOCK_KHO_SCRATCH
` [PATCH v2 2/4] memblock: rename KHO_SCRATCH to KHO_NOPRSRV
` [PATCH v2 3/4] kho: rename KHO scratch to KHO bootmem
` [PATCH v2 4/4] kho: rename kho_scratch= commandline parameter to kho_bootmem=
[PATCH v2 00/12] mm: make userland page table freeing RCU-safe
2026-09-08 12:32 UTC (13+ messages)
` [PATCH v2 01/12] mm/huge_memory: zap deposited page tables after an RCU grace period
` [PATCH v2 02/12] mm: enable MMU_GATHER_RCU_TABLE_FREE for most 2-level architectures
` [PATCH v2 03/12] mm: enable MMU_GATHER_RCU_TABLE_FREE for MMU riscv
` [PATCH v2 04/12] mm: enable MMU_GATHER_RCU_TABLE_FREE for MMU arm
` [PATCH v2 05/12] mm: enable MMU_GATHER_RCU_TABLE_FREE for arc, microblaze, xtensa
` [PATCH v2 06/12] mm: enable MMU_GATHER_RCU_TABLE_FREE for sparc64
` [PATCH v2 07/12] mm: enable MMU_GATHER_RCU_TABLE_FREE for m68k-coldfire
` [PATCH v2 08/12] mm: enable MMU_GATHER_RCU_TABLE_FREE for sh-X2
` [PATCH v2 09/12] mm: enable MMU_GATHER_RCU_TABLE_FREE for m68k-motorola
` [PATCH v2 10/12] mm: enable MMU_GATHER_RCU_TABLE_FREE for sparc32
` [PATCH v2 11/12] mm: make userland page table freeing RCU-safe
` [PATCH v2 12/12] mm: change the contract for free_pgtables(), update docs
[PATCH 00/12] mm: make userland page table freeing RCU-safe
2026-09-08 11:29 UTC (11+ messages)
` [PATCH 05/12] mm: enable MMU_GATHER_RCU_TABLE_FREE for arc, microblaze, xtensa
` [PATCH 12/12] mm: change the contract for free_pgtables(), update docs
[PATCH v5 0/5] Hyper-V: Add para-virtualized IOMMU support for Linux guests
2026-09-08 3:16 UTC (12+ messages)
` [PATCH v5 1/5] hyperv: Introduce new hypercall interfaces used by Hyper-V guest IOMMU
` [PATCH v5 2/5] Drivers: hv: Add logical device ID registry for vPCI devices
` [PATCH v5 3/5] iommu/x86: Add architectural MSI reserved region helper
` [PATCH v5 4/5] iommu/hyperv: Add para-virtualized IOMMU support for Hyper-V guest
` [PATCH v5 5/5] iommu/hyperv: Add page-selective IOTLB flush support
[RFC PATCH v2 0/3] btrfs: add error injection support for checksum verification
2026-09-07 16:13 UTC (2+ messages)
[PATCH RFC v3 00/21] mm: change behavior of pXdp_get()/pXd_page() in compile-time folded pgtable
2026-09-07 8:06 UTC (26+ messages)
` [PATCH RFC v3 02/21] ARM: mm: make 2-level pgd_t a scalar
` [PATCH RFC v3 03/21] ARM: mm: remove custom pgdp_get()
` [PATCH RFC v3 04/21] LoongArch: mm: define pud_leaf() only when PUD exists
` [PATCH RFC v3 05/21] MIPS: "
` [PATCH RFC v3 06/21] mm/pgtable: define (pgd|p4d|pud)_leaf() for folded page tables
` [PATCH RFC v3 07/21] mm/pgtable: define (pgd|p4d|pud)_offset_lockless() "
` [PATCH RFC v3 08/21] mm: vmscan: remove stack copy address of pud/pmd pass in walk_pud/pmd_range()
` [PATCH RFC v3 09/21] loongarch: kvm: remove stack copy address of pXd in pXd_offset()
` [PATCH RFC v3 10/21] riscv: "
` [PATCH RFC v3 11/21] riscv: mm: use proper set_pXd() for generic compile-time folded patable in vmalloc_fault()
` [PATCH RFC v3 12/21] mm/pgtable: redefine PGTABLE_LEVEL enum with ascend order from PGD
` [PATCH RFC v3 13/21] x86: mm: use pgtable_level enum in effective_prot_pXd()
` [PATCH RFC v3 14/21] x86: mm: carve out the generic compile-time folded pgtable case in effective_prot()
` [PATCH RFC v3 15/21] x86: mm: skip collapse_pud_page() when CONFIG_X86_DIRECT_GBPAGES disabled
` [PATCH RFC v3 16/21] openrisc/pgtable: drop __pmd_offset()
` [PATCH RFC v3 17/21] mm/pgtable: optimize pmdp_get() and friends for folded pagetable levels
` [PATCH RFC v3 18/21] mm/pgtable: catch abuse of folded dummy pgd_t/p4d_t/pud_t
` [PATCH RFC v3 19/21] mm/pgtable: disallow calling (pgd|p4d|pud)_page, pgd_page_vaddr() and (p4d|pud)_pgtable with dummy
` [PATCH RFC v3 20/21] mm/pgtable: disallow calling folded set_pgd/set_p4d/set_pud "
` [PATCH RFC v3 21/21] Documentation: mm: clarify behaviour of compile-time folded page tables
[PATCH v10 0/2] module: Extend module_blacklist parameter to built-in modules
2026-09-06 14:08 UTC (11+ messages)
` [PATCH v10 1/2] "
` [PATCH v10 2/2] module: Rename module_blacklist to module_denylist
[RFC PATCH 00/24] pidfd: add a minimal process spawn builder
2026-09-06 10:50 UTC (5+ messages)
[PATCH v8 00/43] dyndbg: fix classmaps API for DRM, query extensions, and selftests
2026-09-05 18:13 UTC (44+ messages)
` [PATCH v8 01/43] selftests/dyndbg: Add kselftest script to verify dynamic-debug
` [PATCH v8 02/43] drm: Fix incorrect ccflags-y spelling inside Makefile
` [PATCH v8 03/43] drm: fix config dependent unused variable warning
` [PATCH v8 04/43] drm: Mark CONFIG_DRM_USE_DYNAMIC_DEBUG as unBROKEN
` [PATCH v8 05/43] vmlinux.lds.h: refactor BOUNDED_SECTION_* macros into bounded_sections.lds.h
` [PATCH v8 06/43] vmlinux.lds.h: drop unused HEADERED_SECTION* macros
` [PATCH v8 07/43] vmlinux.lds.h: Fix ALIGN(8) omission causing NULL ptr on i386
` [PATCH v8 08/43] vmlinux.lds.h: remove redundant ALIGN(8) directives
` [PATCH v8 09/43] dyndbg.lds.S: fix lost dyndbg sections in modules
` [PATCH v8 10/43] dyndbg: factor ddebug_match_desc out from ddebug_change
` [PATCH v8 11/43] dyndbg: add stub macro for DECLARE_DYNDBG_CLASSMAP
` [PATCH v8 12/43] dyndbg: reword "class unknown," to "class:_UNKNOWN_"
` [PATCH v8 13/43] dyndbg-API: remove DD_CLASS_TYPE_(DISJOINT|LEVEL)_NAMES and code
` [PATCH v8 14/43] dyndbg: drop NUM_TYPE_ARGS
` [PATCH v8 15/43] dyndbg: bump num-tokens in a query-cmd from 9 to 15
` [PATCH v8 16/43] dyndbg: reduce verbose/debug clutter
` [PATCH v8 17/43] lib/parser: add match_wildcard_hyphen() for agnostic matching
` [PATCH v8 18/43] kbuild, dyndbg: clean up builtin module-name ambiguities
` [PATCH v8 19/43] dyndbg: refactor param_set_dyndbg_classes and below
` [PATCH v8 20/43] dyndbg: tighten fn-sig of ddebug_apply_class_bitmap
` [PATCH v8 21/43] dyndbg: replace classmap list with an array-slice
` [PATCH v8 22/43] dyndbg: macrofy a 2-index for-loop pattern
` [PATCH v8 23/43] dyndbg: reduce class param storage to u32
` [PATCH v8 24/43] dyndbg,module: make proper substructs in _ddebug_info
` [PATCH v8 25/43] dyndbg: move mod_name down from struct ddebug_table to _ddebug_info
` [PATCH v8 26/43] dyndbg: hoist classmap-filter-by-modname up to ddebug_add_module
` [PATCH v8 27/43] dyndbg-API: replace DECLARE_DYNDBG_CLASSMAP
` [PATCH v8 28/43] selftests/dyndbg: enable FT_classmap_inheritance
` [PATCH v8 29/43] dyndbg: detect class_id reservation conflicts
` [PATCH v8 30/43] dyndbg: check DYNAMIC_DEBUG_CLASSMAP_{DEFINE,USE_} args at compile-time
` [PATCH v8 31/43] dyndbg-test: add do_bulk testpoint, rename do_prints to do_classes
` [PATCH v8 32/43] dyndbg-API: promote DYNAMIC_DEBUG_CLASSMAP_PARAM to API
` [PATCH v8 33/43] dyndbg: control-parser: treat comma as a token separator
` [PATCH v8 34/43] selftests: enable comma-terminator tests
` [PATCH v8 35/43] dyndbg: split multi-query strings with @
` [PATCH v8 36/43] dyndbg: resolve "protection" of class'd pr_debug
` [PATCH v8 37/43] dyndbg: harden classmap and descriptor validation
` [PATCH v8 38/43] docs/dyndbg: add classmap info to howto
` [PATCH v8 39/43] dyndbg: Ignore additional arguments from pr_fmt
` [PATCH v8 40/43] dyndbg: add epilogue to dynamic_debug/control file
` [PATCH v8 41/43] dyndbg: add +c flag to count advantage of classmaps for DRM
` [PATCH v8 42/43] dyndbg: add DEBUG-biased fallback stubs for _dynamic_func_call_cls
` [PATCH v8 43/43] selftests/dynamic_debug: Prime params module with +p in FT_comma_terminators
[RFC PATCH 0/3] liveupdate: Move to feature flags for LUO and memfd ABI compatibility
2026-09-05 1:24 UTC (7+ messages)
` [RFC PATCH 1/3] luo: Move to feature flags instead of compatibility strings
` [RFC PATCH 2/3] luo: Export feature support to vmlinux section
` [RFC PATCH 3/3] luo: memfd: Move to feature flags instead of compatibility strings
[PATCH 1/5] asm-generic: fix typo "explicity" in comment
2026-09-04 23:59 UTC (4+ messages)
[PATCH] asm-generic: fix repeated word 'the' in comment
2026-09-04 21:19 UTC (2+ messages)
[PATCH v5 0/9] PCI passthru on Hyper-V
2026-09-04 0:10 UTC (9+ messages)
` [PATCH v5 3/9] mshv: Introduce basic mshv bridge device for VFIO to build upon
[PATCH v2 0/8] mm: distinguish PTE table storage from PTE values
2026-09-03 10:30 UTC (9+ messages)
` [PATCH v2 1/8] mm: introduce hw_pte_t for PTE table storage
` [PATCH v2 2/8] mm: rename pointers to software PTE values as ptentp
` [PATCH v2 3/8] mm: use hw_pte_t for generic PTE table storage
` [PATCH v2 4/8] mm: convert PTE table entries in ptep_get()
` [PATCH v2 5/8] mm: convert PTE table entry to pte
` [PATCH v2 6/8] mm/kasan: use hw_pte_t for the early shadow PTE table
` [PATCH v2 7/8] drm/i915: use hw_pte_t for PTE range callbacks
` [PATCH v2 8/8] xen: "
[PATCH v4 0/5] Hyper-V: Add para-virtualized IOMMU support for Linux guests
2026-09-03 8:09 UTC (7+ messages)
` [PATCH v4 4/5] iommu/hyperv: Add para-virtualized IOMMU support for Hyper-V guest
` [PATCH v4 5/5] iommu/hyperv: Add page-selective IOTLB flush support
[PATCH v2 00/15] exec: Remove AT_VECTOR_SIZE_ARCH from UAPI
2026-09-03 7:41 UTC (16+ messages)
` [PATCH v2 01/15] MAINTAINERS: exec: Add more auxvec.h variants
` [PATCH v2 02/15] auxvec.h: Move AT_VECTOR_SIZE definitions to linux/auxvec.h
` [PATCH v2 03/15] asm-generic: add an in-kernel auxvec.h header
` [PATCH v2 04/15] ARM: drop custom asm/auxvec.h
` [PATCH v2 05/15] x86: Remove AT_VECTOR_SIZE_ARCH from UAPI
` [PATCH v2 06/15] arm64: "
` [PATCH v2 07/15] RISC-V: "
` [PATCH v2 08/15] LoongArch: "
` [PATCH v2 09/15] s390: "
` [PATCH v2 10/15] powerpc: "
` [PATCH v2 11/15] MIPS: "
` [PATCH v2 12/15] sparc: "
` [PATCH v2 13/15] sh: "
` [PATCH v2 14/15] alpha: remove "
` [PATCH v2 15/15] auxvec.h: Drop fallback AT_VECTOR_SIZE_ARCH
[PATCH v11 3/7] mm: add a template-based fast path for zone-device page init
2026-09-03 2:58 UTC (2+ messages)
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox