From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from bombadil.infradead.org (bombadil.infradead.org [198.137.202.133]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.lore.kernel.org (Postfix) with ESMTPS id DE971C02198 for ; Fri, 14 Feb 2025 07:28:20 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=lists.infradead.org; s=bombadil.20210309; h=Sender:List-Subscribe:List-Help :List-Post:List-Archive:List-Unsubscribe:List-Id:Content-Transfer-Encoding: Content-Type:In-Reply-To:From:References:Cc:To:Subject:MIME-Version:Date: Message-ID:Reply-To:Content-ID:Content-Description:Resent-Date:Resent-From: Resent-Sender:Resent-To:Resent-Cc:Resent-Message-ID:List-Owner; bh=zSCjFfR20TU7hwUMrS4urDZFjwQFxtUiglQqA7+Ae/0=; b=jZCr61xz3pPlAsj1L0wXGKOlNV +157FtUrLZfho9Z0tSBWcl9CNdpYufqLSeq8xXy3axTkPp2aqhwd8Mw45raaBrFZ9RENYMR/Yqn9X RFiBzuYpsm1j3dKv3gOcWewHEjdB5cviNNvLRErOpnTVMW4//TI+bspS32s9o+TtDjFNIydVU4972 rvHmx1PV5HZnvaPR23v3m0EHUOW6C2BVsa+kphs7Yu4XGmAAqsD3zK2v0snfaZEOcHG/iB5PXf63W fuaQAj7znu2bWGhDNnV0OzAqpkmFkNLnn07XRX/kAf+JhSSbhHY5cnxe1jVuBXnJ41ZJvFVZyck7K 6iNlAHow==; Received: from localhost ([::1] helo=bombadil.infradead.org) by bombadil.infradead.org with esmtp (Exim 4.98 #2 (Red Hat Linux)) id 1tiq7O-0000000DxX2-3xBf; Fri, 14 Feb 2025 07:28:10 +0000 Received: from foss.arm.com ([217.140.110.172]) by bombadil.infradead.org with esmtp (Exim 4.98 #2 (Red Hat Linux)) id 1tiq5b-0000000DxCX-1qJt; Fri, 14 Feb 2025 07:26:20 +0000 Received: from usa-sjc-imap-foss1.foss.arm.com (unknown [10.121.207.14]) by usa-sjc-mx-foss1.foss.arm.com (Postfix) with ESMTP id A2A3D113E; Thu, 13 Feb 2025 23:26:38 -0800 (PST) Received: from [10.163.37.128] (unknown [10.163.37.128]) by usa-sjc-imap-foss1.foss.arm.com (Postfix) with ESMTPSA id 57E413F58B; Thu, 13 Feb 2025 23:26:08 -0800 (PST) Message-ID: <03b042ec-1cb7-4419-8741-c65e74e49d51@arm.com> Date: Fri, 14 Feb 2025 12:56:01 +0530 MIME-Version: 1.0 User-Agent: Mozilla Thunderbird Subject: Re: [PATCH 4/4] mm: Rename GENERIC_PTDUMP and PTDUMP_CORE To: Christophe Leroy , Steven Price , linux-mm@kvack.org Cc: Catalin Marinas , Will Deacon , Jonathan Corbet , Marc Zyngier , Michael Ellerman , Nicholas Piggin , Paul Walmsley , Palmer Dabbelt , Heiko Carstens , Vasily Gorbik , Thomas Gleixner , Ingo Molnar , Andrew Morton , linux-arm-kernel@lists.infradead.org, linux-doc@vger.kernel.org, linux-kernel@vger.kernel.org, kvmarm@lists.linux.dev, linuxppc-dev@lists.ozlabs.org, linux-riscv@lists.infradead.org, linux-s390@vger.kernel.org References: <20250213040934.3245750-1-anshuman.khandual@arm.com> <20250213040934.3245750-5-anshuman.khandual@arm.com> <8e75c5ff-a97b-4a6f-9c8b-ac2598eafe60@arm.com> <6e1201a1-60c1-40a3-951f-d603b6341a11@csgroup.eu> Content-Language: en-US From: Anshuman Khandual In-Reply-To: <6e1201a1-60c1-40a3-951f-d603b6341a11@csgroup.eu> Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit X-CRM114-Version: 20100106-BlameMichelson ( TRE 0.8.0 (BSD) ) MR-646709E3 X-CRM114-CacheID: sfid-20250213_232619_524450_8C1966B9 X-CRM114-Status: UNSURE ( 9.89 ) X-CRM114-Notice: Please train this message. X-BeenThere: linux-arm-kernel@lists.infradead.org X-Mailman-Version: 2.1.34 Precedence: list List-Id: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: "linux-arm-kernel" Errors-To: linux-arm-kernel-bounces+linux-arm-kernel=archiver.kernel.org@lists.infradead.org On 2/13/25 17:19, Christophe Leroy wrote: > > > Le 13/02/2025 à 12:23, Steven Price a écrit : >> On 13/02/2025 04:09, Anshuman Khandual wrote: >>> Platforms subscribe into generic ptdump implementation via GENERIC_PTDUMP. >>> But generic ptdump gets enabled via PTDUMP_CORE. These configs combination >>> is confusing as they sound very similar and does not differentiate between >>> platform's feature subscription and feature enablement for ptdump. Rename >>> the configs as ARCH_HAS_PTDUMP and PTDUMP making it more clear and improve >>> readability. >> >> [...] >>> diff --git a/arch/powerpc/configs/mpc885_ads_defconfig b/arch/powerpc/configs/mpc885_ads_defconfig >>> index 77306be62e9e..db005618690b 100644 >>> --- a/arch/powerpc/configs/mpc885_ads_defconfig >>> +++ b/arch/powerpc/configs/mpc885_ads_defconfig >>> @@ -78,4 +78,4 @@ CONFIG_DEBUG_VM_PGTABLE=y >>>   CONFIG_DETECT_HUNG_TASK=y >>>   CONFIG_BDI_SWITCH=y >>>   CONFIG_PPC_EARLY_DEBUG=y >>> -CONFIG_GENERIC_PTDUMP=y >>> +CONFIG_PTDUMP=y >> >> I'd suggest dropp this from the defconfig too, just like patch 1 dropped >> it from debug.config. >> > > Thanks for spotting that. > > That one is wrong. Was introduced by commit d210ee3fdfe8 ("powerpc/configs: Update config files for removed/renamed symbols") which aimed at fixing commit e084728393a5 ("powerpc/ptdump: Convert powerpc to GENERIC_PTDUMP") but it did it wrong. > > It is CONFIG_PTDUMP_DEBUGFS that is wanted. Should this replacement be done in the series or would you like it to be handled in powerpc later ?