From: vinod.koul@intel.com (Koul, Vinod)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH v2 1/5] dmaengine: at_hdmac: modify way to use interrupts
Date: Tue, 26 Apr 2011 09:54:41 +0530 [thread overview]
Message-ID: <1303791881.896.18.camel@vkoul-udesk3> (raw)
In-Reply-To: <20110426043408.GG12904@game.jcrosoft.org>
On Tue, 2011-04-26 at 10:04 +0530, Jean-Christophe PLAGNIOL-VILLARD
wrote:
> On 09:32 Tue 26 Apr , Koul, Vinod wrote:
> > On Fri, 2011-04-22 at 19:41 +0200, Nicolas Ferre wrote:
> > > Now we use Buffer Transfer Completed interrupts. If we
> > > want a chained buffer completed information, we setup the
> > > ATC_IEN bit in CTRLB register in the lli.
> > > This is done by set_desc_eol() function and used by
> > > memcpy/slave_sg functions.
> > >
> > > Signed-off-by: Nicolas Ferre <nicolas.ferre@atmel.com>
> > > ---
> > > drivers/dma/at_hdmac.c | 4 ++--
> > > drivers/dma/at_hdmac_regs.h | 11 ++++++++---
> > > 2 files changed, 10 insertions(+), 5 deletions(-)
> > >
> > >
> > Looks like your forgot to run checkpatch
> > WARNING: line over 80 characters
> > #401: FILE: drivers/dma/at_hdmac_regs.h:106:
> > +#define MEM_IF 0 /* specify AHB interface 0 as memory interface */
> >
> > WARNING: line over 80 characters
> > #402: FILE: drivers/dma/at_hdmac_regs.h:107:
> > +#define PER_IF 1 /* specify AHB interface 1 as peripheral interface
> > */
> >
> > WARNING: line over 80 characters
> > #689: FILE: drivers/dma/at_hdmac.c:899:
> > + direction == DMA_TO_DEVICE ? "TO DEVICE" : "FROM DEVICE",
> >
> > total: 0 errors, 3 warnings, 465 lines checked
> >
> > While I am okay with 3rd one, you can easily reformat code for first two
> > and avoid these two warnings...
> It's comments it make it more readable
And that's why it can be easily reformatted without sacrificing code
readability and also avoid the warnings.
These warnings should be removed wherever its possible without
sacrificing code readability, something like:
+/* AHB interface defines */
+#define MEM_IF 0 /* 0 as memory interface */
+#define PER_IF 1 /* 1 as peripheral interface
and while at it, you need to fix these for namespace
--
~Vinod
next prev parent reply other threads:[~2011-04-26 4:24 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-04-01 17:19 [PATCH 1/5] dmaengine: at_hdmac: modify way to use interrupts Nicolas Ferre
2011-04-01 17:19 ` [PATCH 2/5] dmaengine: at_hdmac: add cyclic DMA operation support Nicolas Ferre
2011-04-06 10:08 ` Koul, Vinod
2011-04-06 12:50 ` Nicolas Ferre
2011-04-06 14:02 ` Koul, Vinod
2011-04-06 15:45 ` Nicolas Ferre
2011-04-01 17:19 ` [PATCH 3/5] dmaengine: at_hdmac: debug information sg_len for prep_slave_sg Nicolas Ferre
2011-04-01 17:19 ` [PATCH 4/5] dmaengine: at_hdmac: remove channel status testing in tasklet Nicolas Ferre
2011-04-01 17:19 ` [PATCH 5/5] dmaengine: at_hdmac: specialize AHB interfaces to optimize transfers Nicolas Ferre
2011-04-22 17:41 ` [PATCH v2 1/5] dmaengine: at_hdmac: modify way to use interrupts Nicolas Ferre
2011-04-26 4:02 ` Koul, Vinod
2011-04-26 4:06 ` Koul, Vinod
2011-04-26 4:34 ` Jean-Christophe PLAGNIOL-VILLARD
2011-04-26 4:24 ` Koul, Vinod [this message]
2011-04-30 14:57 ` [PATCH v3 4/5] dmaengine: at_hdmac: remove channel status testing in tasklet Nicolas Ferre
[not found] ` <35f32b2bdf51d9d5867ca352ce96d786c74a58eb.1304174965.git.nicolas.ferre@atmel.com>
2011-05-02 10:14 ` [PATCH v3 1/5] dmaengine: at_hdmac: modify way to use interrupts Koul, Vinod
2011-04-22 17:41 ` [PATCH v2 2/5] dmaengine: at_hdmac: add cyclic DMA operation support Nicolas Ferre
2011-04-22 17:41 ` [PATCH v2 3/5] dmaengine: at_hdmac: debug information sg_len for prep_slave_sg Nicolas Ferre
2011-04-22 17:42 ` [PATCH v2 4/5] dmaengine: at_hdmac: remove channel status testing in tasklet Nicolas Ferre
2011-04-22 17:42 ` [PATCH v2 5/5] dmaengine: at_hdmac: specialize AHB interfaces to optimize transfers Nicolas Ferre
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1303791881.896.18.camel@vkoul-udesk3 \
--to=vinod.koul@intel.com \
--cc=linux-arm-kernel@lists.infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox