From mboxrd@z Thu Jan 1 00:00:00 1970 From: thunder.leizhen@huawei.com (Zhen Lei) Date: Tue, 7 Jun 2016 16:08:10 +0800 Subject: [PATCH v4 06/14] of_numa: Use of_get_next_parent to simplify code In-Reply-To: <1465286898-13828-1-git-send-email-thunder.leizhen@huawei.com> References: <1465286898-13828-1-git-send-email-thunder.leizhen@huawei.com> Message-ID: <1465286898-13828-7-git-send-email-thunder.leizhen@huawei.com> To: linux-arm-kernel@lists.infradead.org List-Id: linux-arm-kernel.lists.infradead.org From: Kefeng Wang Use of_get_next_parent() instead of open-code. Signed-off-by: Kefeng Wang --- drivers/of/of_numa.c | 6 +----- 1 file changed, 1 insertion(+), 5 deletions(-) diff --git a/drivers/of/of_numa.c b/drivers/of/of_numa.c index 3157130..ed7bd22 100644 --- a/drivers/of/of_numa.c +++ b/drivers/of/of_numa.c @@ -153,8 +153,6 @@ int of_node_to_nid(struct device_node *device) np = of_node_get(device); while (np) { - struct device_node *parent; - r = of_property_read_u32(np, "numa-node-id", &nid); /* * -EINVAL indicates the property was not found, and @@ -165,9 +163,7 @@ int of_node_to_nid(struct device_node *device) if (r != -EINVAL) break; - parent = of_get_parent(np); - of_node_put(np); - np = parent; + np = of_get_next_parent(np); } if (np && r) pr_warn("NUMA: Invalid \"numa-node-id\" property in node %s\n", -- 2.5.0