From mboxrd@z Thu Jan 1 00:00:00 1970 From: linuxzsc@gmail.com (Richard Zhao) Date: Sun, 16 Jan 2011 23:25:34 +0800 Subject: [PATCH 2/2] arm: mx50_rdp: add i2c bus support In-Reply-To: References: <1294988137-24654-1-git-send-email-richard.zhao@freescale.com> <1294988137-24654-2-git-send-email-richard.zhao@freescale.com> Message-ID: <20110116152300.GA26203@richard-laptop> To: linux-arm-kernel@lists.infradead.org List-Id: linux-arm-kernel.lists.infradead.org Hi Jason, On Sat, Jan 15, 2011 at 12:10:34AM +0800, Jason Liu wrote: > Hi, Richard, > > 2011/1/14 Richard Zhao : > > On Fri, Jan 14, 2011 at 10:27 PM, Jason Liu wrote: > >> Hi, Richard, > >> > >> 2011/1/14 Richard Zhao : > >>> Signed-off-by: Richard Zhao > >>> --- > >>> ?arch/arm/mach-mx5/board-mx50_rdp.c ? ? ? ? ? | ? ?7 +++++++ > >>> ?arch/arm/mach-mx5/devices-mx50.h ? ? ? ? ? ? | ? ?3 +++ > >> > >> We need align the naming convention with i.mx53/i.mx50 fordevices-mx50.h , > >> I have send out one patch for it.It seems not good when using devices-mx50.h > >> while using devices-imx53 and devices-imx51.h in the same directory. > >> > >> I think we need use imx as much as possible since i.mx is FSL chip brand name. > >> > >> Sascha, please help merge the following patch if you don't have some > >> comments about it. > >> http://lists.arm.linux.org.uk/lurker/message/20110110.223149.e2d1fe51.en.html > > I have comments on that thread too. I past here: > > I noticed that too. Sometimes we use imx as part of file name or macro > > name, but other times we use mx . We'd better make some rule that when > > and where we suppose to use what. > > I suggest we move all to mx for short. Reasons: > > - For freescale internal, starting from mx5, we all use mx. > > - macros in soc header files all use mx. > > - soc header file name all use mx too. > > - mach-types all use mx. (count in freescale board only) > > No, I prefer to use imx since imx is the chip brand and FSL IC doc > stat it clearly it's i.mx. > And the most important is to keep compatible, we had better keep the > same naming convention. > Otherwise, it will make the directory a little mess. I don't care much what we use. I just think we'd better have a rule to tell when which should be used. Anyway, it's out of this patch. Sascha/Uwe, Is this patch series ok? Thanks Richard > > > > > Thanks > > Richard > >> > >> BR, > >> Jason > >> > >>> _______________________________________________ > >>> linux-arm-kernel mailing list > >>> linux-arm-kernel at lists.infradead.org > >>> http://lists.infradead.org/mailman/listinfo/linux-arm-kernel > >>> > >> > >