From: jeyu@redhat.com (Jessica Yu)
To: linux-arm-kernel@lists.infradead.org
Subject: arch: Rename CONFIG_DEBUG_RODATA and CONFIG_DEBUG_MODULE_RONX
Date: Tue, 7 Feb 2017 11:25:05 -0800 [thread overview]
Message-ID: <20170207192505.m5gg6rtqgbbwtwa4@jeyu> (raw)
In-Reply-To: <1486427518-14819-3-git-send-email-labbott@redhat.com>
+++ Laura Abbott [06/02/17 16:31 -0800]:
>Both of these options are poorly named. The features they provide are
>necessary for system security and should not be considered debug only.
>Change the names to CONFIG_STRICT_KERNEL_RWX and
>CONFIG_STRICT_MODULE_RWX to better describe what these options do.
>
>Signed-off-by: Laura Abbott <labbott@redhat.com>
>---
>v3: Minor config text tweek per Kees. Corrected the change of config names in
>the arm config files.
>---
> Documentation/DocBook/kgdb.tmpl | 8 ++++----
> Documentation/security/self-protection.txt | 4 ++--
> arch/Kconfig | 4 ++--
> arch/arm/configs/aspeed_g4_defconfig | 4 ++--
> arch/arm/configs/aspeed_g5_defconfig | 4 ++--
> arch/arm/include/asm/cacheflush.h | 2 +-
> arch/arm/kernel/patch.c | 4 ++--
> arch/arm/kernel/vmlinux.lds.S | 8 ++++----
> arch/arm/mm/Kconfig | 2 +-
> arch/arm/mm/init.c | 4 ++--
> arch/arm64/Kconfig.debug | 2 +-
> arch/arm64/kernel/insn.c | 2 +-
> arch/parisc/configs/712_defconfig | 1 -
> arch/parisc/configs/c3000_defconfig | 1 -
> arch/parisc/mm/init.c | 2 +-
> include/linux/filter.h | 4 ++--
> include/linux/init.h | 4 ++--
> include/linux/module.h | 2 +-
> init/main.c | 4 ++--
> kernel/configs/android-recommended.config | 2 +-
> kernel/module.c | 6 +++---
> kernel/power/hibernate.c | 2 +-
> kernel/power/power.h | 4 ++--
> kernel/power/snapshot.c | 4 ++--
> 24 files changed, 41 insertions(+), 43 deletions(-)
For the module.{c,h} bits:
Acked-by: Jessica Yu <jeyu@redhat.com>
next prev parent reply other threads:[~2017-02-07 19:25 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-02-07 0:31 [PATCHv3 0/2] Hardening configs refactor/rename Laura Abbott
2017-02-07 0:31 ` [PATCHv3 1/2] arch: Move CONFIG_DEBUG_RODATA and CONFIG_SET_MODULE_RONX to be common Laura Abbott
2017-02-07 7:16 ` Ingo Molnar
2017-02-07 11:42 ` Heiko Carstens
2017-02-07 0:31 ` [PATCHv3 2/2] arch: Rename CONFIG_DEBUG_RODATA and CONFIG_DEBUG_MODULE_RONX Laura Abbott
2017-02-07 19:25 ` Jessica Yu [this message]
2017-02-16 22:25 ` Pavel Machek
2017-02-17 1:08 ` Kees Cook
2017-02-17 8:22 ` Helge Deller
2017-02-17 18:23 ` Mark Rutland
2017-02-20 7:21 ` Ingo Molnar
2017-02-07 21:06 ` [PATCHv3 0/2] Hardening configs refactor/rename Kees Cook
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20170207192505.m5gg6rtqgbbwtwa4@jeyu \
--to=jeyu@redhat.com \
--cc=linux-arm-kernel@lists.infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox