From: juri.lelli@arm.com (Juri Lelli)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH V2 4/5] arch_topology: Return 0 or -ve errors from topology_parse_cpu_capacity()
Date: Thu, 22 Jun 2017 10:39:57 +0100 [thread overview]
Message-ID: <20170622093957.vlhacauj4vff64bv@e106622-lin> (raw)
In-Reply-To: <2213a1f0657ef057dd775085943b362dc3e9757d.1498019799.git.viresh.kumar@linaro.org>
Hi,
On 21/06/17 10:16, Viresh Kumar wrote:
> Use the standard way of returning errors instead of returning 0(failure)
> OR 1(success) and making it hard to read.
>
> Signed-off-by: Viresh Kumar <viresh.kumar@linaro.org>
> ---
> arch/arm/kernel/topology.c | 2 +-
> drivers/base/arch_topology.c | 8 ++++----
> 2 files changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/arch/arm/kernel/topology.c b/arch/arm/kernel/topology.c
> index bf949a763dbe..a7ef4c35855e 100644
> --- a/arch/arm/kernel/topology.c
> +++ b/arch/arm/kernel/topology.c
> @@ -111,7 +111,7 @@ static void __init parse_dt_topology(void)
> continue;
> }
>
> - if (topology_parse_cpu_capacity(cn, cpu)) {
> + if (!topology_parse_cpu_capacity(cn, cpu)) {
Not sure why you want to change this.
I currently read it as "if cpu_capacity parsing succedeed" continue with
next CPU, otherwise we set cap_from_dt to false and fall back to using
efficiencies.
Thanks,
- Juri
next prev parent reply other threads:[~2017-06-22 9:39 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-06-21 4:46 [PATCH V2 0/5] arch_topology: Minor cleanups Viresh Kumar
2017-06-21 4:46 ` [PATCH V2 1/5] arch_topology: Get rid of "cap_parsing_done" Viresh Kumar
2017-06-22 9:44 ` Juri Lelli
2017-06-22 14:29 ` Viresh Kumar
2017-06-22 16:44 ` Juri Lelli
2017-06-21 4:46 ` [PATCH V2 2/5] arch_topology: Don't break lines unnecessarily Viresh Kumar
2017-06-21 4:46 ` [PATCH V2 3/5] arch_topology: Covert switch block to if block Viresh Kumar
2017-06-21 4:46 ` [PATCH V2 4/5] arch_topology: Return 0 or -ve errors from topology_parse_cpu_capacity() Viresh Kumar
2017-06-22 9:39 ` Juri Lelli [this message]
2017-06-22 14:28 ` Viresh Kumar
2017-06-22 16:43 ` Juri Lelli
2017-06-21 4:46 ` [PATCH V2 5/5] arch_topology: Localize cap_parsing_failed to topology_parse_cpu_capacity() Viresh Kumar
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20170622093957.vlhacauj4vff64bv@e106622-lin \
--to=juri.lelli@arm.com \
--cc=linux-arm-kernel@lists.infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox