From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-3.0 required=3.0 tests=DKIMWL_WL_HIGH,DKIM_SIGNED, DKIM_VALID,HEADER_FROM_DIFFERENT_DOMAINS,MAILING_LIST_MULTI,SPF_PASS, URIBL_BLOCKED,USER_AGENT_NEOMUTT autolearn=ham autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 73246C10F11 for ; Wed, 24 Apr 2019 16:17:43 +0000 (UTC) Received: from bombadil.infradead.org (bombadil.infradead.org [198.137.202.133]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by mail.kernel.org (Postfix) with ESMTPS id 40770208E4 for ; Wed, 24 Apr 2019 16:17:43 +0000 (UTC) Authentication-Results: mail.kernel.org; dkim=pass (2048-bit key) header.d=lists.infradead.org header.i=@lists.infradead.org header.b="a64l+D1F" DMARC-Filter: OpenDMARC Filter v1.3.2 mail.kernel.org 40770208E4 Authentication-Results: mail.kernel.org; dmarc=fail (p=none dis=none) header.from=redhat.com Authentication-Results: mail.kernel.org; spf=none smtp.mailfrom=linux-arm-kernel-bounces+infradead-linux-arm-kernel=archiver.kernel.org@lists.infradead.org DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=lists.infradead.org; s=bombadil.20170209; h=Sender: Content-Transfer-Encoding:Content-Type:Cc:List-Subscribe:List-Help:List-Post: List-Archive:List-Unsubscribe:List-Id:In-Reply-To:MIME-Version:References: Message-ID:Subject:To:From:Date:Reply-To:Content-ID:Content-Description: Resent-Date:Resent-From:Resent-Sender:Resent-To:Resent-Cc:Resent-Message-ID: List-Owner; bh=Da914IaOoMs16DXqArUlv0Edi1SmlvN6NrSX7D4PkRw=; b=a64l+D1F11ch1S uXWSkwTyEnPC6/KYCpgap7V3MsZQ+cR4AMn5ynI8bAKDPLNZsieIpQaDKernk2rD62VEtuznYldpE yl8FWDKbYCswf0GsT2dxIiRno8R3z7vkeu1lDvzAAwDHxAl+uYdzx5e0kqy+ddHyCm87WuY780mJz mHc5l1Ys8wCmDQJd0fcjYEzdUWRIE1rW/LuFqhDWMi2LRB+qhBlAkq6hcbn0oYA/m4OwTQm2xy/N4 a0TRmT8iDPL90JVy9q0n6qOzPa9YOzSJn12PgKXdMydhYosPAkTJZaWAlFZrSwBkD7p1zcPUg2W4L ARsEdFqYQmU4pM6VwFqw==; Received: from localhost ([127.0.0.1] helo=bombadil.infradead.org) by bombadil.infradead.org with esmtp (Exim 4.90_1 #2 (Red Hat Linux)) id 1hJKaY-0004W3-IK; Wed, 24 Apr 2019 16:17:38 +0000 Received: from mx1.redhat.com ([209.132.183.28]) by bombadil.infradead.org with esmtps (Exim 4.90_1 #2 (Red Hat Linux)) id 1hJKaV-0004VX-9O for linux-arm-kernel@lists.infradead.org; Wed, 24 Apr 2019 16:17:36 +0000 Received: from smtp.corp.redhat.com (int-mx03.intmail.prod.int.phx2.redhat.com [10.5.11.13]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by mx1.redhat.com (Postfix) with ESMTPS id F0F2D89AE4; Wed, 24 Apr 2019 16:17:34 +0000 (UTC) Received: from treble (ovpn-123-99.rdu2.redhat.com [10.10.123.99]) by smtp.corp.redhat.com (Postfix) with ESMTPS id 0BB96608C1; Wed, 24 Apr 2019 16:17:33 +0000 (UTC) Date: Wed, 24 Apr 2019 11:17:32 -0500 From: Josh Poimboeuf To: Raphael Gault Subject: Re: [RFC 1/6] objtool: Refactor code to make it more suitable for multiple architecture support Message-ID: <20190424161732.lnttohdvhujtey64@treble> References: <20190409135243.12424-1-raphael.gault@arm.com> <20190409135243.12424-2-raphael.gault@arm.com> <20190423201306.wyb57hz7xrvqbn75@treble> <13212ab1-20fe-88c6-f121-acd8ea623757@arm.com> MIME-Version: 1.0 Content-Disposition: inline In-Reply-To: <13212ab1-20fe-88c6-f121-acd8ea623757@arm.com> User-Agent: NeoMutt/20180716 X-Scanned-By: MIMEDefang 2.79 on 10.5.11.13 X-Greylist: Sender IP whitelisted, not delayed by milter-greylist-4.5.16 (mx1.redhat.com [10.5.110.26]); Wed, 24 Apr 2019 16:17:35 +0000 (UTC) X-CRM114-Version: 20100106-BlameMichelson ( TRE 0.8.0 (BSD) ) MR-646709E3 X-CRM114-CacheID: sfid-20190424_091735_343906_165CBC3D X-CRM114-Status: GOOD ( 14.93 ) X-BeenThere: linux-arm-kernel@lists.infradead.org X-Mailman-Version: 2.1.21 Precedence: list List-Id: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Cc: Julien Thierry , "peterz@infradead.org" , Catalin Marinas , Will Deacon , "linux-kernel@vger.kernel.org" , "linux-arm-kernel@lists.infradead.org" Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Sender: "linux-arm-kernel" Errors-To: linux-arm-kernel-bounces+infradead-linux-arm-kernel=archiver.kernel.org@lists.infradead.org On Wed, Apr 24, 2019 at 04:11:57PM +0000, Raphael Gault wrote: > On 4/23/19 9:13 PM, Josh Poimboeuf wrote: > > arch_dest_rela_addend_offset() might be a more descriptive name. Also > > it might be simpler to just make it an arch-specific macro which is 0 on > > arm64 and 4 on x86. > > > > "compute" is implied, it can probably be removed from the names to make > > them a little more concise. > > > > I am more in favor of the functions, I have to admit I don't know which > is really better but in any event I will rename them. If you prefer functions, that's fine with me. I don't have a strong preference. -- Josh _______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel