From: Will Deacon <will@kernel.org>
To: Mark Brown <broonie@kernel.org>
Cc: Mark Rutland <mark.rutland@arm.com>,
Catalin Marinas <catalin.marinas@arm.com>,
linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH v3 3/3] arm64: insn: Report PAC and BTI instructions as NOPs
Date: Mon, 4 May 2020 13:14:00 +0100 [thread overview]
Message-ID: <20200504121359.GA1439@willie-the-truck> (raw)
In-Reply-To: <20200501161210.GF5276@sirena.org.uk>
On Fri, May 01, 2020 at 05:12:10PM +0100, Mark Brown wrote:
> On Fri, May 01, 2020 at 01:57:34PM +0100, Mark Rutland wrote:
>
> > I appreciate the desire to not change this code too much, but could we
> > please rename this to aarch64_insn_is_steppable_hint() to avoid the
> > misleading name?
>
> That's definitely clearer. I've got this change locally but looking at
> the new function name I can see that having done the rename people might
> want to go through and also make sure that the list of HINTs we mark as
> steppable is up to date which is probably a good idea but would hold
> things up further, some of the barriers look like they might need a bit
> of thought.
>
> Will, what would you prefer - should I send out a version with the
> just rename, do that incrementally or some other thing?
Please send a version with the rename and then people can add extra
instructions to the whitelist as and when they are needed.
Will
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
prev parent reply other threads:[~2020-05-04 12:14 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-05-01 12:37 [PATCH v3 0/3] arm64: Make NOP handling a whitelist Mark Brown
2020-05-01 12:37 ` [PATCH v3 1/3] arm64: insn: Don't assume unrecognized HINTs are NOPs Mark Brown
2020-05-01 12:37 ` [PATCH v3 2/3] arm64: insn: Add constants for new HINT instruction decode Mark Brown
2020-05-01 12:37 ` [PATCH v3 3/3] arm64: insn: Report PAC and BTI instructions as NOPs Mark Brown
2020-05-01 12:57 ` Mark Rutland
2020-05-01 16:12 ` Mark Brown
2020-05-04 12:14 ` Will Deacon [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200504121359.GA1439@willie-the-truck \
--to=will@kernel.org \
--cc=broonie@kernel.org \
--cc=catalin.marinas@arm.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=mark.rutland@arm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox