From: Frank Li <Frank.Li@nxp.com>
To: Rob Herring <robh@kernel.org>,
Krzysztof Kozlowski <krzk+dt@kernel.org>,
Conor Dooley <conor+dt@kernel.org>,
Shawn Guo <shawnguo@kernel.org>,
Sascha Hauer <s.hauer@pengutronix.de>,
Pengutronix Kernel Team <kernel@pengutronix.de>,
Fabio Estevam <festevam@gmail.com>
Cc: devicetree@vger.kernel.org, imx@lists.linux.dev,
linux-arm-kernel@lists.infradead.org,
linux-kernel@vger.kernel.org, Frank Li <Frank.Li@nxp.com>
Subject: [PATCH 00/11] ARM: dts: imx6: trivial change to clean up some DTB warnings.
Date: Thu, 25 Sep 2025 17:13:44 -0400 [thread overview]
Message-ID: <20250925-imx6_dts_cleanup-v1-0-748380dd0d22@nxp.com> (raw)
Trivial change to clean up some DTB warnings.
Signed-off-by: Frank Li <Frank.Li@nxp.com>
---
Frank Li (11):
ARM: dts: imx6: rename stmpgpio to gpio
ARM: dts: imx6: rename touch-thermal0 to touch-0-thermal
ARM: dts: imx6: rename m95m02 to eeprom
ARM: dts: imx6qdl-ts4900: rename ngpio to ngpios
ARM: dts: imx6: remove gpio suffix for regulator
ARM: dts: imx6: change voltage-divider's io-channel-cells to 1
ARM: dts: imx6: remove pinctrl-name if pinctrl-0 doesn't exist
ARM: dts: imx6-tbs2910: rename ir_recv to ir
ARM: dts: imx6q-utilite-pro: add missing required property for pci
ARM: dts: imx6ull-phytec-tauri: remove extra space before jedec,spi-nor
ARM: dts: imx6qdl-nitrogen6_max: rename i2c<n>mux to i2c
arch/arm/boot/dts/nxp/imx/imx6dl-plym2m.dts | 4 ++--
arch/arm/boot/dts/nxp/imx/imx6dl-prtvt7.dts | 8 ++++----
arch/arm/boot/dts/nxp/imx/imx6dl-victgo.dts | 10 +++++-----
arch/arm/boot/dts/nxp/imx/imx6q-cm-fx6.dts | 2 +-
arch/arm/boot/dts/nxp/imx/imx6q-dmo-edmqmx6.dts | 10 ++++++++--
arch/arm/boot/dts/nxp/imx/imx6q-evi.dts | 2 +-
arch/arm/boot/dts/nxp/imx/imx6q-pistachio.dts | 2 --
arch/arm/boot/dts/nxp/imx/imx6q-tbs2910.dts | 2 +-
arch/arm/boot/dts/nxp/imx/imx6q-utilite-pro.dts | 5 ++++-
arch/arm/boot/dts/nxp/imx/imx6qdl-colibri.dtsi | 2 +-
arch/arm/boot/dts/nxp/imx/imx6qdl-nitrogen6_max.dtsi | 6 +++---
arch/arm/boot/dts/nxp/imx/imx6qdl-ts4900.dtsi | 2 +-
arch/arm/boot/dts/nxp/imx/imx6sl-tolino-vision.dts | 1 -
arch/arm/boot/dts/nxp/imx/imx6sx-sdb.dtsi | 2 +-
arch/arm/boot/dts/nxp/imx/imx6ul-isiot.dtsi | 12 +++++++++---
arch/arm/boot/dts/nxp/imx/imx6ull-phytec-tauri.dtsi | 2 +-
16 files changed, 42 insertions(+), 30 deletions(-)
---
base-commit: 4cf7dfd6c51e0292521a92eabcf687c8b82f8df2
change-id: 20250925-imx6_dts_cleanup-6edf53e09c62
Best regards,
--
Frank Li <Frank.Li@nxp.com>
next reply other threads:[~2025-09-25 21:14 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-09-25 21:13 Frank Li [this message]
2025-09-25 21:13 ` [PATCH 01/11] ARM: dts: imx6: rename stmpgpio to gpio Frank Li
2025-09-25 21:13 ` [PATCH 02/11] ARM: dts: imx6: rename touch-thermal0 to touch-0-thermal Frank Li
2025-09-25 21:13 ` [PATCH 03/11] ARM: dts: imx6: rename m95m02 to eeprom Frank Li
2025-09-25 21:13 ` [PATCH 04/11] ARM: dts: imx6qdl-ts4900: rename ngpio to ngpios Frank Li
2025-09-25 21:13 ` [PATCH 05/11] ARM: dts: imx6: remove gpio suffix for regulator Frank Li
2025-09-25 21:16 ` Fabio Estevam
2025-09-25 21:23 ` Frank Li
2025-09-25 21:13 ` [PATCH 06/11] ARM: dts: imx6: change voltage-divider's io-channel-cells to 1 Frank Li
2025-09-25 21:13 ` [PATCH 07/11] ARM: dts: imx6: remove pinctrl-name if pinctrl-0 doesn't exist Frank Li
2025-09-25 21:13 ` [PATCH 08/11] ARM: dts: imx6-tbs2910: rename ir_recv to ir Frank Li
2025-09-26 1:04 ` Fabio Estevam
2025-09-25 21:13 ` [PATCH 09/11] ARM: dts: imx6q-utilite-pro: add missing required property for pci Frank Li
2025-09-25 21:13 ` [PATCH 10/11] ARM: dts: imx6ull-phytec-tauri: remove extra space before jedec,spi-nor Frank Li
2025-09-25 21:13 ` [PATCH 11/11] ARM: dts: imx6qdl-nitrogen6_max: rename i2c<n>mux to i2c Frank Li
2025-09-26 5:34 ` [PATCH 00/11] ARM: dts: imx6: trivial change to clean up some DTB warnings Peng Fan
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250925-imx6_dts_cleanup-v1-0-748380dd0d22@nxp.com \
--to=frank.li@nxp.com \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=festevam@gmail.com \
--cc=imx@lists.linux.dev \
--cc=kernel@pengutronix.de \
--cc=krzk+dt@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=robh@kernel.org \
--cc=s.hauer@pengutronix.de \
--cc=shawnguo@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox