Linux-ARM-Kernel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Javier Martinez Canillas <javierm@redhat.com>
To: "Uwe Kleine-König" <u.kleine-koenig@pengutronix.de>,
	"Thomas Zimmermann" <tzimmermann@suse.de>
Cc: linux-samsung-soc@vger.kernel.org, amd-gfx@lists.freedesktop.org,
	linux-stm32@st-md-mailman.stormreply.com,
	linux-rockchip@lists.infradead.org,
	Xinwei Kong <kong.kongxinwei@hisilicon.com>,
	VMware Graphics Reviewers <linux-graphics-maintainer@vmware.com>,
	NXP Linux Team <linux-imx@nxp.com>,
	spice-devel@lists.freedesktop.org, linux-sunxi@lists.linux.dev,
	Martin Blumenstingl <martin.blumenstingl@googlemail.com>,
	linux-arm-msm@vger.kernel.org, intel-gfx@lists.freedesktop.org,
	linux-mediatek@lists.infradead.org,
	xen-devel@lists.xenproject.org, linux-tegra@vger.kernel.org,
	linux-amlogic@lists.infradead.org,
	Gurchetan Singh <gurchetansingh@chromium.org>,
	Sean Paul <sean@poorly.run>,
	linux-arm-kernel@lists.infradead.org,
	AngeloGioacchino Del Regno
	<angelogioacchino.delregno@collabora.com>,
	Andrew Jeffery <andrew@aj.id.au>,
	linux-mips@vger.kernel.org, Chia-I Wu <olvaffe@gmail.com>,
	linux-renesas-soc@vger.kernel.org, kernel@pengutronix.de,
	John Stultz <jstultz@google.com>,
	freedreno@lists.freedesktop.org,
	Lucas Stach <l.stach@pengutronix.de>
Subject: Re: [PATCH RFC v1 00/52] drm/crtc: Rename struct drm_crtc::dev to drm_dev
Date: Wed, 12 Jul 2023 13:18:14 +0200	[thread overview]
Message-ID: <87r0pdgyyx.fsf@minerva.mail-host-address-is-not-set> (raw)
In-Reply-To: <20230712105432.urgwb4zzwgsyfbwq@pengutronix.de>

Uwe Kleine-König <u.kleine-koenig@pengutronix.de> writes:

[dropping some recipients since my SMTP server was complaining about the size]

> Hello Thomas,
>
> On Wed, Jul 12, 2023 at 12:19:37PM +0200, Thomas Zimmermann wrote:
>> Am 12.07.23 um 11:46 schrieb Uwe Kleine-König:
>> > Hello,
>> > 
>> > while I debugged an issue in the imx-lcdc driver I was constantly
>> > irritated about struct drm_device pointer variables being named "dev"
>> > because with that name I usually expect a struct device pointer.
>> > 
>> > I think there is a big benefit when these are all renamed to "drm_dev".
>> 
>> If you rename drm_crtc.dev, you should also address *all* other data
>> structures.
>
> Yes. Changing drm_crtc::dev was some effort, so I thought to send that
> one out before doing the same to
>
> 	drm_dp_mst_topology_mgr
> 	drm_atomic_state
> 	drm_master
> 	drm_bridge
> 	drm_client_dev
> 	drm_connector
> 	drm_debugfs_entry
> 	drm_encoder
> 	drm_fb_helper
> 	drm_minor
> 	drm_framebuffer
> 	drm_gem_object
> 	drm_plane
> 	drm_property
> 	drm_property_blob
> 	drm_vblank_crtc
>
> when in the end the intention isn't welcome.
>
>> > I have no strong preference here though, so "drmdev" or "drm" are fine
>> > for me, too. Let the bikesheding begin!
>> 
>> We've discussed this to death. IIRC 'drm' would be the prefered choice.
>
> "drm" at least has the advantage to be the 2nd most common name. With
> Paul Kocialkowski prefering "drm_dev" there is no clear favourite yet.

I think that either "drm" or "drm_dev" would be more clear than "dev",
which I also found it confusing and thinking about a "struct device".

Probably leaning to "drm", since as you said is the second most used name
in drivers that assign crtc->dev to a local variable.

> Maybe all the other people with strong opinions are dead if this was
> "discussed to death" before? :-)
>
> Best regards
> Uwe
>
> -- 
> Pengutronix e.K.                           | Uwe Kleine-König            |
> Industrial Linux Solutions                 | https://www.pengutronix.de/ |

-- 
Best regards,

Javier Martinez Canillas
Core Platforms
Red Hat


_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

      parent reply	other threads:[~2023-07-12 11:18 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <20230712094702.1770121-1-u.kleine-koenig@pengutronix.de>
2023-07-12  9:46 ` [PATCH RFC v1 06/52] drm/aspeed: Use struct drm_crtc::drm_dev instead of struct drm_crtc::dev Uwe Kleine-König
2023-07-12  9:46 ` [PATCH RFC v1 08/52] drm/atmel-hlcdc: " Uwe Kleine-König
2023-07-12  9:46 ` [PATCH RFC v1 09/52] drm/exynos: " Uwe Kleine-König
2023-07-12  9:46 ` [PATCH RFC v1 16/52] drm/imx: " Uwe Kleine-König
2023-07-12  9:46 ` [PATCH RFC v1 21/52] drm/mediatek: " Uwe Kleine-König
2023-07-12  9:46 ` [PATCH RFC v1 22/52] drm/meson: " Uwe Kleine-König
2023-07-12  9:46 ` [PATCH RFC v1 25/52] drm/mxsfb: " Uwe Kleine-König
2023-07-12  9:46 ` [PATCH RFC v1 33/52] drm/rockchip: " Uwe Kleine-König
2023-07-12  9:46 ` [PATCH RFC v1 37/52] drm/stm: " Uwe Kleine-König
2023-07-12  9:46 ` [PATCH RFC v1 38/52] drm/sun4i: " Uwe Kleine-König
2023-07-12  9:47 ` [PATCH RFC v1 51/52] drm/xlnx: " Uwe Kleine-König
     [not found] ` <abf26a82-4f17-51f2-5753-785f8516a81a@suse.de>
     [not found]   ` <20230712105432.urgwb4zzwgsyfbwq@pengutronix.de>
2023-07-12 11:18     ` Javier Martinez Canillas [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87r0pdgyyx.fsf@minerva.mail-host-address-is-not-set \
    --to=javierm@redhat.com \
    --cc=amd-gfx@lists.freedesktop.org \
    --cc=andrew@aj.id.au \
    --cc=angelogioacchino.delregno@collabora.com \
    --cc=freedreno@lists.freedesktop.org \
    --cc=gurchetansingh@chromium.org \
    --cc=intel-gfx@lists.freedesktop.org \
    --cc=jstultz@google.com \
    --cc=kernel@pengutronix.de \
    --cc=kong.kongxinwei@hisilicon.com \
    --cc=l.stach@pengutronix.de \
    --cc=linux-amlogic@lists.infradead.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-graphics-maintainer@vmware.com \
    --cc=linux-imx@nxp.com \
    --cc=linux-mediatek@lists.infradead.org \
    --cc=linux-mips@vger.kernel.org \
    --cc=linux-renesas-soc@vger.kernel.org \
    --cc=linux-rockchip@lists.infradead.org \
    --cc=linux-samsung-soc@vger.kernel.org \
    --cc=linux-stm32@st-md-mailman.stormreply.com \
    --cc=linux-sunxi@lists.linux.dev \
    --cc=linux-tegra@vger.kernel.org \
    --cc=martin.blumenstingl@googlemail.com \
    --cc=olvaffe@gmail.com \
    --cc=sean@poorly.run \
    --cc=spice-devel@lists.freedesktop.org \
    --cc=tzimmermann@suse.de \
    --cc=u.kleine-koenig@pengutronix.de \
    --cc=xen-devel@lists.xenproject.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox