From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from bombadil.infradead.org (bombadil.infradead.org [198.137.202.133]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.lore.kernel.org (Postfix) with ESMTPS id 1373AC61DA4 for ; Thu, 16 Feb 2023 11:08:21 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=lists.infradead.org; s=bombadil.20210309; h=Sender: Content-Transfer-Encoding:Content-Type:List-Subscribe:List-Help:List-Post: List-Archive:List-Unsubscribe:List-Id:In-Reply-To:From:References:Cc:To: Subject:MIME-Version:Date:Message-ID:Reply-To:Content-ID:Content-Description: Resent-Date:Resent-From:Resent-Sender:Resent-To:Resent-Cc:Resent-Message-ID: List-Owner; bh=8jSN1xyDa/N3Xfflwaboc47wCWeZSewf+cDKfWqakKA=; b=vghvFegcHshTA8 fWRYcPj/6rwrHcJqiVdSvj8xtcOmdlgC2DE9pXD6PLGp7Ggqry8CqjW5PzXPZ2q53IrSIv8z1pfRB 9wqQmRPiYQIBI97nvahGFxRtmNDnF8sMDAWhgEluEzd/97zCA30Wf68b7C4qGB85wgc+y+Q7usmkv u3IvmUGa3ujeEhgvBku5CRvaEoQL2qHHatT7G1xHM+F+MMB3uWP2oavtTIOATjGkUNSagaP70yHYQ 8OiJQVislwbP46YpO7mdoO9wnW94HSu3MjLRm13fy6TGABmpM1jQaenraHOVqP8W0pQe2qGC9RexS urucJS7nbvTdoeEgsWwg==; Received: from localhost ([::1] helo=bombadil.infradead.org) by bombadil.infradead.org with esmtp (Exim 4.94.2 #2 (Red Hat Linux)) id 1pSc6c-009qHA-HH; Thu, 16 Feb 2023 11:07:15 +0000 Received: from mail-ej1-x635.google.com ([2a00:1450:4864:20::635]) by bombadil.infradead.org with esmtps (Exim 4.94.2 #2 (Red Hat Linux)) id 1pSc6V-009qFH-HI for linux-arm-kernel@lists.infradead.org; Thu, 16 Feb 2023 11:07:09 +0000 Received: by mail-ej1-x635.google.com with SMTP id qw12so4294982ejc.2 for ; Thu, 16 Feb 2023 03:07:07 -0800 (PST) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=linaro.org; s=google; h=content-transfer-encoding:in-reply-to:from:references:cc:to :content-language:subject:user-agent:mime-version:date:message-id :from:to:cc:subject:date:message-id:reply-to; bh=2XtfON9YmhK/54vgAcFs1XoGNiMG/tSNcLmL9ZluKEY=; b=xTtIjm+aMf26mPdovCi9L09kIwvE8z/9D/ZIgVDo0CjMWbgGkRpVEkbqaNq9/LFb2U HY6jsIAafQ37cZZSt+uegtQyTo6Fq4h2IKtAyXLOh41gpi37gjU0x+XmkmOAvhMHr5ug /SZVtkSJ7E8qiF0nTUg6h9vwIgJ3LC3hr9hlBYWKTMp0snLWgXTs+eSKsliGFKaOZcgq Vff7AaoxCVd0MqqXOfHXLjWCy/EZbLz/lD8Mav5xSyezIFhxgs5ypS8LqbH/79iGNMcr Ltu5XMxQGBheqBUSdTfV148/7BoiuncWJkivuxWaSfYCkt+NqlFpQZplIJDt6iVa6txF DgmQ== X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20210112; h=content-transfer-encoding:in-reply-to:from:references:cc:to :content-language:subject:user-agent:mime-version:date:message-id :x-gm-message-state:from:to:cc:subject:date:message-id:reply-to; bh=2XtfON9YmhK/54vgAcFs1XoGNiMG/tSNcLmL9ZluKEY=; b=idFiZGJ0jyS0NxjrZkRhahZE+ZtW8s6O3FWosB8tpGleQ1osXjmkfgD92YKEeTBKYi i7Qc58Ez4t1g55QL//uaTk29C2PwOT0Xc98Co72q+ug2FkjX/UdTZADtiaomIVHI0hTA t0d9x0ym3kkyqkz2KdexOPVvsxxUmRuLyb4Z+dICE/w37piEvaAMJ0trtqKlc1tfQVSp KVN4KyjA6exxI7C6VNNEYUbee9iOf6cto3aq5dqji3zPuvZylYtGZTn1GFYd7oQwSBTB 2EpqI40+t0xidPqkcQZXv+1oSpBvJa7KlfcT69b2AKZp1k0PDR1/f0OJnaqkug7MCT/g btSg== X-Gm-Message-State: AO0yUKX6Zd69VeL48x4C0r++4dyXPKYeH8kiF12zIn84cUEvjn0Fudj8 L5OpC9CUT6c5NwRfSTeeefZh0Q== X-Google-Smtp-Source: AK7set9+/bKi4OtttusS38rCL3Uq4qJh+IzTiwS3GRQZ6Gip9Lt1BDOBFqxhTbtmvnS3mFcQtENeVQ== X-Received: by 2002:a17:906:40e:b0:87b:dc07:380f with SMTP id d14-20020a170906040e00b0087bdc07380fmr6245015eja.0.1676545626049; Thu, 16 Feb 2023 03:07:06 -0800 (PST) Received: from [192.168.1.109] ([178.197.216.144]) by smtp.gmail.com with ESMTPSA id ad24-20020a170907259800b0087bdac06a3bsm681976ejc.2.2023.02.16.03.07.04 (version=TLS1_3 cipher=TLS_AES_128_GCM_SHA256 bits=128/128); Thu, 16 Feb 2023 03:07:05 -0800 (PST) Message-ID: Date: Thu, 16 Feb 2023 12:07:03 +0100 MIME-Version: 1.0 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Thunderbird/102.7.1 Subject: Re: [PATCH 08/16] PCI: samsung: Rename exynos_pcie to samsung_pcie Content-Language: en-US To: Shradha Todi , lpieralisi@kernel.org, kw@linux.com, robh@kernel.org, bhelgaas@google.com, krzysztof.kozlowski+dt@linaro.org, alim.akhtar@samsung.com, jingoohan1@gmail.com, Sergey.Semin@baikalelectronics.ru, lukas.bulwahn@gmail.com, hongxing.zhu@nxp.com, tglx@linutronix.de, m.szyprowski@samsung.com, jh80.chung@samsung.co, pankaj.dubey@samsung.com Cc: linux-pci@vger.kernel.org, devicetree@vger.kernel.org, linux-arm-kernel@lists.infradead.org, linux-samsung-soc@vger.kernel.org, linux-kernel@vger.kernel.org References: <20230214121333.1837-1-shradha.t@samsung.com> <20230214121333.1837-9-shradha.t@samsung.com> From: Krzysztof Kozlowski In-Reply-To: <20230214121333.1837-9-shradha.t@samsung.com> X-CRM114-Version: 20100106-BlameMichelson ( TRE 0.8.0 (BSD) ) MR-646709E3 X-CRM114-CacheID: sfid-20230216_030707_681836_06341B1B X-CRM114-Status: GOOD ( 16.62 ) X-BeenThere: linux-arm-kernel@lists.infradead.org X-Mailman-Version: 2.1.34 Precedence: list List-Id: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Sender: "linux-arm-kernel" Errors-To: linux-arm-kernel-bounces+linux-arm-kernel=archiver.kernel.org@lists.infradead.org On 14/02/2023 13:13, Shradha Todi wrote: > The platform specific structure being used is named > exynos_pcie. Changing it to samsung_pcie for making it > generic. > > Suggested-by: Pankaj Dubey > Signed-off-by: Shradha Todi > --- > drivers/pci/controller/dwc/pci-samsung.c | 190 +++++++++++------------ > 1 file changed, 95 insertions(+), 95 deletions(-) > > diff --git a/drivers/pci/controller/dwc/pci-samsung.c b/drivers/pci/controller/dwc/pci-samsung.c > index d5adf1017a05..be0177fcd763 100644 > --- a/drivers/pci/controller/dwc/pci-samsung.c > +++ b/drivers/pci/controller/dwc/pci-samsung.c > @@ -23,7 +23,7 @@ > > #include "pcie-designware.h" > > -#define to_exynos_pcie(x) dev_get_drvdata((x)->dev) > +#define to_samsung_pcie(x) dev_get_drvdata((x)->dev) > > /* PCIe APPL registers */ > #define EXYNOS_PCIE_IRQ_PULSE 0x000 > @@ -51,7 +51,7 @@ > #define EXYNOS_PCIE_APPL_SLV_ARMISC 0x120 > #define EXYNOS_PCIE_APPL_SLV_DBI_ENABLE BIT(21) > > -struct exynos_pcie { > +struct samsung_pcie { No, I don't see benefit of this at all. How we call stuff inside driver is not related whether this is for Tesla or Exynos. We could even call it "pony". :) Thus renamings just to support new variant of Samsung device is not a good reason. Unless all of the old "exynos" names will be soon needed for some exynos-specific variants? Best regards, Krzysztof _______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel