From: tglx@linutronix.de (Thomas Gleixner)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH 00/10] Save MSI chip in pci_sys_data
Date: Mon, 17 Nov 2014 22:31:14 +0100 (CET) [thread overview]
Message-ID: <alpine.DEB.2.11.1411172230010.3909@nanos> (raw)
In-Reply-To: <CAErSpo7hH=v15w2UgG3mWc_B=YQNA-ZXj_VO_9dHZ3oFrk_yjw@mail.gmail.com>
On Mon, 17 Nov 2014, Bjorn Helgaas wrote:
> Super. Thank you very much for taking care of this; it's a big weight
> off my mind.
>
> You can add my Acked-by to these patches if you want it. I would
> suggest a minor comment expansion here, just because the code *looks
> like* it's setting up something to match a hardware device:
>
> > +/**
> > + * pci_msi_domain_calc_hwirq - Generate a unique ID for an MSI source
> > + * @dev: Pointer to the PCI device
> > + * @desc: Pointer to the msi descriptor
> > + *
> > + * The ID number is only used within the irqdomain.
>
> Maybe include something like:
>
> This "irq_hw_number_t" is an opaque identifier used only by the
> irqdomain code.
> It does not correspond to any hardware implementation or register encoding.
Yes, that's really a way better description of it.
Thanks for having a look!
tglx
next prev parent reply other threads:[~2014-11-17 21:31 UTC|newest]
Thread overview: 23+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-10-27 7:48 [PATCH 00/10] Save MSI chip in pci_sys_data Yijing Wang
2014-10-27 7:48 ` [PATCH 01/10] MSI: Rename msi_chip to msi_controller for better readability Yijing Wang
2014-10-27 7:48 ` [PATCH 02/10] PCI/MSI: Introduce weak pcibios_msi_controller() Yijing Wang
2014-10-27 7:48 ` [PATCH 03/10] arm/MSI: Save MSI controller in pci_sys_data Yijing Wang
2014-10-27 7:48 ` [PATCH 04/10] PCI: tegra: " Yijing Wang
2014-10-27 7:48 ` [PATCH 05/10] PCI: designware: " Yijing Wang
2014-10-27 7:48 ` [PATCH 06/10] PCI: rcar: " Yijing Wang
2014-10-27 7:48 ` [PATCH 07/10] PCI: mvebu: " Yijing Wang
2014-10-27 7:48 ` [PATCH 08/10] PCI: xilinx: " Yijing Wang
2014-10-27 7:48 ` [PATCH 09/10] arm/PCI: Clean unused pcibios_add_bus() and pcibios_remove_bus() Yijing Wang
2014-10-27 7:48 ` [PATCH 10/10] PCI/MSI: Remove useless bus->msi assignment Yijing Wang
2014-11-12 4:24 ` Bjorn Helgaas
2014-11-12 5:54 ` Yijing Wang
2014-11-12 4:23 ` [PATCH 00/10] Save MSI chip in pci_sys_data Bjorn Helgaas
2014-11-17 2:59 ` Bjorn Helgaas
2014-11-17 9:38 ` Thomas Gleixner
2014-11-17 16:54 ` Bjorn Helgaas
2014-11-17 21:02 ` Thomas Gleixner
2014-11-17 21:27 ` Bjorn Helgaas
2014-11-17 21:31 ` Thomas Gleixner [this message]
2014-11-18 17:53 ` Marc Zyngier
2014-11-21 17:20 ` Bjorn Helgaas
2014-11-22 2:58 ` Yijing Wang
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.DEB.2.11.1411172230010.3909@nanos \
--to=tglx@linutronix.de \
--cc=linux-arm-kernel@lists.infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox