From: Frank Li <Frank.li@oss.nxp.com>
To: Pawel Zalewski <pzalewski@thegoodpenguin.co.uk>
Cc: Viresh Kumar <vireshk@kernel.org>,
Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
Vinod Koul <vkoul@kernel.org>, Frank Li <Frank.Li@kernel.org>,
Binbin Zhou <zhoubinbin@loongson.cn>,
Sinan Kaya <okaya@kernel.org>,
dmaengine@vger.kernel.org, linux-kernel@vger.kernel.org,
linux-arm-kernel@lists.infradead.org,
linux-arm-msm@vger.kernel.org
Subject: Re: [PATCH 3/4] dma: qcom: use named initializers for acpi_device_id
Date: Fri, 4 Sep 2026 09:43:53 -0500 [thread overview]
Message-ID: <aprZKXi7h1prHZft@SMW015318> (raw)
In-Reply-To: <20260904-acpi-dma-v1-3-0fcc63d65d4b@thegoodpenguin.co.uk>
On Fri, Sep 04, 2026 at 03:10:42PM +0100, Pawel Zalewski wrote:
> [You don't often get email from pzalewski@thegoodpenguin.co.uk. Learn why this is important at https://aka.ms/LearnAboutSenderIdentification ]
Subject: dmaengine: qcom: ...
>
> Use a named initializer for the acpi_device_id fields which
> makes the code more readable and consistent with how lists
> are initialized in the rest of the kernel code base.
> Also drop explicitly setting fields to 0 where it is redundant.
>
> While we are at it - unify the list terminator to have
> a single space between the brackets and no trailing
> comma.
Remove "While we are at it". Unify the list ...
and wrap at 75 char, check other patches
Frank
>
> Signed-off-by: Pawel Zalewski <pzalewski@thegoodpenguin.co.uk>
> ---
> drivers/dma/qcom/hidma.c | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/dma/qcom/hidma.c b/drivers/dma/qcom/hidma.c
> index c939635be21d..1349066b1544 100644
> --- a/drivers/dma/qcom/hidma.c
> +++ b/drivers/dma/qcom/hidma.c
> @@ -935,10 +935,10 @@ static void hidma_remove(struct platform_device *pdev)
>
> #if IS_ENABLED(CONFIG_ACPI)
> static const struct acpi_device_id hidma_acpi_ids[] = {
> - {"QCOM8061"},
> - {"QCOM8062", HIDMA_MSI_CAP},
> - {"QCOM8063", (HIDMA_MSI_CAP | HIDMA_IDENTITY_CAP)},
> - {},
> + { .id = "QCOM8061" },
> + { .id = "QCOM8062", .driver_data = HIDMA_MSI_CAP },
> + { .id = "QCOM8063", .driver_data = (HIDMA_MSI_CAP | HIDMA_IDENTITY_CAP) },
> + { }
> };
> MODULE_DEVICE_TABLE(acpi, hidma_acpi_ids);
> #endif
>
> --
> 2.43.0
>
next prev parent reply other threads:[~2026-09-04 14:44 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-04 14:10 [PATCH 0/4] dma: use designated initializers for acpi_device_id Pawel Zalewski
2026-09-04 14:10 ` [PATCH 1/4] dma: dw: " Pawel Zalewski
2026-09-04 14:10 ` [PATCH 2/4] dma: loongson: use named " Pawel Zalewski
2026-09-05 8:15 ` Binbin Zhou
2026-09-04 14:10 ` [PATCH 3/4] dma: qcom: " Pawel Zalewski
2026-09-04 14:43 ` Frank Li [this message]
2026-09-04 14:10 ` [PATCH 4/4] dma: xgene-dmac: " Pawel Zalewski
2026-09-05 8:12 ` [PATCH 0/4] dma: use designated " Andy Shevchenko
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=aprZKXi7h1prHZft@SMW015318 \
--to=frank.li@oss.nxp.com \
--cc=Frank.Li@kernel.org \
--cc=andriy.shevchenko@linux.intel.com \
--cc=dmaengine@vger.kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=okaya@kernel.org \
--cc=pzalewski@thegoodpenguin.co.uk \
--cc=vireshk@kernel.org \
--cc=vkoul@kernel.org \
--cc=zhoubinbin@loongson.cn \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox