From mboxrd@z Thu Jan 1 00:00:00 1970 From: avictor.za@gmail.com (Andrew Victor) Date: Wed, 28 Oct 2009 21:53:03 +0200 Subject: [PATCH 3/3 v2] at91/atmel-mci: inclusion of sd/mmc driver in at91sam9g45 chip and board In-Reply-To: References: <20090930155557.7dae503b@hskinnemoen-d830> <20091028083548.38f1d80c@hskinnemoen-d830> Message-ID: To: linux-arm-kernel@lists.infradead.org List-Id: linux-arm-kernel.lists.infradead.org hi, > Then I think it would be best to use GPIO_PIN_NONE. Makes it clear > what is expected and avoids confusion on what should be the proper > value. > I hope I'm not saying non-sense, but even if I am, I guess you can see > that I'm advocating against the magic numbers :) What magic numbers ? If you have a "wp_pin" on the board, you declare the struct as: static struct mci_platform_data __initdata mci0_data = { .slot[0] = { .bus_width = 4, .detect_pin = AT91_PIN_PD10, } } and if you do have a "wp_pin" on your board, you declare the struct as: static struct mci_platform_data __initdata mci0_data = { .slot[0] = { .bus_width = 4, .detect_pin = AT91_PIN_PD10, .wp_pin = AT91_PIN_PD11, } } And it's more future-proof. If the next version of the driver/peripheral has a "toggle_pin" GPIO option, you don't need to go update all board files with a ".toggle_pin = GPIO_PIN_NONE" or ".toggle_pin = -ENODEV". Regards, Andrew Victor