From mboxrd@z Thu Jan 1 00:00:00 1970 From: dave.hansen@linux.intel.com (Dave Hansen) Date: Fri, 1 Dec 2017 10:02:43 -0800 Subject: [PATCH v2 00/18] arm64: Unmap the kernel whilst running in userspace (KAISER) In-Reply-To: <20171201175812.n6ht7h52j3z4pgw2@lakrids.cambridge.arm.com> References: <1512059986-21325-1-git-send-email-will.deacon@arm.com> <20171201140406.oanuaz6zvyrhp4ml@lakrids.cambridge.arm.com> <20171201175026.GB8826@arm.com> <20171201175812.n6ht7h52j3z4pgw2@lakrids.cambridge.arm.com> Message-ID: To: linux-arm-kernel@lists.infradead.org List-Id: linux-arm-kernel.lists.infradead.org On 12/01/2017 09:58 AM, Mark Rutland wrote: > On Fri, Dec 01, 2017 at 05:50:26PM +0000, Will Deacon wrote: >> On Fri, Dec 01, 2017 at 02:04:06PM +0000, Mark Rutland wrote: >>> On Thu, Nov 30, 2017 at 04:39:28PM +0000, Will Deacon wrote: >> Thanks for going through this. Do you have any ideas about what we could >> rename the command-line option to? I'll get us started: >> >> - kaiser= >> - hidekernel= >> - unmapkernel= >> - hardenkaslr= >> - swuan= > Off all of these, I think "unmapkernel" is the clear winner, since it > says what it does in the tin (even if it misses the when). > > I'll have a think over the weekend. On the x86 side we've been leaning toward renaming kaiser to something like "user pagetable isolation", so the boot parameter is something like "noupti". But I think the consensus is definitely to get rid of "kaiser".