From: Krzysztof Kozlowski <krzysztof.kozlowski@oss.qualcomm.com>
To: Sumit Garg <sumit.garg@kernel.org>
Cc: Amirreza Zarrabi <amirreza.zarrabi@oss.qualcomm.com>,
Jens Wiklander <jens.wiklander@linaro.org>,
linux-arm-msm@vger.kernel.org, op-tee@lists.trustedfirmware.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/3] tee: qcomtee: call: Fix confusing cleanup.h syntax
Date: Fri, 12 Dec 2025 02:07:40 +0100 [thread overview]
Message-ID: <b29c97cd-cade-40ef-8e6d-d164b1d16059@oss.qualcomm.com> (raw)
In-Reply-To: <aTtn-x0hh18V7n7J@sumit-X1>
On 12/12/2025 01:55, Sumit Garg wrote:
> On Mon, Dec 08, 2025 at 03:08:45AM +0100, Krzysztof Kozlowski wrote:
>> Initializing automatic __free variables to NULL without need (e.g.
>> branches with different allocations), followed by actual allocation is
>> in contrary to explicit coding rules guiding cleanup.h:
>>
>> "Given that the "__free(...) = NULL" pattern for variables defined at
>> the top of the function poses this potential interdependency problem the
>> recommendation is to always define and assign variables in one statement
>> and not group variable definitions at the top of the function when
>> __free() is used."
>>
>> Code does not have a bug, but is less readable and uses discouraged
>> coding practice, so fix that by moving declaration to the place of
>> assignment.
>
> Okay I see but..
>
>>
>> Signed-off-by: Krzysztof Kozlowski <krzysztof.kozlowski@oss.qualcomm.com>
>> ---
>> drivers/tee/qcomtee/call.c | 17 ++++++++---------
>> 1 file changed, 8 insertions(+), 9 deletions(-)
>>
>> diff --git a/drivers/tee/qcomtee/call.c b/drivers/tee/qcomtee/call.c
>> index 65f9140d4e1f..8f8830f0df26 100644
>> --- a/drivers/tee/qcomtee/call.c
>> +++ b/drivers/tee/qcomtee/call.c
>> @@ -395,9 +395,7 @@ static int qcomtee_object_invoke(struct tee_context *ctx,
>> struct tee_ioctl_object_invoke_arg *arg,
>> struct tee_param *params)
>> {
>> - struct qcomtee_object_invoke_ctx *oic __free(kfree) = NULL;
>> struct qcomtee_context_data *ctxdata = ctx->data;
>> - struct qcomtee_arg *u __free(kfree) = NULL;
>> struct qcomtee_object *object;
>> int i, ret, result;
>>
>> @@ -412,12 +410,14 @@ static int qcomtee_object_invoke(struct tee_context *ctx,
>> }
>>
>> /* Otherwise, invoke a QTEE object: */
>> - oic = qcomtee_object_invoke_ctx_alloc(ctx);
>> + struct qcomtee_object_invoke_ctx *oic __free(kfree) =
>> + qcomtee_object_invoke_ctx_alloc(ctx);
>> if (!oic)
>> return -ENOMEM;
>>
>> /* +1 for ending QCOMTEE_ARG_TYPE_INV. */
>> - u = kcalloc(arg->num_params + 1, sizeof(*u), GFP_KERNEL);
>> + struct qcomtee_arg *u __free(kfree) = kcalloc(arg->num_params + 1, sizeof(*u),
>> + GFP_KERNEL);
>
> ..this makes the code less readable with variable declarations floating
Which is intentional.
> within the function. I would rather favor to not use the cleanup.h construct
> but use explicit kfree() invocations instead like it's done in all other
> allocations in the TEE subsystem.
Sure, fair. I just don't get why introducing cleanup.h without actually
accepting its explicitly documented style...
Best regards,
Krzysztof
next prev parent reply other threads:[~2025-12-12 1:07 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-12-08 2:08 [PATCH 1/3] tee: qcomtee: call: Fix confusing cleanup.h syntax Krzysztof Kozlowski
2025-12-08 2:08 ` [PATCH 2/3] tee: qcomtee: mem: " Krzysztof Kozlowski
2026-01-04 22:48 ` Amirreza Zarrabi
2025-12-08 2:08 ` [PATCH 3/3] tee: qcomtee: user: " Krzysztof Kozlowski
2026-01-04 22:50 ` Amirreza Zarrabi
2026-01-05 10:45 ` Jens Wiklander
2025-12-12 0:55 ` [PATCH 1/3] tee: qcomtee: call: " Sumit Garg
2025-12-12 1:07 ` Krzysztof Kozlowski [this message]
2025-12-12 1:39 ` Sumit Garg
2025-12-15 20:29 ` Amirreza Zarrabi
2025-12-16 7:33 ` Jens Wiklander
2026-01-04 21:42 ` Amirreza Zarrabi
2025-12-15 23:11 ` Jeff Johnson
2026-01-04 22:42 ` Amirreza Zarrabi
2026-01-05 10:44 ` Jens Wiklander
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=b29c97cd-cade-40ef-8e6d-d164b1d16059@oss.qualcomm.com \
--to=krzysztof.kozlowski@oss.qualcomm.com \
--cc=amirreza.zarrabi@oss.qualcomm.com \
--cc=jens.wiklander@linaro.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=op-tee@lists.trustedfirmware.org \
--cc=sumit.garg@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox