From mboxrd@z Thu Jan 1 00:00:00 1970 From: Jan Kara Subject: [PATCH] audit: Rename audit mark variable to amark Date: Thu, 4 Oct 2018 09:07:55 +0200 Message-ID: <20181004070755.9981-1-jack@suse.cz> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: linux-audit-bounces@redhat.com Errors-To: linux-audit-bounces@redhat.com To: Paul Moore Cc: rgb@redhat.com, linux-audit@redhat.com, Jan Kara List-Id: linux-audit@redhat.com Variable of audit_tree_mark type was called 'mark' which is confusing as we usually call fsnotify_mark variables this way. Rename it to 'amark' to make it explicit this a actually a different thing. Signed-off-by: Jan Kara --- kernel/audit_tree.c | 12 ++++++------ 1 file changed, 6 insertions(+), 6 deletions(-) Hello Paul, here is the patch to rename mark to amark as Richard suggested. Honza diff --git a/kernel/audit_tree.c b/kernel/audit_tree.c index 9c53f7c37bdf..232b8b18cb5b 100644 --- a/kernel/audit_tree.c +++ b/kernel/audit_tree.c @@ -175,14 +175,14 @@ static void audit_tree_destroy_watch(struct fsnotify_mark *mark) static struct fsnotify_mark *alloc_mark(void) { - struct audit_tree_mark *mark; + struct audit_tree_mark *amark; - mark = kmem_cache_zalloc(audit_tree_mark_cachep, GFP_KERNEL); - if (!mark) + amark = kmem_cache_zalloc(audit_tree_mark_cachep, GFP_KERNEL); + if (!amark) return NULL; - fsnotify_init_mark(&mark->mark, audit_tree_group); - mark->mark.mask = FS_IN_IGNORED; - return &mark->mark; + fsnotify_init_mark(&amark->mark, audit_tree_group); + amark->mark.mask = FS_IN_IGNORED; + return &amark->mark; } static struct audit_chunk *alloc_chunk(int count) -- 2.16.4