From: Laurent Vivier <laurent@vivier.eu>
To: Finn Thain <fthain@linux-m68k.org>, Jens Axboe <axboe@kernel.dk>
Cc: Geert Uytterhoeven <geert@linux-m68k.org>,
Joshua Thompson <funaho@jurai.org>,
linux-block@vger.kernel.org, linux-m68k@lists.linux-m68k.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 29/31] swim: Define macros for constants
Date: Sun, 26 Jul 2026 17:46:11 +0200 [thread overview]
Message-ID: <0e80449f-e315-42e7-b5a0-2cb2eb313256@vivier.eu> (raw)
In-Reply-To: <960a50d4c5b3b23f7198f4a3dae03bdeddbf098a.1784196135.git.fthain@linux-m68k.org>
Le 16/07/2026 à 12:02, Finn Thain a écrit :
> Define a SEL_MASK macro to name the anonymous constant. Define STEPPING
> rather than re-use STEP because the latter is a command bit macro (see also
> GCR_MODE vs. SETGCR). No functional change, just better readability.
>
> Signed-off-by: Finn Thain <fthain@linux-m68k.org>
> ---
> drivers/block/swim.c | 6 ++++--
> 1 file changed, 4 insertions(+), 2 deletions(-)
Reviewed-by: Laurent Vivier <laurent@vivier.eu>
>
> diff --git a/drivers/block/swim.c b/drivers/block/swim.c
> index 406792952e7f..460f74c19cfd 100644
> --- a/drivers/block/swim.c
> +++ b/drivers/block/swim.c
> @@ -112,9 +112,11 @@ struct iwm {
> #define LSTRB 0x0F8
>
> #define CA_MASK 0x0F7
> +#define SEL_MASK 0x100
>
> /* Select values for swim_select and swim_readbit */
>
> +#define STEPPING 0x0F1
> #define READ_DATA_0 0x0F4
> #define ONEMEG_DRIVE 0x0F5
> #define SINGLE_SIDED 0x0F6
> @@ -271,7 +273,7 @@ static inline void swim_select(struct swim __iomem *base, int sel)
> {
> swim_write(base, phase, RELAX);
>
> - via1_set_head(sel & 0x100);
> + via1_set_head(sel & SEL_MASK);
>
> swim_write(base, phase, sel & CA_MASK);
> }
> @@ -369,7 +371,7 @@ static int swim_step(struct swim __iomem *base)
> {
> swim_action(base, STEP);
> udelay(150);
> - return swim_readbit_timeout_atomic(base, STEP, false, 20 * 1000);
> + return swim_readbit_timeout_atomic(base, STEPPING, false, 20 * 1000);
> }
>
> static int swim_track00(struct swim __iomem *base)
next prev parent reply other threads:[~2026-07-26 15:46 UTC|newest]
Thread overview: 68+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-16 10:02 [PATCH 00/31] block/swim: Fixes and improvements Finn Thain
2026-07-16 10:02 ` [PATCH 27/31] swim: Remove unused macro definitions Finn Thain
2026-07-26 15:43 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 08/31] swim: Don't start motor until medium is present Finn Thain
2026-07-20 19:02 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 26/31] swim: Add some helpful references Finn Thain
2026-07-26 15:41 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 17/31] swim: Convert to blocking queue Finn Thain
2026-07-21 6:03 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 19/31] swim: Deduplicate polling loops Finn Thain
2026-07-26 14:43 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 31/31] swim: Unexport global symbols Finn Thain
2026-07-26 15:51 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 18/31] swim: Remove redundant RELAX actions Finn Thain
2026-07-21 6:10 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 29/31] swim: Define macros for constants Finn Thain
2026-07-26 15:46 ` Laurent Vivier [this message]
2026-07-16 10:02 ` [PATCH 15/31] swim: Don't use the mark register to read data Finn Thain
2026-07-21 5:49 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 04/31] swim: Don't disable drive after every sector Finn Thain
2026-07-20 18:10 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 05/31] swim: Perform ISM/IWM mode switching according to specs Finn Thain
2026-07-20 18:20 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 07/31] swim: Enable clock divider only where appropriate Finn Thain
2026-07-20 18:49 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 06/31] swim: Configure parameter memory Finn Thain
2026-07-20 18:31 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 24/31] swim: Remove pointless specifiers Finn Thain
2026-07-26 15:38 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 16/31] swim: Fix buffer overflow Finn Thain
2026-07-21 5:59 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 03/31] swim: Enable the drive when probing Finn Thain
2026-07-20 18:08 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 13/31] swim: Check for CRC errors Finn Thain
2026-07-20 19:37 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 20/31] swim: Check drive ready bit Finn Thain
2026-07-26 14:48 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 21/31] swim: Revisit delays Finn Thain
2026-07-26 14:50 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 30/31] swim: Define symbols for constants Finn Thain
2026-07-26 15:47 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 12/31] swim: Simplify return value initialization Finn Thain
2026-07-20 19:21 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 22/31] swim: Remove pointless mode0 register write Finn Thain
2026-07-26 14:51 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 09/31] swim: Recalibrate when drive is probed Finn Thain
2026-07-20 19:12 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 11/31] swim: Handle FIFO timeout error Finn Thain
2026-07-20 19:17 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 28/31] swim: Clean up whitespace Finn Thain
2026-07-26 15:45 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 23/31] swim: Don't needlessly re-read sectors Finn Thain
2026-07-26 16:01 ` Laurent Vivier
2026-07-27 0:30 ` Finn Thain
2026-07-16 10:02 ` [PATCH 10/31] swim: Add track zero recalibration delay Finn Thain
2026-07-20 19:14 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 02/31] swim: Select appropriate drive once only Finn Thain
2026-07-20 13:27 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 01/31] swim: Assert strobe with stable outputs Finn Thain
2026-07-20 13:22 ` Laurent Vivier
2026-07-21 5:41 ` Finn Thain
2026-07-21 6:23 ` Laurent Vivier
2026-07-21 7:37 ` Finn Thain
2026-07-21 7:48 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 14/31] swim: Check error register during sector read Finn Thain
2026-07-21 5:43 ` Laurent Vivier
2026-07-16 10:02 ` [PATCH 25/31] swim: Move swd initialization Finn Thain
2026-07-26 15:40 ` Laurent Vivier
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=0e80449f-e315-42e7-b5a0-2cb2eb313256@vivier.eu \
--to=laurent@vivier.eu \
--cc=axboe@kernel.dk \
--cc=fthain@linux-m68k.org \
--cc=funaho@jurai.org \
--cc=geert@linux-m68k.org \
--cc=linux-block@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-m68k@lists.linux-m68k.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox