From: Ming Lei <ming.lei@redhat.com>
To: Johannes Thumshirn <Johannes.Thumshirn@wdc.com>
Cc: Jens Axboe <axboe@kernel.dk>,
"linux-block@vger.kernel.org" <linux-block@vger.kernel.org>,
Sagi Grimberg <sagi@grimberg.me>,
Baolin Wang <baolin.wang7@gmail.com>,
"hch@infradead.org" <hch@infradead.org>
Subject: Re: [PATCH V2 5/6] blk-mq: pass obtained budget count to blk_mq_dispatch_rq_list
Date: Mon, 25 May 2020 21:48:20 +0800 [thread overview]
Message-ID: <20200525134820.GA847759@T590> (raw)
In-Reply-To: <SN4PR0401MB359822F483E45C998996D49B9BB30@SN4PR0401MB3598.namprd04.prod.outlook.com>
On Mon, May 25, 2020 at 11:01:29AM +0000, Johannes Thumshirn wrote:
> On 25/05/2020 11:39, Ming Lei wrote:
> > bool blk_mq_dispatch_rq_list(struct blk_mq_hw_ctx *hctx, struct list_head *list,
> > - bool got_budget)
> > + unsigned int nr_budgets)
>
> I would probably just call it budget instead of nr_budgets.
>
It was named as 'budget' or 'budgets', but Christoph suggested to rename
it as 'nr_budgets'.
Thanks,
Ming
next prev parent reply other threads:[~2020-05-25 13:48 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-05-25 9:38 [PATCH V2 0/6] blk-mq: support batching dispatch from scheduler Ming Lei
2020-05-25 9:38 ` [PATCH V2 1/6] blk-mq: pass request queue into get/put budget callback Ming Lei
2020-05-25 9:38 ` [PATCH V2 2/6] blk-mq: pass hctx to blk_mq_dispatch_rq_list Ming Lei
2020-05-25 9:47 ` Johannes Thumshirn
2020-05-25 9:38 ` [PATCH V2 3/6] blk-mq: move getting driver tag and bugget into one helper Ming Lei
2020-05-25 9:48 ` Johannes Thumshirn
2020-05-25 16:33 ` Keith Busch
2020-05-25 9:38 ` [PATCH V2 4/6] blk-mq: remove dead check from blk_mq_dispatch_rq_list Ming Lei
2020-05-25 9:38 ` [PATCH V2 5/6] blk-mq: pass obtained budget count to blk_mq_dispatch_rq_list Ming Lei
2020-05-25 11:01 ` Johannes Thumshirn
2020-05-25 13:48 ` Ming Lei [this message]
2020-05-25 15:51 ` Johannes Thumshirn
2020-05-25 9:38 ` [PATCH V2 6/6] blk-mq: support batching dispatch in case of io scheduler Ming Lei
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200525134820.GA847759@T590 \
--to=ming.lei@redhat.com \
--cc=Johannes.Thumshirn@wdc.com \
--cc=axboe@kernel.dk \
--cc=baolin.wang7@gmail.com \
--cc=hch@infradead.org \
--cc=linux-block@vger.kernel.org \
--cc=sagi@grimberg.me \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox