From: "Darrick J. Wong" <djwong@kernel.org>
To: Christoph Hellwig <hch@lst.de>
Cc: Jens Axboe <axboe@kernel.dk>,
Christian Brauner <brauner@kernel.org>,
Carlos Maiolino <cem@kernel.org>,
Tal Zussman <tz2294@columbia.edu>,
Anuj Gupta <anuj20.g@samsung.com>,
linux-block@vger.kernel.org, linux-xfs@vger.kernel.org,
linux-fsdevel@vger.kernel.org
Subject: Re: [PATCH 08/16] xfs: move PI generation into xfs_submit_zoned_bio
Date: Wed, 9 Sep 2026 09:06:19 -0700 [thread overview]
Message-ID: <20260909160619.GJ2619314@frogsfrogsfrogs> (raw)
In-Reply-To: <20260909060924.1102037-9-hch@lst.de>
On Wed, Sep 09, 2026 at 09:08:57AM +0300, Christoph Hellwig wrote:
> Keep the code in one place.
>
> Signed-off-by: Christoph Hellwig <hch@lst.de>
Seems reasonable to move this to a common function.
Reviewed-by: "Darrick J. Wong" <djwong@kernel.org>
--D
> ---
> fs/xfs/xfs_aops.c | 4 +---
> fs/xfs/xfs_file.c | 2 --
> fs/xfs/xfs_zone_alloc.c | 4 ++++
> 3 files changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/fs/xfs/xfs_aops.c b/fs/xfs/xfs_aops.c
> index 4e862406eee9..d2cdb7cffa6b 100644
> --- a/fs/xfs/xfs_aops.c
> +++ b/fs/xfs/xfs_aops.c
> @@ -23,7 +23,6 @@
> #include "xfs_ioend.h"
> #include "xfs_zone_alloc.h"
> #include "xfs_rtgroup.h"
> -#include <linux/bio-integrity.h>
>
> struct xfs_writepage_ctx {
> struct iomap_writepage_ctx ctx;
> @@ -498,8 +497,7 @@ xfs_zoned_writeback_submit(
> bio_endio(&ioend->io_bio);
> return error;
> }
> - if (ioend->io_flags & IOMAP_IOEND_INTEGRITY)
> - fs_bio_integrity_generate(&ioend->io_bio);
> +
> xfs_zone_alloc_and_submit(ioend, &XFS_ZWPC(wpc)->open_zone);
> return 0;
> }
> diff --git a/fs/xfs/xfs_file.c b/fs/xfs/xfs_file.c
> index acbfd55f56a3..0e029db2e85b 100644
> --- a/fs/xfs/xfs_file.c
> +++ b/fs/xfs/xfs_file.c
> @@ -739,8 +739,6 @@ xfs_dio_zoned_submit_io(
> bio->bi_end_io = xfs_end_bio;
> ioend = iomap_init_ioend(iter->inode, bio, file_offset,
> iomap_ioend_flags(&iter->iomap) | IOMAP_IOEND_DIRECT);
> - if (ioend->io_flags & IOMAP_IOEND_INTEGRITY)
> - fs_bio_integrity_generate(bio);
> xfs_zone_alloc_and_submit(ioend, &ac->open_zone);
> }
>
> diff --git a/fs/xfs/xfs_zone_alloc.c b/fs/xfs/xfs_zone_alloc.c
> index bdbb60cc5d5b..bede79859671 100644
> --- a/fs/xfs/xfs_zone_alloc.c
> +++ b/fs/xfs/xfs_zone_alloc.c
> @@ -26,6 +26,7 @@
> #include "xfs_zones.h"
> #include "xfs_trace.h"
> #include "xfs_mru_cache.h"
> +#include <linux/bio-integrity.h>
>
> static void
> xfs_open_zone_free_rcu(
> @@ -909,6 +910,9 @@ xfs_zone_alloc_and_submit(
> if (xfs_is_shutdown(mp))
> goto out_error;
>
> + if (ioend->io_flags & IOMAP_IOEND_INTEGRITY)
> + fs_bio_integrity_generate(&ioend->io_bio);
> +
> /*
> * If we don't have a locally cached zone in this write context, see if
> * the inode is still associated with a zone and use that if so.
> --
> 2.53.0
>
>
next prev parent reply other threads:[~2026-09-09 16:06 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-09 6:08 lazy bounce buffering for checksummed reads v3 Christoph Hellwig
2026-09-09 6:08 ` [PATCH 01/16] block: split bio_iov_iter_bounce_write Christoph Hellwig
2026-09-11 16:41 ` Jens Axboe
2026-09-09 6:08 ` [PATCH 02/16] block: export fs_bio_integrity_{alloc,free} Christoph Hellwig
2026-09-09 6:08 ` [PATCH 03/16] block: add a bio_prepare_reissue helper Christoph Hellwig
2026-09-09 16:05 ` Darrick J. Wong
2026-09-09 6:08 ` [PATCH 04/16] iomap: respect maximum I/O size in iomap_dio_bio_iter_one Christoph Hellwig
2026-09-09 6:08 ` [PATCH 05/16] iomap: add a iomap_ioend_flags helper Christoph Hellwig
2026-09-09 6:08 ` [PATCH 06/16] iomap: add a IOMAP_IOEND_INTEGRITY flag Christoph Hellwig
2026-09-09 6:08 ` [PATCH 07/16] iomap,xfs: move T10 PI handling for direct I/O into ->submit_io Christoph Hellwig
2026-09-09 6:08 ` [PATCH 08/16] xfs: move PI generation into xfs_submit_zoned_bio Christoph Hellwig
2026-09-09 16:06 ` Darrick J. Wong [this message]
2026-09-09 6:08 ` [PATCH 09/16] block,iomap: fix protection information verification with initial bvec offset Christoph Hellwig
2026-09-09 6:08 ` [PATCH 10/16] iomap: better read bounce buffering support Christoph Hellwig
2026-09-09 6:09 ` [PATCH 11/16] xfs: use BIO_COMPLETE_IN_TASK for bounce buffered read I/Os Christoph Hellwig
2026-09-09 6:09 ` [PATCH 12/16] iomap,xfs: move integrity verification to the file system Christoph Hellwig
2026-09-09 6:09 ` [PATCH 13/16] xfs: add support for lazy direct read bounce buffering Christoph Hellwig
2026-09-09 6:09 ` [PATCH 14/16] xfs: add error injection for lazy " Christoph Hellwig
2026-09-09 6:09 ` [PATCH 15/16] xfs: log a message at mount time when using integrity protection Christoph Hellwig
2026-09-09 6:09 ` [PATCH 16/16] block,iomap: remove the old read side bounce buffering support Christoph Hellwig
2026-09-09 16:15 ` Darrick J. Wong
2026-09-10 20:50 ` lazy bounce buffering for checksummed reads v3 Jens Axboe
2026-09-10 20:51 ` Jens Axboe
2026-09-11 11:44 ` Christoph Hellwig
2026-09-11 13:38 ` Jens Axboe
2026-09-11 3:57 ` Anuj gupta
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260909160619.GJ2619314@frogsfrogsfrogs \
--to=djwong@kernel.org \
--cc=anuj20.g@samsung.com \
--cc=axboe@kernel.dk \
--cc=brauner@kernel.org \
--cc=cem@kernel.org \
--cc=hch@lst.de \
--cc=linux-block@vger.kernel.org \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-xfs@vger.kernel.org \
--cc=tz2294@columbia.edu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox