From: Hannes Reinecke <hare@suse.de>
To: Bart Van Assche <bart.vanassche@wdc.com>, Jens Axboe <axboe@kernel.dk>
Cc: linux-block@vger.kernel.org, linux-scsi@vger.kernel.org,
Christoph Hellwig <hch@lst.de>,
"Martin K . Petersen" <martin.petersen@oracle.com>,
Oleksandr Natalenko <oleksandr@natalenko.name>,
Ming Lei <ming.lei@redhat.com>,
linux-raid@vger.kernel.org, Hannes Reinecke <hare@suse.com>
Subject: Re: [PATCH v9 01/10] md: Rename md_notifier into md_reboot_notifier
Date: Tue, 17 Oct 2017 08:23:09 +0200 [thread overview]
Message-ID: <60b26c61-555a-d715-6d93-b3be620e3fca@suse.de> (raw)
In-Reply-To: <20171016232905.5047-2-bart.vanassche@wdc.com>
On 10/17/2017 01:28 AM, Bart Van Assche wrote:
> This avoids confusion with the pm notifier that will be added
> through a later patch.
>
> Signed-off-by: Bart Van Assche <bart.vanassche@wdc.com>
> Reviewed-by: Johannes Thumshirn <jthumshirn@suse.de>
> Reviewed-by: Shaohua Li <shli@kernel.org>
> Tested-by: Martin Steigerwald <martin@lichtvoll.de>
> Cc: linux-raid@vger.kernel.org
> Cc: Ming Lei <ming.lei@redhat.com>
> Cc: Christoph Hellwig <hch@lst.de>
> Cc: Hannes Reinecke <hare@suse.com>
> ---
> drivers/md/md.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/md/md.c b/drivers/md/md.c
> index 5d61049e7417..8933cafc212d 100644
> --- a/drivers/md/md.c
> +++ b/drivers/md/md.c
> @@ -8966,7 +8966,7 @@ static int md_notify_reboot(struct notifier_block *this,
> return NOTIFY_DONE;
> }
>
> -static struct notifier_block md_notifier = {
> +static struct notifier_block md_reboot_notifier = {
> .notifier_call = md_notify_reboot,
> .next = NULL,
> .priority = INT_MAX, /* before any real devices */
> @@ -9003,7 +9003,7 @@ static int __init md_init(void)
> blk_register_region(MKDEV(mdp_major, 0), 1UL<<MINORBITS, THIS_MODULE,
> md_probe, NULL, NULL);
>
> - register_reboot_notifier(&md_notifier);
> + register_reboot_notifier(&md_reboot_notifier);
> raid_table_header = register_sysctl_table(raid_root_table);
>
> md_geninit();
> @@ -9243,7 +9243,7 @@ static __exit void md_exit(void)
>
> unregister_blkdev(MD_MAJOR,"md");
> unregister_blkdev(mdp_major, "mdp");
> - unregister_reboot_notifier(&md_notifier);
> + unregister_reboot_notifier(&md_reboot_notifier);
> unregister_sysctl_table(raid_table_header);
>
> /* We cannot unload the modules while some process is
>
Reviewed-by: Hannes Reinecke <hare@suse.com>
Cheers,
Hannes
--
Dr. Hannes Reinecke Teamlead Storage & Networking
hare@suse.de +49 911 74053 688
SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nürnberg
GF: F. Imendörffer, J. Smithard, J. Guild, D. Upmanyu, G. Norton
HRB 21284 (AG Nürnberg)
next prev parent reply other threads:[~2017-10-17 6:23 UTC|newest]
Thread overview: 28+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-10-16 23:28 [PATCH v9 00/10] block, scsi, md: Improve suspend and resume Bart Van Assche
2017-10-16 23:28 ` [PATCH v9 01/10] md: Rename md_notifier into md_reboot_notifier Bart Van Assche
2017-10-17 6:23 ` Hannes Reinecke [this message]
2017-10-16 23:28 ` [PATCH v9 02/10] md: Introduce md_stop_all_writes() Bart Van Assche
2017-10-17 6:23 ` Hannes Reinecke
2017-10-16 23:28 ` [PATCH v9 03/10] md: Neither resync nor reshape while the system is frozen Bart Van Assche
2017-10-17 6:24 ` Hannes Reinecke
2017-10-16 23:28 ` [PATCH v9 04/10] block: Make q_usage_counter also track legacy requests Bart Van Assche
2017-10-17 6:25 ` Hannes Reinecke
2017-10-16 23:29 ` [PATCH v9 05/10] block: Introduce blk_get_request_flags() Bart Van Assche
2017-10-17 6:26 ` Hannes Reinecke
2017-10-16 23:29 ` [PATCH v9 06/10] block: Introduce BLK_MQ_REQ_PREEMPT Bart Van Assche
2017-10-17 6:26 ` Hannes Reinecke
2017-10-16 23:29 ` [PATCH v9 07/10] ide, scsi: Tell the block layer at request allocation time about preempt requests Bart Van Assche
2017-10-17 4:12 ` Martin K. Petersen
2017-10-17 6:27 ` Hannes Reinecke
2017-10-16 23:29 ` [PATCH v9 08/10] block: Add the QUEUE_FLAG_PREEMPT_ONLY request queue flag Bart Van Assche
2017-10-17 6:27 ` Hannes Reinecke
2017-10-16 23:29 ` [PATCH v9 09/10] block, scsi: Make SCSI quiesce and resume work reliably Bart Van Assche
2017-10-17 0:43 ` Ming Lei
2017-10-17 20:08 ` Bart Van Assche
2017-10-17 4:17 ` Martin K. Petersen
2017-10-17 6:33 ` Hannes Reinecke
2017-10-17 10:43 ` Ming Lei
2017-10-17 20:18 ` Bart Van Assche
2017-10-18 5:58 ` Hannes Reinecke
2017-10-16 23:29 ` [PATCH v9 10/10] block, nvme: Introduce blk_mq_req_flags_t Bart Van Assche
2017-10-17 6:34 ` Hannes Reinecke
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=60b26c61-555a-d715-6d93-b3be620e3fca@suse.de \
--to=hare@suse.de \
--cc=axboe@kernel.dk \
--cc=bart.vanassche@wdc.com \
--cc=hare@suse.com \
--cc=hch@lst.de \
--cc=linux-block@vger.kernel.org \
--cc=linux-raid@vger.kernel.org \
--cc=linux-scsi@vger.kernel.org \
--cc=martin.petersen@oracle.com \
--cc=ming.lei@redhat.com \
--cc=oleksandr@natalenko.name \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox