Linux block layer
 help / color / mirror / Atom feed
From: Jens Axboe <axboe@kernel.dk>
To: Bart Van Assche <bvanassche@acm.org>
Cc: linux-block@vger.kernel.org, Christoph Hellwig <hch@lst.de>,
	Daniel Wagner <dwagner@suse.de>,
	Dongli Zhang <dongli.zhang@oracle.com>,
	Damien Le Moal <damien.lemoal@wdc.com>,
	Johannes Thumshirn <johannes.thumshirn@wdc.com>,
	Chaitanya Kulkarni <chaitanya.kulkarni@wdc.com>
Subject: Re: [PATCH] null_blk: Move the null_blk source files into a subdirectory
Date: Sun, 21 Jun 2020 21:03:09 -0600	[thread overview]
Message-ID: <7d33a3a0-bc04-48e0-3e68-c792920823f7@kernel.dk> (raw)
In-Reply-To: <20200621204257.16006-1-bvanassche@acm.org>

On 6/21/20 2:42 PM, Bart Van Assche wrote:
> Since the number of source files of the null_blk driver keeps growing,
> move these source files into a new subdirectory.
> 
> Cc: Christoph Hellwig <hch@lst.de>
> Cc: Daniel Wagner <dwagner@suse.de>
> Cc: Dongli Zhang <dongli.zhang@oracle.com>
> Cc: Damien Le Moal <damien.lemoal@wdc.com>
> Cc: Johannes Thumshirn <johannes.thumshirn@wdc.com>
> Cc: Chaitanya Kulkarni <chaitanya.kulkarni@wdc.com>
> Signed-off-by: Bart Van Assche <bvanassche@acm.org>
> ---
>  drivers/block/Kconfig                         | 8 +-------
>  drivers/block/Makefile                        | 7 +------
>  drivers/block/null_blk/Kconfig                | 9 +++++++++
>  drivers/block/null_blk/Makefile               | 8 ++++++++
>  drivers/block/{ => null_blk}/null_blk.h       | 0
>  drivers/block/{ => null_blk}/null_blk_main.c  | 0
>  drivers/block/{ => null_blk}/null_blk_trace.c | 0
>  drivers/block/{ => null_blk}/null_blk_trace.h | 0
>  drivers/block/{ => null_blk}/null_blk_zoned.c | 0
>  9 files changed, 19 insertions(+), 13 deletions(-)
>  create mode 100644 drivers/block/null_blk/Kconfig
>  create mode 100644 drivers/block/null_blk/Makefile
>  rename drivers/block/{ => null_blk}/null_blk.h (100%)
>  rename drivers/block/{ => null_blk}/null_blk_main.c (100%)
>  rename drivers/block/{ => null_blk}/null_blk_trace.c (100%)
>  rename drivers/block/{ => null_blk}/null_blk_trace.h (100%)
>  rename drivers/block/{ => null_blk}/null_blk_zoned.c (100%)

I'm all for this since, but why not name them null_blk/main.c etc?  A
bit annoying/redundant to have them be drivers/block/null_blk/null_main.c
and so forth.

Probably have null_blk.h be the exception.

-- 
Jens Axboe


  parent reply	other threads:[~2020-06-22  3:03 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-06-21 20:42 [PATCH] null_blk: Move the null_blk source files into a subdirectory Bart Van Assche
2020-06-21 23:57 ` Damien Le Moal
2020-06-22  3:03 ` Jens Axboe [this message]
2020-06-22  7:03 ` Johannes Thumshirn

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=7d33a3a0-bc04-48e0-3e68-c792920823f7@kernel.dk \
    --to=axboe@kernel.dk \
    --cc=bvanassche@acm.org \
    --cc=chaitanya.kulkarni@wdc.com \
    --cc=damien.lemoal@wdc.com \
    --cc=dongli.zhang@oracle.com \
    --cc=dwagner@suse.de \
    --cc=hch@lst.de \
    --cc=johannes.thumshirn@wdc.com \
    --cc=linux-block@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox