From: Niklas Cassel <Niklas.Cassel@wdc.com>
To: Damien Le Moal <dlemoal@kernel.org>
Cc: Bart Van Assche <bvanassche@acm.org>,
Jens Axboe <axboe@kernel.dk>,
"linux-block@vger.kernel.org" <linux-block@vger.kernel.org>,
"linux-scsi@vger.kernel.org" <linux-scsi@vger.kernel.org>,
"linux-fsdevel@vger.kernel.org" <linux-fsdevel@vger.kernel.org>,
"Martin K . Petersen" <martin.petersen@oracle.com>,
Christoph Hellwig <hch@lst.de>, Avri Altman <Avri.Altman@wdc.com>,
Bean Huo <huobean@gmail.com>,
Daejun Park <daejun7.park@samsung.com>,
Hannes Reinecke <hare@suse.de>
Subject: Re: [PATCH v2 03/15] block: Support data lifetime in the I/O priority bitfield
Date: Fri, 6 Oct 2023 09:53:39 +0000 [thread overview]
Message-ID: <ZR/ZH7hKcc56jg4L@x1-carbon> (raw)
In-Reply-To: <8aec03bb-4cef-9423-0ce4-c10d060afce4@kernel.org>
On Fri, Oct 06, 2023 at 05:19:52PM +0900, Damien Le Moal wrote:
> On 10/6/23 04:40, Bart Van Assche wrote:
> > The NVMe and SCSI standards define 64 different data lifetimes. Support
> > storing this information in the I/O priority bitfield.
> >
> > The current allocation of the 16 bits in the I/O priority bitfield is as
> > follows:
> > * 15..13: I/O priority class
> > * 12..6: unused
> > * 5..3: I/O hint (CDL)
> > * 2..0: I/O priority level
> >
> > This patch changes this into the following:
> > * 15..13: I/O priority class
> > * 12: unused
> > * 11..6: data lifetime
> > * 5..3: I/O hint (CDL)
> > * 2..0: I/O priority level
> >
> > Cc: Damien Le Moal <dlemoal@kernel.org>
> > Cc: Niklas Cassel <niklas.cassel@wdc.com>
> > Signed-off-by: Bart Van Assche <bvanassche@acm.org>
> > ---
> > include/uapi/linux/ioprio.h | 8 +++++++-
> > 1 file changed, 7 insertions(+), 1 deletion(-)
> >
> > diff --git a/include/uapi/linux/ioprio.h b/include/uapi/linux/ioprio.h
> > index bee2bdb0eedb..efe9bc450872 100644
> > --- a/include/uapi/linux/ioprio.h
> > +++ b/include/uapi/linux/ioprio.h
> > @@ -71,7 +71,7 @@ enum {
> > * class and level.
> > */
> > #define IOPRIO_HINT_SHIFT IOPRIO_LEVEL_NR_BITS
> > -#define IOPRIO_HINT_NR_BITS 10
> > +#define IOPRIO_HINT_NR_BITS 3
Can we really redefine this?
This is defined to 10 in released kernels, e.g. kernel v6.5.
Perhaps a better option would be to keep this defined to 10,
and then add new macros that define "specific" IO prio hint "classes".
something like
IOPRIO_HINT_NR_BITS 10
IOPRIO_HINT_CDL
IOPRIO_HINT_CDL_NR_BITS
IOPRIO_HINT_LIFETIME
IOPRIO_HINT_LIFETIME_NR_BITS
lifetime is really a hint, so I think it makes sense for it to be part of
the "IOPRIO_HINT bits".
> > #define IOPRIO_NR_HINTS (1 << IOPRIO_HINT_NR_BITS)
> > #define IOPRIO_HINT_MASK (IOPRIO_NR_HINTS - 1)
> > #define IOPRIO_PRIO_HINT(ioprio) \
> > @@ -102,6 +102,12 @@ enum {
> > IOPRIO_HINT_DEV_DURATION_LIMIT_7 = 7,
> > };
> >
> > +#define IOPRIO_LIFETIME_SHIFT (IOPRIO_HINT_SHIFT + IOPRIO_HINT_NR_BITS)
> > +#define IOPRIO_LIFETIME_NR_BITS 6
> > +#define IOPRIO_LIFETIME_MASK ((1u << IOPRIO_LIFETIME_NR_BITS) - 1)
> > +#define IOPRIO_PRIO_LIFETIME(ioprio) \
> > + ((ioprio >> IOPRIO_LIFETIME_SHIFT) & IOPRIO_LIFETIME_MASK)
> > +
> > #define IOPRIO_BAD_VALUE(val, max) ((val) < 0 || (val) >= (max))
>
> I am really not a fan of this. This essentially limits prio hints to CDL, while
> the initial intent was to define the hints as something generic that depend on
> the device features. With your change, we will not be able to support new
> features in the future.
>
> Your change seem to assume that it makes sense to be able to combine CDL with
> lifetime hints. But does it really ? CDL is of dubious value for solid state
> media and as far as I know, UFS world has not expressed interest. Conversely,
> data lifetime hints do not make much sense for spin rust media where CDL is
> important. So I would say that the combination of CDL and lifetime hints is of
> dubious value.
>
> Given this, why not simply define the 64 possible lifetime values as plain hint
> values (8 to 71, following 1 to 7 for CDL) ?
>
> The other question here if you really want to keep the bit separation approach
> is: do we really need up to 64 different lifetime hints ? While the scsi
> standard allows that much, does this many different lifetime make sense in
> practice ? Can we ever think of a usecase that needs more than say 8 different
> liftimes (3 bits) ? If you limit the number of possible lifetime hints to 8,
> then we can keep 4 bits unused in the hint field for future features.
I think the question is: do we ever want to allow ioprio hints to be combined
or not?
If the answer is no, then go ahead and add the life time hints as values
8 to 71.
If the answer is yes, then life time hints need to use unique bits, even if it
might not make sense for CDL and life times to be combined.
Kind regards,
Niklas
next prev parent reply other threads:[~2023-10-06 9:53 UTC|newest]
Thread overview: 45+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-10-05 19:40 [PATCH v2 00/15] Pass data temperature information to UFS devices Bart Van Assche
2023-10-05 19:40 ` [PATCH v2 01/15] block: Make bio_set_ioprio() modify fewer bio->bi_ioprio bits Bart Van Assche
2023-10-06 6:28 ` Kanchan Joshi
2023-10-06 18:20 ` Bart Van Assche
2023-10-10 5:22 ` Kanchan Joshi
2023-10-11 16:52 ` Bart Van Assche
2023-10-12 8:49 ` Kanchan Joshi
2023-10-12 14:03 ` Niklas Cassel
2023-10-12 17:42 ` Bart Van Assche
2023-10-05 19:40 ` [PATCH v2 02/15] blk-ioprio: Modify " Bart Van Assche
2023-10-06 6:36 ` Kanchan Joshi
2023-10-06 18:25 ` Bart Van Assche
2023-10-05 19:40 ` [PATCH v2 03/15] block: Support data lifetime in the I/O priority bitfield Bart Van Assche
2023-10-06 6:42 ` Kanchan Joshi
2023-10-06 8:19 ` Damien Le Moal
2023-10-06 9:53 ` Niklas Cassel [this message]
2023-10-06 18:07 ` Bart Van Assche
2023-10-11 20:51 ` Bart Van Assche
2023-10-12 1:02 ` Damien Le Moal
2023-10-12 18:00 ` Bart Van Assche
2023-10-13 1:08 ` Damien Le Moal
2023-10-13 9:33 ` Niklas Cassel
2023-10-13 21:20 ` Bart Van Assche
2023-10-16 9:20 ` Niklas Cassel
2023-10-16 16:36 ` Bart Van Assche
2023-10-13 20:18 ` Bart Van Assche
2023-10-15 22:22 ` Damien Le Moal
2023-10-16 16:31 ` Bart Van Assche
2023-10-16 6:17 ` Christoph Hellwig
2023-10-16 16:32 ` Bart Van Assche
2023-10-05 19:40 ` [PATCH v2 04/15] fs: Restore write hint support Bart Van Assche
2023-10-10 5:42 ` Kanchan Joshi
2023-10-11 16:56 ` Bart Van Assche
2023-10-16 6:20 ` Christoph Hellwig
2023-10-05 19:40 ` [PATCH v2 05/15] fs/f2fs: Restore the whint_mode mount option Bart Van Assche
2023-10-05 19:40 ` [PATCH v2 06/15] scsi: core: Query the Block Limits Extension VPD page Bart Van Assche
2023-10-05 19:40 ` [PATCH v2 07/15] scsi_proto: Add structures and constants related to I/O groups and streams Bart Van Assche
2023-10-05 19:40 ` [PATCH v2 08/15] sd: Translate data lifetime information Bart Van Assche
2023-10-05 19:40 ` [PATCH v2 09/15] scsi_debug: Reduce code duplication Bart Van Assche
2023-10-05 19:40 ` [PATCH v2 10/15] scsi_debug: Support the block limits extension VPD page Bart Van Assche
2023-10-05 19:40 ` [PATCH v2 11/15] scsi_debug: Rework page code error handling Bart Van Assche
2023-10-05 19:40 ` [PATCH v2 12/15] scsi_debug: Rework subpage " Bart Van Assche
2023-10-05 19:40 ` [PATCH v2 13/15] scsi_debug: Implement the IO Advice Hints Grouping mode page Bart Van Assche
2023-10-05 19:41 ` [PATCH v2 14/15] scsi_debug: Implement GET STREAM STATUS Bart Van Assche
2023-10-05 19:41 ` [PATCH v2 15/15] scsi_debug: Maintain write statistics per group number Bart Van Assche
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ZR/ZH7hKcc56jg4L@x1-carbon \
--to=niklas.cassel@wdc.com \
--cc=Avri.Altman@wdc.com \
--cc=axboe@kernel.dk \
--cc=bvanassche@acm.org \
--cc=daejun7.park@samsung.com \
--cc=dlemoal@kernel.org \
--cc=hare@suse.de \
--cc=hch@lst.de \
--cc=huobean@gmail.com \
--cc=linux-block@vger.kernel.org \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-scsi@vger.kernel.org \
--cc=martin.petersen@oracle.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox