Linux bluetooth development
 help / color / mirror / Atom feed
From: Szymon Janc <szymon.janc@tieto.com>
To: Anderson Lizardo <anderson.lizardo@openbossa.org>
Cc: "linux-bluetooth@vger.kernel.org" <linux-bluetooth@vger.kernel.org>
Subject: Re: [PATCH 16/16] avctp: Remove double looking for audio device
Date: Wed, 12 Dec 2012 14:24:17 +0100	[thread overview]
Message-ID: <12216041.cC5xxHztGE@uw000953> (raw)
In-Reply-To: <CAJdJm_PqVbJTQKuqor7-2Dz+gRKTu+Bca7mSMW8PsFj8qW6itw@mail.gmail.com>

On Wednesday 12 of December 2012 15:19:44 Anderson Lizardo wrote:
> Hi Szymon,

Hi Anderson,

> 
> On Wed, Dec 12, 2012 at 6:28 AM, Szymon Janc <szymon.janc@tieto.com> wrote:
> > There is no need to double call for manager_get_audio_device with
> > toggled create flag. manager_get_audio_device with create set to true
> > will only create new audio device if matching one was not found.
> 
> What's the difference between "manager_get_audio_device(device,
> FALSE)" and "manager_find_device(device)" ? Also, would be better to
> rename manager_find_device() to manager_find_audio_device()?

No difference, please see patch 13/16, manager_find_device{s} are made
static there.


-- 
BR
Szymon Janc

  reply	other threads:[~2012-12-12 13:24 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-12-12 10:27 [PATCH 00/16] audio: Use device/adapter reference instead of bdaddr_t Szymon Janc
2012-12-12 10:27 ` [PATCH 01/16] a2dp: Remove bogus '\' at the end of line Szymon Janc
2012-12-12 10:27 ` [PATCH 02/16] a2dp: Remove useless return Szymon Janc
2012-12-12 10:27 ` [PATCH 03/16] a2dp: Remove not used macros definitions Szymon Janc
2012-12-12 10:27 ` [PATCH 04/16] a2dp: Convert sink/source register to accept btd_adapter Szymon Janc
2012-12-12 10:27 ` [PATCH 05/16] a2dp: Convert a2dp_unregister " Szymon Janc
2012-12-12 10:27 ` [PATCH 06/16] media: Convert register/unregister " Szymon Janc
2012-12-12 10:27 ` [PATCH 07/16] a2dp: Convert a2dp_add_sep to accept struct btd_adapter Szymon Janc
2012-12-12 10:28 ` [PATCH 08/16] avdtp: Use refs to adapter and device instead of bdaddr_t Szymon Janc
2012-12-12 10:28 ` [PATCH 09/16] a2dp: Use btd_adapter ref in a2dp_server " Szymon Janc
2012-12-12 10:28 ` [PATCH 10/16] avrcp: Convert to accept btd_adapter " Szymon Janc
2012-12-12 10:28 ` [PATCH 11/16] avctp: Convert register/unregister to accept btd_adapter Szymon Janc
2012-12-12 12:52   ` Anderson Lizardo
2012-12-12 12:55     ` Anderson Lizardo
2012-12-12 13:03       ` Anderson Lizardo
2012-12-12 13:05         ` Szymon Janc
2012-12-12 10:28 ` [PATCH 12/16] avdtp: Replace avdtp_get_peers with adapter and device getters Szymon Janc
2012-12-12 10:28 ` [PATCH 13/16] audio: Use manager_get_device to get device object Szymon Janc
2012-12-12 10:28 ` [PATCH 14/16] audio: Make manager_get_device accept btd_device Szymon Janc
2012-12-12 10:28 ` [PATCH 15/16] audio: Simplify manager_find_device Szymon Janc
2012-12-12 10:28 ` [PATCH 16/16] avctp: Remove double looking for audio device Szymon Janc
2012-12-12 13:19   ` Anderson Lizardo
2012-12-12 13:24     ` Szymon Janc [this message]
2012-12-19 12:16 ` [PATCH 00/16] audio: Use device/adapter reference instead of bdaddr_t Luiz Augusto von Dentz

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=12216041.cC5xxHztGE@uw000953 \
    --to=szymon.janc@tieto.com \
    --cc=anderson.lizardo@openbossa.org \
    --cc=linux-bluetooth@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox